aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/device-mapper/device-mapper-1.01.05/remove_insanity.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/device-mapper/device-mapper-1.01.05/remove_insanity.patch')
-rw-r--r--recipes/device-mapper/device-mapper-1.01.05/remove_insanity.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/device-mapper/device-mapper-1.01.05/remove_insanity.patch b/recipes/device-mapper/device-mapper-1.01.05/remove_insanity.patch
new file mode 100644
index 0000000000..1bc846e625
--- /dev/null
+++ b/recipes/device-mapper/device-mapper-1.01.05/remove_insanity.patch
@@ -0,0 +1,33 @@
+Index: device-mapper.1.01.05/dmsetup/Makefile.in
+===================================================================
+--- device-mapper.1.01.05.orig/dmsetup/Makefile.in 2008-03-26 09:17:23.000000000 +0000
++++ device-mapper.1.01.05/dmsetup/Makefile.in 2008-03-26 09:18:01.000000000 +0000
+@@ -31,11 +31,11 @@
+
+ dmsetup: $(OBJECTS) $(interfacedir)/libdevmapper.$(LIB_SUFFIX)
+ $(CC) -o $@ $(OBJECTS) $(LDFLAGS) \
+- -L$(interfacedir) -L$(DESTDIR)/lib -ldevmapper $(LIBS)
++ -L$(interfacedir) -ldevmapper $(LIBS)
+
+ dmsetup.static: $(OBJECTS) $(interfacedir)/libdevmapper.a
+ $(CC) -o $@ $(OBJECTS) $(LDFLAGS) -static \
+- -L$(interfacedir) -L$(DESTDIR)/lib -ldevmapper $(LIBS)
++ -L$(interfacedir) -ldevmapper $(LIBS)
+
+ install: $(INSTALL_TYPE)
+
+Index: device-mapper.1.01.05/make.tmpl.in
+===================================================================
+--- device-mapper.1.01.05.orig/make.tmpl.in 2008-03-26 09:18:44.000000000 +0000
++++ device-mapper.1.01.05/make.tmpl.in 2008-03-26 09:19:10.000000000 +0000
+@@ -91,10 +91,6 @@
+
+ INCLUDES += -I. -I$(top_srcdir)/include
+
+-ifdef DESTDIR
+- INCLUDES += -I$(DESTDIR)/usr/include
+-endif
+-
+ ifneq ("@missingkernel@", "yes")
+ INCLUDES += -I$(kerneldir)/include
+ endif