aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/device-mapper/device-mapper-1.01.05
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/device-mapper/device-mapper-1.01.05')
-rw-r--r--recipes/device-mapper/device-mapper-1.01.05/devmap-mknod-busybox.patch9
-rw-r--r--recipes/device-mapper/device-mapper-1.01.05/remove_insanity.patch33
2 files changed, 42 insertions, 0 deletions
diff --git a/recipes/device-mapper/device-mapper-1.01.05/devmap-mknod-busybox.patch b/recipes/device-mapper/device-mapper-1.01.05/devmap-mknod-busybox.patch
new file mode 100644
index 0000000000..8b24f143dd
--- /dev/null
+++ b/recipes/device-mapper/device-mapper-1.01.05/devmap-mknod-busybox.patch
@@ -0,0 +1,9 @@
+--- device-mapper.1.01.05/scripts/devmap_mknod.sh 2002-07-23 05:50:13.000000000 -0700
++++ device-mapper.1.01.05/scripts/devmap_mknod.sh~ 2005-08-25 14:51:13.000000000 -0700
+@@ -37,5 +37,5 @@
+ test -e $CONTROL && rm -f $CONTROL
+
+ echo "Creating $CONTROL character device with major:$MAJOR minor:$MINOR."
+-mknod --mode=600 $CONTROL c $MAJOR $MINOR
++mknod -m 600 $CONTROL c $MAJOR $MINOR
+
diff --git a/recipes/device-mapper/device-mapper-1.01.05/remove_insanity.patch b/recipes/device-mapper/device-mapper-1.01.05/remove_insanity.patch
new file mode 100644
index 0000000000..1bc846e625
--- /dev/null
+++ b/recipes/device-mapper/device-mapper-1.01.05/remove_insanity.patch
@@ -0,0 +1,33 @@
+Index: device-mapper.1.01.05/dmsetup/Makefile.in
+===================================================================
+--- device-mapper.1.01.05.orig/dmsetup/Makefile.in 2008-03-26 09:17:23.000000000 +0000
++++ device-mapper.1.01.05/dmsetup/Makefile.in 2008-03-26 09:18:01.000000000 +0000
+@@ -31,11 +31,11 @@
+
+ dmsetup: $(OBJECTS) $(interfacedir)/libdevmapper.$(LIB_SUFFIX)
+ $(CC) -o $@ $(OBJECTS) $(LDFLAGS) \
+- -L$(interfacedir) -L$(DESTDIR)/lib -ldevmapper $(LIBS)
++ -L$(interfacedir) -ldevmapper $(LIBS)
+
+ dmsetup.static: $(OBJECTS) $(interfacedir)/libdevmapper.a
+ $(CC) -o $@ $(OBJECTS) $(LDFLAGS) -static \
+- -L$(interfacedir) -L$(DESTDIR)/lib -ldevmapper $(LIBS)
++ -L$(interfacedir) -ldevmapper $(LIBS)
+
+ install: $(INSTALL_TYPE)
+
+Index: device-mapper.1.01.05/make.tmpl.in
+===================================================================
+--- device-mapper.1.01.05.orig/make.tmpl.in 2008-03-26 09:18:44.000000000 +0000
++++ device-mapper.1.01.05/make.tmpl.in 2008-03-26 09:19:10.000000000 +0000
+@@ -91,10 +91,6 @@
+
+ INCLUDES += -I. -I$(top_srcdir)/include
+
+-ifdef DESTDIR
+- INCLUDES += -I$(DESTDIR)/usr/include
+-endif
+-
+ ifneq ("@missingkernel@", "yes")
+ INCLUDES += -I$(kerneldir)/include
+ endif