aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/devio
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/devio')
-rw-r--r--recipes/devio/devio-cvs.inc16
-rw-r--r--recipes/devio/devio-native.inc5
-rw-r--r--recipes/devio/devio-native_1.0.bb3
-rw-r--r--recipes/devio/devio-native_1.1.bb3
-rw-r--r--recipes/devio/devio-native_1.2.bb3
-rw-r--r--recipes/devio/devio-native_cvs.bb3
-rw-r--r--recipes/devio/devio-native_r1.bb3
-rw-r--r--recipes/devio/devio-native_r2.bb3
-rw-r--r--recipes/devio/devio-sdk.inc5
-rw-r--r--recipes/devio/devio-sdk_1.2.bb3
-rw-r--r--recipes/devio/devio.inc22
-rw-r--r--recipes/devio/devio_1.0.bb1
-rw-r--r--recipes/devio/devio_1.1.bb1
-rw-r--r--recipes/devio/devio_1.2.bb1
-rw-r--r--recipes/devio/devio_cvs.bb2
-rw-r--r--recipes/devio/devio_r1.bb1
-rw-r--r--recipes/devio/devio_r2.bb1
17 files changed, 76 insertions, 0 deletions
diff --git a/recipes/devio/devio-cvs.inc b/recipes/devio/devio-cvs.inc
new file mode 100644
index 0000000000..0469a4962e
--- /dev/null
+++ b/recipes/devio/devio-cvs.inc
@@ -0,0 +1,16 @@
+# CVS based releases, disfavour these
+DEFAULT_PREFERENCE = "-1"
+
+include devio.inc
+
+# this is a CVS only release
+CVS_TAG ?= ";tag=${PV}"
+SRC_URI = "cvs://anonymous@devio.cvs.sourceforge.net/cvsroot/devio;method=pserver;module=devio${CVS_TAG}"
+
+# This accesses the head version, anonymous pserver access is
+# only updated once per day (and it is necessary to change
+# 'jbowler' to the name of a developer with ssh access.)
+#SRC_URI = "cvs://jbowler@devio.cvs.sourceforge.net/cvsroot/devio;method=ext;rsh=ssh;tag=HEAD;module=devio"
+
+# The source will end up in the subdirectory 'devio' - no release name
+S = "${WORKDIR}/devio"
diff --git a/recipes/devio/devio-native.inc b/recipes/devio/devio-native.inc
new file mode 100644
index 0000000000..49987e6f0a
--- /dev/null
+++ b/recipes/devio/devio-native.inc
@@ -0,0 +1,5 @@
+# Set the installation dir back to the default
+sbindir = "${exec_prefix}/sbin"
+bindir = "${exec_prefix}/bin"
+
+inherit native
diff --git a/recipes/devio/devio-native_1.0.bb b/recipes/devio/devio-native_1.0.bb
new file mode 100644
index 0000000000..6e214379eb
--- /dev/null
+++ b/recipes/devio/devio-native_1.0.bb
@@ -0,0 +1,3 @@
+# This package builds the devio program for the build architecture
+require devio_1.0.bb
+require devio-native.inc
diff --git a/recipes/devio/devio-native_1.1.bb b/recipes/devio/devio-native_1.1.bb
new file mode 100644
index 0000000000..c4d957b931
--- /dev/null
+++ b/recipes/devio/devio-native_1.1.bb
@@ -0,0 +1,3 @@
+# This package builds the devio program for the build architecture
+require devio_1.1.bb
+require devio-native.inc
diff --git a/recipes/devio/devio-native_1.2.bb b/recipes/devio/devio-native_1.2.bb
new file mode 100644
index 0000000000..c0040d19b2
--- /dev/null
+++ b/recipes/devio/devio-native_1.2.bb
@@ -0,0 +1,3 @@
+# This package builds the devio program for the build architecture
+require devio.inc
+require devio-native.inc
diff --git a/recipes/devio/devio-native_cvs.bb b/recipes/devio/devio-native_cvs.bb
new file mode 100644
index 0000000000..a05cc28594
--- /dev/null
+++ b/recipes/devio/devio-native_cvs.bb
@@ -0,0 +1,3 @@
+# This package builds the devio program for the build architecture
+require devio_cvs.bb
+require devio-native.inc
diff --git a/recipes/devio/devio-native_r1.bb b/recipes/devio/devio-native_r1.bb
new file mode 100644
index 0000000000..1e7b0e5504
--- /dev/null
+++ b/recipes/devio/devio-native_r1.bb
@@ -0,0 +1,3 @@
+# This package builds the devio program for the build architecture
+require devio_r1.bb
+require devio-native.inc
diff --git a/recipes/devio/devio-native_r2.bb b/recipes/devio/devio-native_r2.bb
new file mode 100644
index 0000000000..650e2299f0
--- /dev/null
+++ b/recipes/devio/devio-native_r2.bb
@@ -0,0 +1,3 @@
+# This package builds the devio program for the build architecture
+require devio_r2.bb
+require devio-native.inc
diff --git a/recipes/devio/devio-sdk.inc b/recipes/devio/devio-sdk.inc
new file mode 100644
index 0000000000..6ba6606f17
--- /dev/null
+++ b/recipes/devio/devio-sdk.inc
@@ -0,0 +1,5 @@
+# Set the installation dir back to the default
+sbindir = "${exec_prefix}/sbin"
+bindir = "${exec_prefix}/bin"
+
+inherit sdk
diff --git a/recipes/devio/devio-sdk_1.2.bb b/recipes/devio/devio-sdk_1.2.bb
new file mode 100644
index 0000000000..caf741a2ff
--- /dev/null
+++ b/recipes/devio/devio-sdk_1.2.bb
@@ -0,0 +1,3 @@
+# This package builds the devio program for the build architecture
+require devio.inc
+require devio-sdk.inc
diff --git a/recipes/devio/devio.inc b/recipes/devio/devio.inc
new file mode 100644
index 0000000000..b2d09e81f0
--- /dev/null
+++ b/recipes/devio/devio.inc
@@ -0,0 +1,22 @@
+# This package builds the devio program
+DESCRIPTION = "devio - block devio io"
+HOMEPAGE = "http://devio.sourceforge.net/"
+SECTION = "base"
+LICENSE = "MIT"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/devio/devio-${PV}.tar.gz"
+
+# Source directory
+S = "${WORKDIR}/devio-${PV}"
+
+# Just the one package at present
+
+# Set the install dir to /sbin, not /usr/sbin, because devio is used
+# during bootstrap (we want it to be posible to mount /usr separately)
+sbindir = "${base_sbindir}"
+
+# From 1.2 devio installs to bindir, not sbindir, so set that to /bin
+# for the same reason
+bindir = "${base_bindir}"
+
+inherit autotools
diff --git a/recipes/devio/devio_1.0.bb b/recipes/devio/devio_1.0.bb
new file mode 100644
index 0000000000..989fd53587
--- /dev/null
+++ b/recipes/devio/devio_1.0.bb
@@ -0,0 +1 @@
+require devio.inc
diff --git a/recipes/devio/devio_1.1.bb b/recipes/devio/devio_1.1.bb
new file mode 100644
index 0000000000..989fd53587
--- /dev/null
+++ b/recipes/devio/devio_1.1.bb
@@ -0,0 +1 @@
+require devio.inc
diff --git a/recipes/devio/devio_1.2.bb b/recipes/devio/devio_1.2.bb
new file mode 100644
index 0000000000..989fd53587
--- /dev/null
+++ b/recipes/devio/devio_1.2.bb
@@ -0,0 +1 @@
+require devio.inc
diff --git a/recipes/devio/devio_cvs.bb b/recipes/devio/devio_cvs.bb
new file mode 100644
index 0000000000..153748f347
--- /dev/null
+++ b/recipes/devio/devio_cvs.bb
@@ -0,0 +1,2 @@
+CVS_TAG = ""
+require devio-cvs.inc
diff --git a/recipes/devio/devio_r1.bb b/recipes/devio/devio_r1.bb
new file mode 100644
index 0000000000..45fb34a562
--- /dev/null
+++ b/recipes/devio/devio_r1.bb
@@ -0,0 +1 @@
+require devio-cvs.inc
diff --git a/recipes/devio/devio_r2.bb b/recipes/devio/devio_r2.bb
new file mode 100644
index 0000000000..45fb34a562
--- /dev/null
+++ b/recipes/devio/devio_r2.bb
@@ -0,0 +1 @@
+require devio-cvs.inc