aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/devmem2/devmem2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/devmem2/devmem2.bb')
-rw-r--r--recipes/devmem2/devmem2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/devmem2/devmem2.bb b/recipes/devmem2/devmem2.bb
new file mode 100644
index 0000000000..143883afea
--- /dev/null
+++ b/recipes/devmem2/devmem2.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Simple program to read/write from/to any location in memory."
+SRC_URI = "http://www.lartmaker.nl/lartware/port/devmem2.c"
+LICENSE = "GPL"
+PR = "r1"
+
+S = "${WORKDIR}"
+
+do_compile() {
+ ${CC} -o devmem2 devmem2.c ${CFLAGS} ${LDFLAGS}
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install devmem2 ${D}${bindir}
+}