aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dhcdbd/dhcdbd_1.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dhcdbd/dhcdbd_1.14.bb')
-rw-r--r--recipes/dhcdbd/dhcdbd_1.14.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/dhcdbd/dhcdbd_1.14.bb b/recipes/dhcdbd/dhcdbd_1.14.bb
new file mode 100644
index 0000000000..55d3c72899
--- /dev/null
+++ b/recipes/dhcdbd/dhcdbd_1.14.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "DBus-enabled dhcp client"
+HOMEPAGE = "http://people.redhat.com/jvdias/dhcdbd/"
+SECTION = "net"
+LICENSE = "GPL"
+DEPENDS = "dbus"
+
+PR = "r1"
+
+SRC_URI = "https://fedorahosted.org/releases/d/h/dhcdbd/dhcdbd-${PV}.tar.bz2 \
+ file://dhcdbd-1.14-pkgconfig_dbus.patch;patch=1 \
+ file://dbus-api-fix.patch;patch=1 \
+ file://dhcdbd"
+
+do_compile() {
+ CC=${TARGET_SYS}-gcc DESTDIR=${prefix} make
+}
+
+do_install() {
+ DESTDIR=${D} make install
+ install -d ${D}/etc/init.d
+ install -m 0755 ${WORKDIR}/dhcdbd ${D}/etc/init.d/
+}
+
+FILES_${PN} += "${sysconfdir} ${datadir}/dbus-1 ${base_sbindir}/*"