aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/directfb/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/directfb/files')
-rw-r--r--recipes/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch47
-rw-r--r--recipes/directfb/files/dont-use-linux-config.patch12
-rw-r--r--recipes/directfb/files/fix-font-missing-char.patch11
-rw-r--r--recipes/directfb/files/fix-includes.patch24
-rw-r--r--recipes/directfb/files/fix-pkgconfig-cflags.patch45
-rw-r--r--recipes/directfb/files/fix-pkgconfig-specs.patch50
-rw-r--r--recipes/directfb/files/getpagesize.patch16
-rw-r--r--recipes/directfb/files/mkdfiff.patch11
-rw-r--r--recipes/directfb/files/ts_lib_autotools.patch16
-rw-r--r--recipes/directfb/files/use_limits_h.patch10
10 files changed, 242 insertions, 0 deletions
diff --git a/recipes/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch b/recipes/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch
new file mode 100644
index 0000000000..745c561cc0
--- /dev/null
+++ b/recipes/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch
@@ -0,0 +1,47 @@
+Index: DirectFB-1.1.1/directfb-internal.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/directfb-internal.pc.in 2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.1/directfb-internal.pc.in 2008-07-17 21:00:47.424654304 +0200
+@@ -2,10 +2,10 @@
+ exec_prefix=@exec_prefix@
+ moduledir=@MODULEDIR@
+ moduledirname=@MODULEDIRNAME@
+-includedir=@INTERNALINCLUDEDIR@
++includedir=@includedir@
+
+ Name: DirectFB-Internal
+ Description: Third party module support package for DirectFB.
+ Version: @VERSION@
+ Requires: directfb = @VERSION@
+-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
++Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir}/directfb -I${includedir}
+Index: DirectFB-1.1.1/directfb.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/directfb.pc.in 2007-12-15 16:23:16.000000000 +0100
++++ DirectFB-1.1.1/directfb.pc.in 2008-07-17 20:59:58.044985193 +0200
+@@ -9,4 +9,4 @@
+ Requires: fusion direct
+ Libs: -L${libdir} -ldirectfb @THREADLIB@ @OSX_LIBS@
+ Libs.private: -L${libdir} @DYNLIB@ @ZLIB_LIBS@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}/directfb
+Index: DirectFB-1.1.1/lib/fusion/fusion.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/lib/fusion/fusion.pc.in 2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.1/lib/fusion/fusion.pc.in 2008-07-17 20:58:07.051338866 +0200
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lfusion
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}
+Index: DirectFB-1.1.1/lib/voodoo/voodoo.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/lib/voodoo/voodoo.pc.in 2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.1/lib/voodoo/voodoo.pc.in 2008-07-17 20:58:07.054671842 +0200
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lvoodoo
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}
diff --git a/recipes/directfb/files/dont-use-linux-config.patch b/recipes/directfb/files/dont-use-linux-config.patch
new file mode 100644
index 0000000000..f971660954
--- /dev/null
+++ b/recipes/directfb/files/dont-use-linux-config.patch
@@ -0,0 +1,12 @@
+diff -urN DirectFB-1.1.0.orig/lib/direct/ppcasm_memcpy_cachable.S DirectFB-1.1.0/lib/direct/ppcasm_memcpy_cachable.S
+--- DirectFB-1.1.0.orig/lib/direct/ppcasm_memcpy_cachable.S 2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.0/lib/direct/ppcasm_memcpy_cachable.S 2008-06-07 04:14:26.000000000 +0200
+@@ -34,8 +34,6 @@
+
+ #define __ASSEMBLY__
+
+-#include <linux/config.h>
+-
+ #if defined(CONFIG_8xx) || defined(CONFIG_403GCX)
+ #define L1_CACHE_LINE_SIZE 16
+ #define LG_L1_CACHE_LINE_SIZE 4
diff --git a/recipes/directfb/files/fix-font-missing-char.patch b/recipes/directfb/files/fix-font-missing-char.patch
new file mode 100644
index 0000000000..4c5e5883f4
--- /dev/null
+++ b/recipes/directfb/files/fix-font-missing-char.patch
@@ -0,0 +1,11 @@
+--- git/src/media/idirectfbfont.c~org 2007-07-10 10:35:46.000000000 -0400
++++ git/src/media/idirectfbfont.c 2007-07-10 10:36:09.000000000 -0400
+@@ -497,7 +497,7 @@
+
+ if (width<max_width && string >= end) {
+ *ret_next_line = NULL;
+- *ret_str_length = length-1;
++ *ret_str_length = length;
+ *ret_width = width;
+
+ return DFB_OK;
diff --git a/recipes/directfb/files/fix-includes.patch b/recipes/directfb/files/fix-includes.patch
new file mode 100644
index 0000000000..7b4a112582
--- /dev/null
+++ b/recipes/directfb/files/fix-includes.patch
@@ -0,0 +1,24 @@
+#
+# pkgconfig points to STAGING_INCDIR, hence
+# we need to make this a local include
+# or else it doesn't find its own header files
+#
+# Signed-Off: mickey@openmoko.org
+#
+Index: DirectFB-1.0.0/include/directfb.h
+===================================================================
+--- DirectFB-1.0.0.orig/include/directfb.h
++++ DirectFB-1.0.0/include/directfb.h
+@@ -29,10 +29,10 @@
+ #ifndef __DIRECTFB_H__
+ #define __DIRECTFB_H__
+
+-#include <dfb_types.h>
++#include "dfb_types.h"
+ #include <sys/time.h> /* struct timeval */
+
+-#include <directfb_keyboard.h>
++#include "directfb_keyboard.h"
+
+ #ifdef __cplusplus
+ extern "C"
diff --git a/recipes/directfb/files/fix-pkgconfig-cflags.patch b/recipes/directfb/files/fix-pkgconfig-cflags.patch
new file mode 100644
index 0000000000..ddaa276fcd
--- /dev/null
+++ b/recipes/directfb/files/fix-pkgconfig-cflags.patch
@@ -0,0 +1,45 @@
+diff -ur DirectFB-1.0.0~org/directfb-internal.pc.in DirectFB-1.0.0/directfb-internal.pc.in
+--- DirectFB-1.0.0~org/directfb-internal.pc.in 2003-07-04 13:30:22.000000000 -0400
++++ DirectFB-1.0.0/directfb-internal.pc.in 2007-03-16 22:34:17.000000000 -0400
+@@ -8,4 +8,4 @@
+ Description: Third party module support package for DirectFB.
+ Version: @VERSION@
+ Requires: directfb = @VERSION@
+-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
++Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir}/directfb -I${includedir}
+diff -ur DirectFB-1.0.0~org/directfb.pc.in DirectFB-1.0.0/directfb.pc.in
+--- DirectFB-1.0.0~org/directfb.pc.in 2004-08-04 12:28:20.000000000 -0400
++++ DirectFB-1.0.0/directfb.pc.in 2007-03-16 22:31:33.000000000 -0400
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: fusion direct
+ Libs: -L${libdir} -ldirectfb @THREADLIB@ @DYNLIB@ @ZLIB_LIBS@ @OSX_LIBS@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}/directfb -I${includedir}
+diff -ur DirectFB-1.0.0~org/lib/direct/direct.pc.in DirectFB-1.0.0/lib/direct/direct.pc.in
+--- DirectFB-1.0.0~org/lib/direct/direct.pc.in 2005-11-23 09:18:59.000000000 -0500
++++ DirectFB-1.0.0/lib/direct/direct.pc.in 2007-03-16 22:32:13.000000000 -0400
+@@ -7,4 +7,4 @@
+ Description: DirectFB base development library
+ Version: @VERSION@
+ Libs: -L${libdir} -ldirect @THREADLIB@ @DYNLIB@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}/directfb -I${includedir}
+diff -ur DirectFB-1.0.0~org/lib/fusion/fusion.pc.in DirectFB-1.0.0/lib/fusion/fusion.pc.in
+--- DirectFB-1.0.0~org/lib/fusion/fusion.pc.in 2004-05-19 07:30:56.000000000 -0400
++++ DirectFB-1.0.0/lib/fusion/fusion.pc.in 2007-03-16 22:32:34.000000000 -0400
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lfusion
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}
+diff -ur DirectFB-1.0.0~org/lib/voodoo/voodoo.pc.in DirectFB-1.0.0/lib/voodoo/voodoo.pc.in
+--- DirectFB-1.0.0~org/lib/voodoo/voodoo.pc.in 2004-05-19 07:31:28.000000000 -0400
++++ DirectFB-1.0.0/lib/voodoo/voodoo.pc.in 2007-03-16 22:32:55.000000000 -0400
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lvoodoo
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}
diff --git a/recipes/directfb/files/fix-pkgconfig-specs.patch b/recipes/directfb/files/fix-pkgconfig-specs.patch
new file mode 100644
index 0000000000..c252dc1792
--- /dev/null
+++ b/recipes/directfb/files/fix-pkgconfig-specs.patch
@@ -0,0 +1,50 @@
+Index: DirectFB-1.0.0/directfb-internal.pc.in
+===================================================================
+--- DirectFB-1.0.0.orig/directfb-internal.pc.in
++++ DirectFB-1.0.0/directfb-internal.pc.in
+@@ -8,4 +8,4 @@ Name: DirectFB-Internal
+ Description: Third party module support package for DirectFB.
+ Version: @VERSION@
+ Requires: directfb = @VERSION@
+-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
++Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir} -I${includedir}/../directfb
+Index: DirectFB-1.0.0/directfb.pc.in
+===================================================================
+--- DirectFB-1.0.0.orig/directfb.pc.in
++++ DirectFB-1.0.0/directfb.pc.in
+@@ -8,4 +8,4 @@ Description: Graphics and windowing libr
+ Version: @VERSION@
+ Requires: fusion direct
+ Libs: -L${libdir} -ldirectfb @THREADLIB@ @DYNLIB@ @ZLIB_LIBS@ @OSX_LIBS@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}
+Index: DirectFB-1.0.0/lib/direct/direct.pc.in
+===================================================================
+--- DirectFB-1.0.0.orig/lib/direct/direct.pc.in
++++ DirectFB-1.0.0/lib/direct/direct.pc.in
+@@ -7,4 +7,4 @@ Name: Direct
+ Description: DirectFB base development library
+ Version: @VERSION@
+ Libs: -L${libdir} -ldirect @THREADLIB@ @DYNLIB@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}
+Index: DirectFB-1.0.0/lib/fusion/fusion.pc.in
+===================================================================
+--- DirectFB-1.0.0.orig/lib/fusion/fusion.pc.in
++++ DirectFB-1.0.0/lib/fusion/fusion.pc.in
+@@ -8,4 +8,4 @@ Description: High Level IPC Mechanisms
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lfusion
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}
+Index: DirectFB-1.0.0/lib/voodoo/voodoo.pc.in
+===================================================================
+--- DirectFB-1.0.0.orig/lib/voodoo/voodoo.pc.in
++++ DirectFB-1.0.0/lib/voodoo/voodoo.pc.in
+@@ -8,4 +8,4 @@ Description: Interface based network tra
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lvoodoo
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}
diff --git a/recipes/directfb/files/getpagesize.patch b/recipes/directfb/files/getpagesize.patch
new file mode 100644
index 0000000000..256b8db290
--- /dev/null
+++ b/recipes/directfb/files/getpagesize.patch
@@ -0,0 +1,16 @@
+diff --git a/lib/direct/system.c b/lib/direct/system.c
+index 8dd3f12..0731fa2 100644
+--- a/lib/direct/system.c
++++ b/lib/direct/system.c
+@@ -36,8 +36,9 @@
+
+ #if HAVE_ASM_PAGE_H
+ #include <asm/page.h>
+-#else
+-#define PAGE_SIZE sysconf( _SC_PAGESIZE )
++#endif
++#ifndef PAGE_SIZE
++# define PAGE_SIZE (getpagesize())
+ #endif
+
+
diff --git a/recipes/directfb/files/mkdfiff.patch b/recipes/directfb/files/mkdfiff.patch
new file mode 100644
index 0000000000..cb56fd3602
--- /dev/null
+++ b/recipes/directfb/files/mkdfiff.patch
@@ -0,0 +1,11 @@
+--- DirectFB-1.0.0-rc1~org/tools/mkdfiff.c 2006-10-12 13:45:50.000000000 -0400
++++ DirectFB-1.0.0-rc1/tools/mkdfiff.c 2006-10-12 13:57:38.000000000 -0400
+@@ -15,6 +15,8 @@
+
+ #include <dfiff.h>
+
++#include <unistd.h>
++
+ static DirectFBPixelFormatNames( format_names );
+
+ static const char *filename;
diff --git a/recipes/directfb/files/ts_lib_autotools.patch b/recipes/directfb/files/ts_lib_autotools.patch
new file mode 100644
index 0000000000..ced7104786
--- /dev/null
+++ b/recipes/directfb/files/ts_lib_autotools.patch
@@ -0,0 +1,16 @@
+Index: DirectFB-1.1.1/configure.in
+===================================================================
+--- DirectFB-1.1.1.orig/configure.in 2008-05-07 23:08:04.000000000 +0200
++++ DirectFB-1.1.1/configure.in 2008-05-07 23:15:43.000000000 +0200
+@@ -1292,8 +1292,11 @@
+
+ enable_tslib=no
+ if test "$checkfor_tslib" = "yes"; then
++ PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0.0], [enable_tslib=yes], [enable_tslib=no])
++ if test "$enable_tslib" = "no"; then
+ PKG_CHECK_MODULES([TSLIB], [tslib-0.0 >= 0.0.2], enable_tslib=yes, enable_tslib=no
+ AC_MSG_WARN([*** no tslib -- tslib driver will not be built.]))
++ fi
+ fi
+
+ enable_ucb1x00_ts=no
diff --git a/recipes/directfb/files/use_limits_h.patch b/recipes/directfb/files/use_limits_h.patch
new file mode 100644
index 0000000000..327cd7a163
--- /dev/null
+++ b/recipes/directfb/files/use_limits_h.patch
@@ -0,0 +1,10 @@
+--- FusionSound-1.0.0.orig/interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_cdda.c
++++ FusionSound-1.0.0/interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_cdda.c
+@@ -109,6 +109,7 @@ typedef struct {
+
+ #if defined(__linux__)
+
++#include <limits.h>
+ #include <linux/cdrom.h>
+
+ static DFBResult