aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/directfb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/directfb')
-rw-r--r--recipes/directfb/++dfb_1.0.0.bb20
-rw-r--r--recipes/directfb/directfb-1.1.0/fix-pkgconfig-cflags.patch57
-rw-r--r--recipes/directfb/directfb-1.1.1/fix-pkgconfig-cflags.patch47
-rw-r--r--recipes/directfb/directfb-1.2.7/ts_lib_autotools.patch22
-rw-r--r--recipes/directfb/directfb-examples_1.0.0.bb17
-rw-r--r--recipes/directfb/directfb-examples_1.2.0.bb17
-rw-r--r--recipes/directfb/directfb.inc75
-rw-r--r--recipes/directfb/directfb_1.0.0.bb7
-rw-r--r--recipes/directfb/directfb_1.1.0.bb6
-rw-r--r--recipes/directfb/directfb_1.1.1.bb27
-rw-r--r--recipes/directfb/directfb_1.2.3.bb28
-rw-r--r--recipes/directfb/directfb_1.2.7.bb28
-rw-r--r--recipes/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch47
-rw-r--r--recipes/directfb/files/dont-use-linux-config.patch12
-rw-r--r--recipes/directfb/files/fix-font-missing-char.patch11
-rw-r--r--recipes/directfb/files/fix-includes.patch24
-rw-r--r--recipes/directfb/files/fix-pkgconfig-cflags.patch45
-rw-r--r--recipes/directfb/files/fix-pkgconfig-specs.patch50
-rw-r--r--recipes/directfb/files/getpagesize.patch16
-rw-r--r--recipes/directfb/files/mkdfiff.patch11
-rw-r--r--recipes/directfb/files/ts_lib_autotools.patch16
-rw-r--r--recipes/directfb/files/use_limits_h.patch10
-rw-r--r--recipes/directfb/fusionsound-1.1.0+git20070709/fix-pkgconfig-cflags.patch23
-rw-r--r--recipes/directfb/fusionsound_1.1.0+git20070709.bb59
-rw-r--r--recipes/directfb/lite_0.9.26+cvs20070207.bb40
25 files changed, 715 insertions, 0 deletions
diff --git a/recipes/directfb/++dfb_1.0.0.bb b/recipes/directfb/++dfb_1.0.0.bb
new file mode 100644
index 0000000000..7c4aea3920
--- /dev/null
+++ b/recipes/directfb/++dfb_1.0.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "A C++ Wrapper for the directfb framebuffer library."
+HOMEPAGE = "http://directfb.org"
+SECTION = "libs"
+DEPENDS = "directfb"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.directfb.org/downloads/Extras/++DFB-${PV}.tar.gz"
+S = "${WORKDIR}/++DFB-${PV}"
+RV = "0.9-25"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+FILES_++dfb_append = " ${libdir}/*.so*"
diff --git a/recipes/directfb/directfb-1.1.0/fix-pkgconfig-cflags.patch b/recipes/directfb/directfb-1.1.0/fix-pkgconfig-cflags.patch
new file mode 100644
index 0000000000..5526776de3
--- /dev/null
+++ b/recipes/directfb/directfb-1.1.0/fix-pkgconfig-cflags.patch
@@ -0,0 +1,57 @@
+Index: DirectFB-1.1.0/directfb-internal.pc.in
+===================================================================
+--- DirectFB-1.1.0.orig/directfb-internal.pc.in 2008-06-22 16:16:13.851722040 +0200
++++ DirectFB-1.1.0/directfb-internal.pc.in 2008-06-22 16:16:33.665465096 +0200
+@@ -2,10 +2,10 @@
+ exec_prefix=@exec_prefix@
+ moduledir=@MODULEDIR@
+ moduledirname=@MODULEDIRNAME@
+-includedir=@INTERNALINCLUDEDIR@
++includedir=@includedir@
+
+ Name: DirectFB-Internal
+ Description: Third party module support package for DirectFB.
+ Version: @VERSION@
+ Requires: directfb = @VERSION@
+-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
++Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir}/directfb -I${includedir}/directfb-internal
+Index: DirectFB-1.1.0/directfb.pc.in
+===================================================================
+--- DirectFB-1.1.0.orig/directfb.pc.in 2008-06-22 16:16:13.868387652 +0200
++++ DirectFB-1.1.0/directfb.pc.in 2008-06-22 16:16:50.816223652 +0200
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: fusion direct
+ Libs: -L${libdir} -ldirectfb @THREADLIB@ @DYNLIB@ @ZLIB_LIBS@ @OSX_LIBS@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}/directfb
+Index: DirectFB-1.1.0/lib/direct/direct.pc.in
+===================================================================
+--- DirectFB-1.1.0.orig/lib/direct/direct.pc.in 2008-06-22 16:16:13.888387824 +0200
++++ DirectFB-1.1.0/lib/direct/direct.pc.in 2008-06-22 16:16:17.121721173 +0200
+@@ -7,4 +7,4 @@
+ Description: DirectFB base development library
+ Version: @VERSION@
+ Libs: -L${libdir} -ldirect @THREADLIB@ @DYNLIB@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}/directfb
+Index: DirectFB-1.1.0/lib/fusion/fusion.pc.in
+===================================================================
+--- DirectFB-1.1.0.orig/lib/fusion/fusion.pc.in 2008-06-22 16:16:13.905054457 +0200
++++ DirectFB-1.1.0/lib/fusion/fusion.pc.in 2008-06-22 16:16:17.121721173 +0200
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lfusion
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb
+Index: DirectFB-1.1.0/lib/voodoo/voodoo.pc.in
+===================================================================
+--- DirectFB-1.1.0.orig/lib/voodoo/voodoo.pc.in 2008-06-22 16:16:13.931720483 +0200
++++ DirectFB-1.1.0/lib/voodoo/voodoo.pc.in 2008-06-22 16:16:17.121721173 +0200
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lvoodoo
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb
diff --git a/recipes/directfb/directfb-1.1.1/fix-pkgconfig-cflags.patch b/recipes/directfb/directfb-1.1.1/fix-pkgconfig-cflags.patch
new file mode 100644
index 0000000000..745c561cc0
--- /dev/null
+++ b/recipes/directfb/directfb-1.1.1/fix-pkgconfig-cflags.patch
@@ -0,0 +1,47 @@
+Index: DirectFB-1.1.1/directfb-internal.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/directfb-internal.pc.in 2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.1/directfb-internal.pc.in 2008-07-17 21:00:47.424654304 +0200
+@@ -2,10 +2,10 @@
+ exec_prefix=@exec_prefix@
+ moduledir=@MODULEDIR@
+ moduledirname=@MODULEDIRNAME@
+-includedir=@INTERNALINCLUDEDIR@
++includedir=@includedir@
+
+ Name: DirectFB-Internal
+ Description: Third party module support package for DirectFB.
+ Version: @VERSION@
+ Requires: directfb = @VERSION@
+-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
++Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir}/directfb -I${includedir}
+Index: DirectFB-1.1.1/directfb.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/directfb.pc.in 2007-12-15 16:23:16.000000000 +0100
++++ DirectFB-1.1.1/directfb.pc.in 2008-07-17 20:59:58.044985193 +0200
+@@ -9,4 +9,4 @@
+ Requires: fusion direct
+ Libs: -L${libdir} -ldirectfb @THREADLIB@ @OSX_LIBS@
+ Libs.private: -L${libdir} @DYNLIB@ @ZLIB_LIBS@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}/directfb
+Index: DirectFB-1.1.1/lib/fusion/fusion.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/lib/fusion/fusion.pc.in 2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.1/lib/fusion/fusion.pc.in 2008-07-17 20:58:07.051338866 +0200
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lfusion
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}
+Index: DirectFB-1.1.1/lib/voodoo/voodoo.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/lib/voodoo/voodoo.pc.in 2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.1/lib/voodoo/voodoo.pc.in 2008-07-17 20:58:07.054671842 +0200
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lvoodoo
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}
diff --git a/recipes/directfb/directfb-1.2.7/ts_lib_autotools.patch b/recipes/directfb/directfb-1.2.7/ts_lib_autotools.patch
new file mode 100644
index 0000000000..f19c724a00
--- /dev/null
+++ b/recipes/directfb/directfb-1.2.7/ts_lib_autotools.patch
@@ -0,0 +1,22 @@
+---
+ configure.in | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+Index: DirectFB-1.2.7/configure.in
+===================================================================
+--- DirectFB-1.2.7.orig/configure.in
++++ DirectFB-1.2.7/configure.in
+@@ -1288,8 +1288,11 @@ fi
+
+ enable_tslib=no
+ if test "$checkfor_tslib" = "yes"; then
+- PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [enable_tslib=yes], [enable_tslib=no,
+- AC_MSG_WARN([*** no tslib -- tslib driver will not be built.])])
++ PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0.0], [enable_tslib=yes], [enable_tslib=no])
++ if test "$enable_tslib" = "no"; then
++ PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [enable_tslib=yes], [enable_tslib=no,
++ AC_MSG_WARN([*** no tslib -- tslib driver will not be built.])])
++ fi
+ fi
+
+ enable_ucb1x00_ts=no
diff --git a/recipes/directfb/directfb-examples_1.0.0.bb b/recipes/directfb/directfb-examples_1.0.0.bb
new file mode 100644
index 0000000000..4e93aa8e5f
--- /dev/null
+++ b/recipes/directfb/directfb-examples_1.0.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "DirectFB extra providers"
+DEPENDS = "directfb"
+SECTION = "libs"
+LICENSE = "GPL"
+
+SRC_URI = " \
+ http://www.directfb.org/downloads/Old/DirectFB-examples-${PV}.tar.gz \
+ "
+S = "${WORKDIR}/DirectFB-examples-${PV}"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/directfb/directfb-examples_1.2.0.bb b/recipes/directfb/directfb-examples_1.2.0.bb
new file mode 100644
index 0000000000..7fd3f38848
--- /dev/null
+++ b/recipes/directfb/directfb-examples_1.2.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "DirectFB extra providers"
+DEPENDS = "directfb"
+SECTION = "libs"
+LICENSE = "GPL"
+
+SRC_URI = " \
+ http://www.directfb.org/downloads/Extras/DirectFB-examples-${PV}.tar.gz \
+ "
+S = "${WORKDIR}/DirectFB-examples-${PV}"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/recipes/directfb/directfb.inc b/recipes/directfb/directfb.inc
new file mode 100644
index 0000000000..9066ff2218
--- /dev/null
+++ b/recipes/directfb/directfb.inc
@@ -0,0 +1,75 @@
+DESCRIPTION = "DirectFB is a thin library that provides developers \
+with hardware graphics acceleration, input device handling and \
+abstraction, an integrated windowing system with support for \
+translucent windows and multiple display layers on top of the \
+Linux framebuffer device."
+SECTION = "libs"
+LICENSE = "LGPL"
+HOMEPAGE = "http://directfb.org"
+DEPENDS = "jpeg libpng freetype zlib tslib"
+
+SRC_URI = " \
+ http://www.directfb.org/downloads/Old/DirectFB-${PV}.tar.gz \
+ file://fix-pkgconfig-cflags.patch;patch=1 \
+ file://fix-font-missing-char.patch;patch=1 \
+ file://getpagesize.patch;patch=1 \
+ file://mkdfiff.patch;patch=1 \
+ file://dont-use-linux-config.patch;patch=1 \
+ file://ts_lib_autotools.patch;patch=1 \
+"
+S = "${WORKDIR}/DirectFB-${PV}"
+
+LDFLAGS_append =" -lts -lm"
+
+inherit autotools binconfig pkgconfig
+
+EXTRA_OECONF = "\
+ --with-gfxdrivers=none \
+ --enable-libmpeg3=no \
+ --enable-freetype=yes \
+ --enable-sdl=no \
+ --enable-vnc=no \
+ --disable-x11 \
+"
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+
+#PACKAGES_DYNAMIC = "directfb-inputdrivers-*"
+#
+#python populate_packages_prepend () {
+# import os.path
+# inputdrivers_libdir = bb.data.expand('${libdir}/directfb-${RV}/inputdrivers', d)
+# do_split_packages(d, inputdrivers_libdir, '*.so$', 'directfb-inputdrivers-%s', 'Directfb plugin for %s')
+#}
+
+# NOTE: monolithic packaging for now, should improve that eventually
+
+
+
+FILES_${PN}-dbg += "\
+ ${libdir}/directfb-${RV}/*/*/.debug/*.so \
+ ${libdir}/directfb-${RV}/*/.debug/*.so \
+"
+
+FILES_${PN}-dev += "\
+ ${bindir}/directfb-config \
+ ${libdir}/directfb-${RV}/systems/*.la \
+ ${libdir}/directfb-${RV}/inputdrivers/*.la \
+ ${libdir}/directfb-${RV}/interfaces/*/*.la \
+ ${libdir}/directfb-${RV}/wm/*.la \
+"
+
+FILES_${PN} += "\
+ ${libdir}/directfb-${RV}/systems/*.so \
+ ${libdir}/directfb-${RV}/inputdrivers/*.so \
+ ${libdir}/directfb-${RV}/interfaces/*/*.so \
+ ${libdir}/directfb-${RV}/wm/*.so \
+ ${datadir}/directfb-${PV} \
+"
diff --git a/recipes/directfb/directfb_1.0.0.bb b/recipes/directfb/directfb_1.0.0.bb
new file mode 100644
index 0000000000..3c98ea8597
--- /dev/null
+++ b/recipes/directfb/directfb_1.0.0.bb
@@ -0,0 +1,7 @@
+require directfb.inc
+
+
+SRC_URI += "file://fix-includes.patch;patch=1"
+
+RV = "1.0-0"
+PR = "r6"
diff --git a/recipes/directfb/directfb_1.1.0.bb b/recipes/directfb/directfb_1.1.0.bb
new file mode 100644
index 0000000000..cd21b81a80
--- /dev/null
+++ b/recipes/directfb/directfb_1.1.0.bb
@@ -0,0 +1,6 @@
+require directfb.inc
+
+RV = "1.1-0"
+PR = "r6"
+
+LEAD_SONAME = "libdirect-1.1.so"
diff --git a/recipes/directfb/directfb_1.1.1.bb b/recipes/directfb/directfb_1.1.1.bb
new file mode 100644
index 0000000000..9b5588b627
--- /dev/null
+++ b/recipes/directfb/directfb_1.1.1.bb
@@ -0,0 +1,27 @@
+require directfb.inc
+
+RV = "1.1-0"
+PR = "r0"
+
+DEPENDS += "sysfsutils"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = " \
+ http://www.directfb.org/downloads/Old/DirectFB-${PV}.tar.gz \
+ file://fix-pkgconfig-cflags.patch;patch=1 \
+ file://fix-font-missing-char.patch;patch=1 \
+ file://mkdfiff.patch;patch=1 \
+ file://dont-use-linux-config.patch;patch=1 \
+ file://ts_lib_autotools.patch;patch=1 \
+"
+
+EXTRA_OECONF = "\
+ --enable-freetype=yes \
+ --enable-zlib \
+ --with-gfxdrivers=none \
+ --disable-libmpeg3 \
+ --disable-sdl \
+ --disable-vnc \
+ --disable-x11 \
+"
diff --git a/recipes/directfb/directfb_1.2.3.bb b/recipes/directfb/directfb_1.2.3.bb
new file mode 100644
index 0000000000..e4d50a3458
--- /dev/null
+++ b/recipes/directfb/directfb_1.2.3.bb
@@ -0,0 +1,28 @@
+require directfb.inc
+
+RV = "1.2-0"
+PR = "r1"
+
+DEPENDS += "sysfsutils"
+
+SRC_URI = " \
+ http://www.directfb.org/downloads/Old/DirectFB-${PV}.tar.gz \
+ file://directfb-1.2.x-fix-pkgconfig-cflags.patch;patch=1 \
+ file://mkdfiff.patch;patch=1 \
+ file://dont-use-linux-config.patch;patch=1 \
+ file://ts_lib_autotools.patch;patch=1 \
+"
+
+EXTRA_OECONF = "\
+ --enable-freetype=yes \
+ --enable-zlib \
+ --with-gfxdrivers=none \
+ --disable-libmpeg3 \
+ --disable-sdl \
+ --disable-vnc \
+ --disable-x11 \
+"
+
+LDFLAGS_append = ""
+
+LEAD_SONAME = "libdirectfb-1.2.so.0"
diff --git a/recipes/directfb/directfb_1.2.7.bb b/recipes/directfb/directfb_1.2.7.bb
new file mode 100644
index 0000000000..be6a6daa52
--- /dev/null
+++ b/recipes/directfb/directfb_1.2.7.bb
@@ -0,0 +1,28 @@
+require directfb.inc
+
+RV = "1.2-0"
+PR = "r0"
+
+DEPENDS += "sysfsutils"
+
+SRC_URI = " \
+ http://directfb.org/downloads/Core/DirectFB-${PV}.tar.gz \
+ file://directfb-1.2.x-fix-pkgconfig-cflags.patch;patch=1 \
+ file://mkdfiff.patch;patch=1 \
+ file://dont-use-linux-config.patch;patch=1 \
+ file://ts_lib_autotools.patch;patch=1 \
+"
+
+EXTRA_OECONF = "\
+ --enable-freetype=yes \
+ --enable-zlib \
+ --with-gfxdrivers=none \
+ --disable-libmpeg3 \
+ --disable-sdl \
+ --disable-vnc \
+ --disable-x11 \
+"
+
+LDFLAGS_append = ""
+
+LEAD_SONAME = "libdirectfb-1.2.so.0"
diff --git a/recipes/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch b/recipes/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch
new file mode 100644
index 0000000000..745c561cc0
--- /dev/null
+++ b/recipes/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch
@@ -0,0 +1,47 @@
+Index: DirectFB-1.1.1/directfb-internal.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/directfb-internal.pc.in 2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.1/directfb-internal.pc.in 2008-07-17 21:00:47.424654304 +0200
+@@ -2,10 +2,10 @@
+ exec_prefix=@exec_prefix@
+ moduledir=@MODULEDIR@
+ moduledirname=@MODULEDIRNAME@
+-includedir=@INTERNALINCLUDEDIR@
++includedir=@includedir@
+
+ Name: DirectFB-Internal
+ Description: Third party module support package for DirectFB.
+ Version: @VERSION@
+ Requires: directfb = @VERSION@
+-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
++Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir}/directfb -I${includedir}
+Index: DirectFB-1.1.1/directfb.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/directfb.pc.in 2007-12-15 16:23:16.000000000 +0100
++++ DirectFB-1.1.1/directfb.pc.in 2008-07-17 20:59:58.044985193 +0200
+@@ -9,4 +9,4 @@
+ Requires: fusion direct
+ Libs: -L${libdir} -ldirectfb @THREADLIB@ @OSX_LIBS@
+ Libs.private: -L${libdir} @DYNLIB@ @ZLIB_LIBS@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}/directfb
+Index: DirectFB-1.1.1/lib/fusion/fusion.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/lib/fusion/fusion.pc.in 2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.1/lib/fusion/fusion.pc.in 2008-07-17 20:58:07.051338866 +0200
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lfusion
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}
+Index: DirectFB-1.1.1/lib/voodoo/voodoo.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/lib/voodoo/voodoo.pc.in 2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.1/lib/voodoo/voodoo.pc.in 2008-07-17 20:58:07.054671842 +0200
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lvoodoo
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}
diff --git a/recipes/directfb/files/dont-use-linux-config.patch b/recipes/directfb/files/dont-use-linux-config.patch
new file mode 100644
index 0000000000..f971660954
--- /dev/null
+++ b/recipes/directfb/files/dont-use-linux-config.patch
@@ -0,0 +1,12 @@
+diff -urN DirectFB-1.1.0.orig/lib/direct/ppcasm_memcpy_cachable.S DirectFB-1.1.0/lib/direct/ppcasm_memcpy_cachable.S
+--- DirectFB-1.1.0.orig/lib/direct/ppcasm_memcpy_cachable.S 2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.0/lib/direct/ppcasm_memcpy_cachable.S 2008-06-07 04:14:26.000000000 +0200
+@@ -34,8 +34,6 @@
+
+ #define __ASSEMBLY__
+
+-#include <linux/config.h>
+-
+ #if defined(CONFIG_8xx) || defined(CONFIG_403GCX)
+ #define L1_CACHE_LINE_SIZE 16
+ #define LG_L1_CACHE_LINE_SIZE 4
diff --git a/recipes/directfb/files/fix-font-missing-char.patch b/recipes/directfb/files/fix-font-missing-char.patch
new file mode 100644
index 0000000000..4c5e5883f4
--- /dev/null
+++ b/recipes/directfb/files/fix-font-missing-char.patch
@@ -0,0 +1,11 @@
+--- git/src/media/idirectfbfont.c~org 2007-07-10 10:35:46.000000000 -0400
++++ git/src/media/idirectfbfont.c 2007-07-10 10:36:09.000000000 -0400
+@@ -497,7 +497,7 @@
+
+ if (width<max_width && string >= end) {
+ *ret_next_line = NULL;
+- *ret_str_length = length-1;
++ *ret_str_length = length;
+ *ret_width = width;
+
+ return DFB_OK;
diff --git a/recipes/directfb/files/fix-includes.patch b/recipes/directfb/files/fix-includes.patch
new file mode 100644
index 0000000000..7b4a112582
--- /dev/null
+++ b/recipes/directfb/files/fix-includes.patch
@@ -0,0 +1,24 @@
+#
+# pkgconfig points to STAGING_INCDIR, hence
+# we need to make this a local include
+# or else it doesn't find its own header files
+#
+# Signed-Off: mickey@openmoko.org
+#
+Index: DirectFB-1.0.0/include/directfb.h
+===================================================================
+--- DirectFB-1.0.0.orig/include/directfb.h
++++ DirectFB-1.0.0/include/directfb.h
+@@ -29,10 +29,10 @@
+ #ifndef __DIRECTFB_H__
+ #define __DIRECTFB_H__
+
+-#include <dfb_types.h>
++#include "dfb_types.h"
+ #include <sys/time.h> /* struct timeval */
+
+-#include <directfb_keyboard.h>
++#include "directfb_keyboard.h"
+
+ #ifdef __cplusplus
+ extern "C"
diff --git a/recipes/directfb/files/fix-pkgconfig-cflags.patch b/recipes/directfb/files/fix-pkgconfig-cflags.patch
new file mode 100644
index 0000000000..ddaa276fcd
--- /dev/null
+++ b/recipes/directfb/files/fix-pkgconfig-cflags.patch
@@ -0,0 +1,45 @@
+diff -ur DirectFB-1.0.0~org/directfb-internal.pc.in DirectFB-1.0.0/directfb-internal.pc.in
+--- DirectFB-1.0.0~org/directfb-internal.pc.in 2003-07-04 13:30:22.000000000 -0400
++++ DirectFB-1.0.0/directfb-internal.pc.in 2007-03-16 22:34:17.000000000 -0400
+@@ -8,4 +8,4 @@
+ Description: Third party module support package for DirectFB.
+ Version: @VERSION@
+ Requires: directfb = @VERSION@
+-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
++Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir}/directfb -I${includedir}
+diff -ur DirectFB-1.0.0~org/directfb.pc.in DirectFB-1.0.0/directfb.pc.in
+--- DirectFB-1.0.0~org/directfb.pc.in 2004-08-04 12:28:20.000000000 -0400
++++ DirectFB-1.0.0/directfb.pc.in 2007-03-16 22:31:33.000000000 -0400
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: fusion direct
+ Libs: -L${libdir} -ldirectfb @THREADLIB@ @DYNLIB@ @ZLIB_LIBS@ @OSX_LIBS@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}/directfb -I${includedir}
+diff -ur DirectFB-1.0.0~org/lib/direct/direct.pc.in DirectFB-1.0.0/lib/direct/direct.pc.in
+--- DirectFB-1.0.0~org/lib/direct/direct.pc.in 2005-11-23 09:18:59.000000000 -0500
++++ DirectFB-1.0.0/lib/direct/direct.pc.in 2007-03-16 22:32:13.000000000 -0400
+@@ -7,4 +7,4 @@
+ Description: DirectFB base development library
+ Version: @VERSION@
+ Libs: -L${libdir} -ldirect @THREADLIB@ @DYNLIB@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}/directfb -I${includedir}
+diff -ur DirectFB-1.0.0~org/lib/fusion/fusion.pc.in DirectFB-1.0.0/lib/fusion/fusion.pc.in
+--- DirectFB-1.0.0~org/lib/fusion/fusion.pc.in 2004-05-19 07:30:56.000000000 -0400
++++ DirectFB-1.0.0/lib/fusion/fusion.pc.in 2007-03-16 22:32:34.000000000 -0400
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lfusion
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}
+diff -ur DirectFB-1.0.0~org/lib/voodoo/voodoo.pc.in DirectFB-1.0.0/lib/voodoo/voodoo.pc.in
+--- DirectFB-1.0.0~org/lib/voodoo/voodoo.pc.in 2004-05-19 07:31:28.000000000 -0400
++++ DirectFB-1.0.0/lib/voodoo/voodoo.pc.in 2007-03-16 22:32:55.000000000 -0400
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lvoodoo
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}
diff --git a/recipes/directfb/files/fix-pkgconfig-specs.patch b/recipes/directfb/files/fix-pkgconfig-specs.patch
new file mode 100644
index 0000000000..c252dc1792
--- /dev/null
+++ b/recipes/directfb/files/fix-pkgconfig-specs.patch
@@ -0,0 +1,50 @@
+Index: DirectFB-1.0.0/directfb-internal.pc.in
+===================================================================
+--- DirectFB-1.0.0.orig/directfb-internal.pc.in
++++ DirectFB-1.0.0/directfb-internal.pc.in
+@@ -8,4 +8,4 @@ Name: DirectFB-Internal
+ Description: Third party module support package for DirectFB.
+ Version: @VERSION@
+ Requires: directfb = @VERSION@
+-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
++Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir} -I${includedir}/../directfb
+Index: DirectFB-1.0.0/directfb.pc.in
+===================================================================
+--- DirectFB-1.0.0.orig/directfb.pc.in
++++ DirectFB-1.0.0/directfb.pc.in
+@@ -8,4 +8,4 @@ Description: Graphics and windowing libr
+ Version: @VERSION@
+ Requires: fusion direct
+ Libs: -L${libdir} -ldirectfb @THREADLIB@ @DYNLIB@ @ZLIB_LIBS@ @OSX_LIBS@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}
+Index: DirectFB-1.0.0/lib/direct/direct.pc.in
+===================================================================
+--- DirectFB-1.0.0.orig/lib/direct/direct.pc.in
++++ DirectFB-1.0.0/lib/direct/direct.pc.in
+@@ -7,4 +7,4 @@ Name: Direct
+ Description: DirectFB base development library
+ Version: @VERSION@
+ Libs: -L${libdir} -ldirect @THREADLIB@ @DYNLIB@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}
+Index: DirectFB-1.0.0/lib/fusion/fusion.pc.in
+===================================================================
+--- DirectFB-1.0.0.orig/lib/fusion/fusion.pc.in
++++ DirectFB-1.0.0/lib/fusion/fusion.pc.in
+@@ -8,4 +8,4 @@ Description: High Level IPC Mechanisms
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lfusion
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}
+Index: DirectFB-1.0.0/lib/voodoo/voodoo.pc.in
+===================================================================
+--- DirectFB-1.0.0.orig/lib/voodoo/voodoo.pc.in
++++ DirectFB-1.0.0/lib/voodoo/voodoo.pc.in
+@@ -8,4 +8,4 @@ Description: Interface based network tra
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lvoodoo
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}
diff --git a/recipes/directfb/files/getpagesize.patch b/recipes/directfb/files/getpagesize.patch
new file mode 100644
index 0000000000..256b8db290
--- /dev/null
+++ b/recipes/directfb/files/getpagesize.patch
@@ -0,0 +1,16 @@
+diff --git a/lib/direct/system.c b/lib/direct/system.c
+index 8dd3f12..0731fa2 100644
+--- a/lib/direct/system.c
++++ b/lib/direct/system.c
+@@ -36,8 +36,9 @@
+
+ #if HAVE_ASM_PAGE_H
+ #include <asm/page.h>
+-#else
+-#define PAGE_SIZE sysconf( _SC_PAGESIZE )
++#endif
++#ifndef PAGE_SIZE
++# define PAGE_SIZE (getpagesize())
+ #endif
+
+
diff --git a/recipes/directfb/files/mkdfiff.patch b/recipes/directfb/files/mkdfiff.patch
new file mode 100644
index 0000000000..cb56fd3602
--- /dev/null
+++ b/recipes/directfb/files/mkdfiff.patch
@@ -0,0 +1,11 @@
+--- DirectFB-1.0.0-rc1~org/tools/mkdfiff.c 2006-10-12 13:45:50.000000000 -0400
++++ DirectFB-1.0.0-rc1/tools/mkdfiff.c 2006-10-12 13:57:38.000000000 -0400
+@@ -15,6 +15,8 @@
+
+ #include <dfiff.h>
+
++#include <unistd.h>
++
+ static DirectFBPixelFormatNames( format_names );
+
+ static const char *filename;
diff --git a/recipes/directfb/files/ts_lib_autotools.patch b/recipes/directfb/files/ts_lib_autotools.patch
new file mode 100644
index 0000000000..ced7104786
--- /dev/null
+++ b/recipes/directfb/files/ts_lib_autotools.patch
@@ -0,0 +1,16 @@
+Index: DirectFB-1.1.1/configure.in
+===================================================================
+--- DirectFB-1.1.1.orig/configure.in 2008-05-07 23:08:04.000000000 +0200
++++ DirectFB-1.1.1/configure.in 2008-05-07 23:15:43.000000000 +0200
+@@ -1292,8 +1292,11 @@
+
+ enable_tslib=no
+ if test "$checkfor_tslib" = "yes"; then
++ PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0.0], [enable_tslib=yes], [enable_tslib=no])
++ if test "$enable_tslib" = "no"; then
+ PKG_CHECK_MODULES([TSLIB], [tslib-0.0 >= 0.0.2], enable_tslib=yes, enable_tslib=no
+ AC_MSG_WARN([*** no tslib -- tslib driver will not be built.]))
++ fi
+ fi
+
+ enable_ucb1x00_ts=no
diff --git a/recipes/directfb/files/use_limits_h.patch b/recipes/directfb/files/use_limits_h.patch
new file mode 100644
index 0000000000..327cd7a163
--- /dev/null
+++ b/recipes/directfb/files/use_limits_h.patch
@@ -0,0 +1,10 @@
+--- FusionSound-1.0.0.orig/interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_cdda.c
++++ FusionSound-1.0.0/interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_cdda.c
+@@ -109,6 +109,7 @@ typedef struct {
+
+ #if defined(__linux__)
+
++#include <limits.h>
+ #include <linux/cdrom.h>
+
+ static DFBResult
diff --git a/recipes/directfb/fusionsound-1.1.0+git20070709/fix-pkgconfig-cflags.patch b/recipes/directfb/fusionsound-1.1.0+git20070709/fix-pkgconfig-cflags.patch
new file mode 100644
index 0000000000..0eb4c7519a
--- /dev/null
+++ b/recipes/directfb/fusionsound-1.1.0+git20070709/fix-pkgconfig-cflags.patch
@@ -0,0 +1,23 @@
+--- git/fusionsound.pc.in~org 2008-08-19 11:04:27.000000000 -0400
++++ git/fusionsound.pc.in 2008-08-19 11:06:20.000000000 -0400
+@@ -8,4 +8,4 @@
+ Description: Multi application sound streaming and mixing
+ Version: @VERSION@
+ Libs: -L${libdir} -lfusionsound
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/fusionsound
+--- git/fusionsound-internal.pc.in~org 2008-08-19 11:11:57.000000000 -0400
++++ git/fusionsound-internal.pc.in 2008-08-19 11:08:31.000000000 -0400
+@@ -1,10 +1,10 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ moduledir=@MODULEDIR@
+-includedir=@INTERNALINCLUDEDIR@
++includedir=@includedir@
+
+ Name: FusionSound-Internal
+ Description: Third party module support package for FusionSound.
+ Version: @VERSION@
+ Requires: fusionsound = @VERSION@
+-Cflags: -I@INTERNALINCLUDEDIR@
++Cflags: -I${includedir}/fusionsound -I${includedir}
diff --git a/recipes/directfb/fusionsound_1.1.0+git20070709.bb b/recipes/directfb/fusionsound_1.1.0+git20070709.bb
new file mode 100644
index 0000000000..dda1de5333
--- /dev/null
+++ b/recipes/directfb/fusionsound_1.1.0+git20070709.bb
@@ -0,0 +1,59 @@
+DESCRIPTION = "FusionSound for DirectFB"
+DEPENDS = "directfb"
+SECTION = "libs"
+LICENSE = "LGPL"
+PR = "r2"
+
+SRC_URI = "git://git.directfb.org/git/directfb/core/FusionSound;protocol=git;tag=0b2162b570c8314fd1240b08d6ab4a8d074ccf37 \
+ file://fix-pkgconfig-cflags.patch;patch=1 \
+ file://use_limits_h.patch;patch=1 \
+"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+CFLAGS_append += " -I${STAGING_INCDIR}/directfb -I${STAGING_INCDIR}/directfb-internal"
+
+#Below are some of the configure options
+EXTRA_OECONF = " \
+ --disable-ieee-floats \
+ --disable-precision \
+ --enable-linear-filter \
+ --disable-dithering \
+ --enable-debug \
+ --enable-examples \
+ --enable-module \
+ --disable-timidity \
+ --disable-wave \
+ --enable-vorbis \
+ --enable-tremor \
+ --disable-mad \
+ --disable-cdda \
+ --disable-playlist \
+ "
+
+do_configure_append() {
+ find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+FILES_fusionsound-dbg_append = " ${libdir}/directfb-1.1-0/*/*/.debug/*.so \
+ ${libdir}/directfb-1.1-0/*/.debug/*.so \
+ "
+
+FILES_fusionsound-dev_append = " ${libdir}/directfb-1.1-0/interfaces/*/*.la \
+ ${libdir}/directfb-1.1-0/snddrivers/*.la \
+ "
+
+FILES_fusionsound_append = " ${libdir}/directfb-1.1-0/interfaces/*/*.so \
+ ${libdir}/directfb-1.1-0/snddrivers/*.so \
+ "
+
diff --git a/recipes/directfb/lite_0.9.26+cvs20070207.bb b/recipes/directfb/lite_0.9.26+cvs20070207.bb
new file mode 100644
index 0000000000..32f97bf962
--- /dev/null
+++ b/recipes/directfb/lite_0.9.26+cvs20070207.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "LiTE stands for Lightweight Toolkit Enabler. Its role is to \
+ facilitate the functions of DirectFB so that a toolbox could \
+ be written on top of DirectFB with less effort. As such LiTE \
+ has abstractions for the underlying graphics and event systems."
+
+DEPENDS = "directfb"
+SECTION = "libs"
+LICENSE = "LGPL"
+
+# this is a CVS only release
+
+SRC_URI = "cvs://anonymous@cvs.directfb.org/cvs/directfb;method=pserver;module=lite;date=${@bb.data.getVar('PV', d, 1)[10:]}"
+
+S = "${WORKDIR}/lite"
+
+inherit autotools pkgconfig
+
+do_configure_append() {
+ find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+FILES_lite-dbg_append = " ${libdir}/directfb-1.0-0/*/*/.debug/*.so \
+ ${libdir}/directfb-1.0-0/*/.debug/*.so \
+ "
+FILES_lite-dev_append = " ${libdir}/directfb-1.0-0/interfaces/*/*.la \
+ "
+
+FILES_lite_append = " ${libdir}/directfb-1.0-0/interfaces/*/*.so \
+ ${datadir}/LiTE/* \
+ ${datadir}/fonts/truetype/* \
+ "
+