aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dpkg
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dpkg')
-rw-r--r--recipes/dpkg/dpkg-1.14.19/ignore_extra_fields.patch26
-rw-r--r--recipes/dpkg/dpkg-1.14.23/ignore_extra_fields.patch24
-rw-r--r--recipes/dpkg/dpkg-1.14.25/ignore_extra_fields.patch24
-rw-r--r--recipes/dpkg/dpkg-native.inc28
-rw-r--r--recipes/dpkg/dpkg-native_1.13.22.bb3
-rw-r--r--recipes/dpkg/dpkg-native_1.13.25.bb3
-rw-r--r--recipes/dpkg/dpkg-native_1.14.19.bb3
-rw-r--r--recipes/dpkg/dpkg-native_1.14.23.bb3
-rw-r--r--recipes/dpkg/dpkg-native_1.14.25.bb3
-rw-r--r--recipes/dpkg/dpkg.inc38
-rw-r--r--recipes/dpkg/dpkg_1.13.22.bb12
-rw-r--r--recipes/dpkg/dpkg_1.13.25.bb12
-rw-r--r--recipes/dpkg/dpkg_1.14.19.bb12
-rw-r--r--recipes/dpkg/dpkg_1.14.23.bb12
-rw-r--r--recipes/dpkg/dpkg_1.14.25.bb11
-rw-r--r--recipes/dpkg/files/autofoo.patch48
-rw-r--r--recipes/dpkg/files/ignore_extra_fields.patch21
-rw-r--r--recipes/dpkg/files/nochroot.patch18
-rw-r--r--recipes/dpkg/files/noman.patch16
-rw-r--r--recipes/dpkg/files/noupdalt.patch16
20 files changed, 333 insertions, 0 deletions
diff --git a/recipes/dpkg/dpkg-1.14.19/ignore_extra_fields.patch b/recipes/dpkg/dpkg-1.14.19/ignore_extra_fields.patch
new file mode 100644
index 0000000000..d09343c6e5
--- /dev/null
+++ b/recipes/dpkg/dpkg-1.14.19/ignore_extra_fields.patch
@@ -0,0 +1,26 @@
+ dpkg-deb/build.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- dpkg-1.14.19.orig/dpkg-deb/build.c
++++ dpkg-1.14.19/dpkg-deb/build.c
+@@ -241,18 +241,18 @@ void do_build(const char *const *argv) {
+ if (checkedinfo->priority == pri_other) {
+ fprintf(stderr, _("warning, `%s' contains user-defined Priority value `%s'\n"),
+ controlfile, checkedinfo->otherpriority);
+ warns++;
+ }
+- for (field= checkedinfo->available.arbs; field; field= field->next) {
++ /*for (field= checkedinfo->available.arbs; field; field= field->next) {
+ if (known_arbitrary_field(field))
+ continue;
+
+ fprintf(stderr, _("warning, `%s' contains user-defined field `%s'\n"),
+ controlfile, field->name);
+ warns++;
+- }
++ }*/
+ checkversion(checkedinfo->available.version.version,"(upstream) version",&errs);
+ checkversion(checkedinfo->available.version.revision,"Debian revision",&errs);
+ if (errs) ohshit(_("%d errors in control file"),errs);
+
+ if (subdir) {
diff --git a/recipes/dpkg/dpkg-1.14.23/ignore_extra_fields.patch b/recipes/dpkg/dpkg-1.14.23/ignore_extra_fields.patch
new file mode 100644
index 0000000000..e47af42bc6
--- /dev/null
+++ b/recipes/dpkg/dpkg-1.14.23/ignore_extra_fields.patch
@@ -0,0 +1,24 @@
+ dpkg-deb/build.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+Index: dpkg-1.14.23/dpkg-deb/build.c
+===================================================================
+--- dpkg-1.14.23.orig/dpkg-deb/build.c 2008-11-18 10:57:33.000000000 +0000
++++ dpkg-1.14.23/dpkg-deb/build.c 2008-12-15 11:27:08.000000000 +0000
+@@ -243,14 +243,14 @@
+ controlfile, checkedinfo->otherpriority);
+ warns++;
+ }
+- for (field= checkedinfo->available.arbs; field; field= field->next) {
++ /*for (field= checkedinfo->available.arbs; field; field= field->next) {
+ if (known_arbitrary_field(field))
+ continue;
+
+ fprintf(stderr, _("warning, `%s' contains user-defined field `%s'\n"),
+ controlfile, field->name);
+ warns++;
+- }
++ }*/
+ checkversion(checkedinfo->available.version.version,"(upstream) version",&errs);
+ checkversion(checkedinfo->available.version.revision,"Debian revision",&errs);
+ if (errs) ohshit(_("%d errors in control file"),errs);
diff --git a/recipes/dpkg/dpkg-1.14.25/ignore_extra_fields.patch b/recipes/dpkg/dpkg-1.14.25/ignore_extra_fields.patch
new file mode 100644
index 0000000000..e47af42bc6
--- /dev/null
+++ b/recipes/dpkg/dpkg-1.14.25/ignore_extra_fields.patch
@@ -0,0 +1,24 @@
+ dpkg-deb/build.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+Index: dpkg-1.14.23/dpkg-deb/build.c
+===================================================================
+--- dpkg-1.14.23.orig/dpkg-deb/build.c 2008-11-18 10:57:33.000000000 +0000
++++ dpkg-1.14.23/dpkg-deb/build.c 2008-12-15 11:27:08.000000000 +0000
+@@ -243,14 +243,14 @@
+ controlfile, checkedinfo->otherpriority);
+ warns++;
+ }
+- for (field= checkedinfo->available.arbs; field; field= field->next) {
++ /*for (field= checkedinfo->available.arbs; field; field= field->next) {
+ if (known_arbitrary_field(field))
+ continue;
+
+ fprintf(stderr, _("warning, `%s' contains user-defined field `%s'\n"),
+ controlfile, field->name);
+ warns++;
+- }
++ }*/
+ checkversion(checkedinfo->available.version.version,"(upstream) version",&errs);
+ checkversion(checkedinfo->available.version.revision,"Debian revision",&errs);
+ if (errs) ohshit(_("%d errors in control file"),errs);
diff --git a/recipes/dpkg/dpkg-native.inc b/recipes/dpkg/dpkg-native.inc
new file mode 100644
index 0000000000..771476ff2f
--- /dev/null
+++ b/recipes/dpkg/dpkg-native.inc
@@ -0,0 +1,28 @@
+require dpkg.inc
+
+inherit native
+
+DEPENDS = "perl-native bzip2-native zlib-native virtual/update-alternatives-native"
+RDEPENDS = ""
+
+SRC_URI += "file://noman.patch;patch=1"
+FILESPATH += "dpkg-${PV}"
+
+# We need to do this so our perl is picked up.
+do_configure_prepend() {
+ export PERL=${STAGING_BINDIR}/perl
+}
+
+EXTRA_OECONF = "--without-static-progs \
+ --without-dselect \
+ --with-start-stop-daemon \
+ --with-zlib \
+ --with-bz2lib \
+ --without-selinux \
+ --without-sgml-doc"
+
+do_stage_append() {
+ for BIN in dpkg-architecture; do
+ sed -i -e '1s,^#.*usr/bin,#!${STAGING_BINDIR},' ${STAGING_BINDIR}/$BIN
+ done
+}
diff --git a/recipes/dpkg/dpkg-native_1.13.22.bb b/recipes/dpkg/dpkg-native_1.13.22.bb
new file mode 100644
index 0000000000..5a1f6abc50
--- /dev/null
+++ b/recipes/dpkg/dpkg-native_1.13.22.bb
@@ -0,0 +1,3 @@
+require dpkg-native.inc
+
+PR = "r5"
diff --git a/recipes/dpkg/dpkg-native_1.13.25.bb b/recipes/dpkg/dpkg-native_1.13.25.bb
new file mode 100644
index 0000000000..47c03424be
--- /dev/null
+++ b/recipes/dpkg/dpkg-native_1.13.25.bb
@@ -0,0 +1,3 @@
+require dpkg-native.inc
+
+PR = "r1"
diff --git a/recipes/dpkg/dpkg-native_1.14.19.bb b/recipes/dpkg/dpkg-native_1.14.19.bb
new file mode 100644
index 0000000000..47c03424be
--- /dev/null
+++ b/recipes/dpkg/dpkg-native_1.14.19.bb
@@ -0,0 +1,3 @@
+require dpkg-native.inc
+
+PR = "r1"
diff --git a/recipes/dpkg/dpkg-native_1.14.23.bb b/recipes/dpkg/dpkg-native_1.14.23.bb
new file mode 100644
index 0000000000..47c03424be
--- /dev/null
+++ b/recipes/dpkg/dpkg-native_1.14.23.bb
@@ -0,0 +1,3 @@
+require dpkg-native.inc
+
+PR = "r1"
diff --git a/recipes/dpkg/dpkg-native_1.14.25.bb b/recipes/dpkg/dpkg-native_1.14.25.bb
new file mode 100644
index 0000000000..47c03424be
--- /dev/null
+++ b/recipes/dpkg/dpkg-native_1.14.25.bb
@@ -0,0 +1,3 @@
+require dpkg-native.inc
+
+PR = "r1"
diff --git a/recipes/dpkg/dpkg.inc b/recipes/dpkg/dpkg.inc
new file mode 100644
index 0000000000..eb5778fa3b
--- /dev/null
+++ b/recipes/dpkg/dpkg.inc
@@ -0,0 +1,38 @@
+DESCRIPTION = "Package maintenance system for Debian."
+LICENSE = "GPL"
+SECTION = "base"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.gz \
+ file://ignore_extra_fields.patch;patch=1 \
+ file://noupdalt.patch;patch=1"
+
+S = "${WORKDIR}/dpkg-${PV}"
+
+DEPENDS_${PN} += "update-alternatives"
+
+RDEPENDS += "perl perl-module-base perl-module-carp perl-module-cwd perl-module-english perl-module-exporter perl-module-exporter-heavy perl-module-fcntl perl-module-file-spec-unix perl-module-file-temp perl-module-io perl-module-io-handle perl-module-posix perl-module-strict perl-module-vars perl-module-warnings perl-module-warnings-register perl-module-autoloader perl-module-config perl-module-constant perl-module-errno perl-module-file-basename perl-module-file-path perl-module-file-spec perl-module-overload perl-module-selectsaver perl-module-symbol perl-module-xsloader"
+
+PARALLEL_MAKE = ""
+
+inherit autotools gettext
+
+DPKG_INIT_POSITION = "98"
+DPKG_INIT_POSITION_slugos = "41"
+
+pkg_postinst_dpkg () {
+#!/bin/sh
+if [ "x$D" != "x" ]; then
+ install -d ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d
+ # this happens at S98 where our good 'ole packages script used to run
+ printf "#!/bin/sh
+ dpkg --configure -a
+ rm -f /${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
+\n" > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
+ chmod 0755 ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
+fi
+}
+
+do_configure () {
+ echo >> m4/compiler.m4
+ autotools_do_configure
+}
diff --git a/recipes/dpkg/dpkg_1.13.22.bb b/recipes/dpkg/dpkg_1.13.22.bb
new file mode 100644
index 0000000000..e4e7a3b279
--- /dev/null
+++ b/recipes/dpkg/dpkg_1.13.22.bb
@@ -0,0 +1,12 @@
+require dpkg.inc
+PR = "r5"
+DEPENDS += "zlib bzip2"
+SRC_URI += "file://noman.patch;patch=1"
+
+EXTRA_OECONF = "--without-static-progs \
+ --without-dselect \
+ --with-start-stop-daemon \
+ --with-zlib \
+ --with-bz2lib \
+ --without-sgml-doc \
+ PERL=/usr/bin/perl"
diff --git a/recipes/dpkg/dpkg_1.13.25.bb b/recipes/dpkg/dpkg_1.13.25.bb
new file mode 100644
index 0000000000..8a2c8abae0
--- /dev/null
+++ b/recipes/dpkg/dpkg_1.13.25.bb
@@ -0,0 +1,12 @@
+require dpkg.inc
+PR = "r1"
+DEPENDS += "zlib bzip2"
+SRC_URI += "file://noman.patch;patch=1"
+
+EXTRA_OECONF = "--without-static-progs \
+ --without-dselect \
+ --with-start-stop-daemon \
+ --with-zlib \
+ --with-bz2lib \
+ --without-sgml-doc \
+ PERL=/usr/bin/perl"
diff --git a/recipes/dpkg/dpkg_1.14.19.bb b/recipes/dpkg/dpkg_1.14.19.bb
new file mode 100644
index 0000000000..0377ce10f1
--- /dev/null
+++ b/recipes/dpkg/dpkg_1.14.19.bb
@@ -0,0 +1,12 @@
+require dpkg.inc
+PR = "r1"
+DEPENDS += "zlib bzip2"
+#RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives}"
+SRC_URI += "file://noman.patch;patch=1"
+
+EXTRA_OECONF = "--without-static-progs \
+ --without-dselect \
+ --with-start-stop-daemon \
+ --with-zlib \
+ --with-bz2lib \
+ --without-sgml-doc"
diff --git a/recipes/dpkg/dpkg_1.14.23.bb b/recipes/dpkg/dpkg_1.14.23.bb
new file mode 100644
index 0000000000..0377ce10f1
--- /dev/null
+++ b/recipes/dpkg/dpkg_1.14.23.bb
@@ -0,0 +1,12 @@
+require dpkg.inc
+PR = "r1"
+DEPENDS += "zlib bzip2"
+#RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives}"
+SRC_URI += "file://noman.patch;patch=1"
+
+EXTRA_OECONF = "--without-static-progs \
+ --without-dselect \
+ --with-start-stop-daemon \
+ --with-zlib \
+ --with-bz2lib \
+ --without-sgml-doc"
diff --git a/recipes/dpkg/dpkg_1.14.25.bb b/recipes/dpkg/dpkg_1.14.25.bb
new file mode 100644
index 0000000000..dac14f96b6
--- /dev/null
+++ b/recipes/dpkg/dpkg_1.14.25.bb
@@ -0,0 +1,11 @@
+require dpkg.inc
+DEPENDS += "zlib bzip2"
+#RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives}"
+SRC_URI += "file://noman.patch;patch=1"
+
+EXTRA_OECONF = "--without-static-progs \
+ --without-dselect \
+ --with-start-stop-daemon \
+ --with-zlib \
+ --with-bz2lib \
+ --without-sgml-doc"
diff --git a/recipes/dpkg/files/autofoo.patch b/recipes/dpkg/files/autofoo.patch
new file mode 100644
index 0000000000..691121e418
--- /dev/null
+++ b/recipes/dpkg/files/autofoo.patch
@@ -0,0 +1,48 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- dpkg-1.10.23/configure.in~autofoo
++++ dpkg-1.10.23/configure.in
+@@ -227,21 +227,36 @@
+ # OpenBSD passes AC_TRY_COMPILE for va_copy even though
+ # it doesn't seem to exist, which is odd. We need to use
+ # AC_TRY_RUN.
++#
++# If crosscompiling, use AC_TRY_COMPILE. -CL
+ AC_TRY_RUN([
+ #include <stdarg.h>
+ main(){
+ va_list v1,v2;
+ va_copy(v1, v2);
+ exit(0);}
+-], [AC_MSG_RESULT(yes)
+-AC_DEFINE(HAVE_VA_COPY,,[Whether the va_copy macro exists])],[AC_MSG_RESULT(no)
+-AC_MSG_CHECKING([for va_list assignment copy])
++], [dpkg_cv_va_copy=yes], [dpkg_cv_va_copy=no],
+ AC_TRY_COMPILE([
+ #include <stdarg.h>
++main(){
++va_list v1,v2;
++va_copy(v1, v2);
++exit(0);}
++], [dpkg_cv_va_copy=yes], [dpkg_vc_va_copy=no]))
++
++if test "$dpkg_cv_va_copy" = "yes"; then
++ AC_MSG_RESULT(yes)
++ AC_DEFINE(HAVE_VA_COPY,,[Whether the va_copy macro exists])
++else
++ AC_MSG_RESULT(no)
++ AC_MSG_CHECKING([for va_list assignment copy])
++ AC_TRY_COMPILE([
++#include <stdarg.h>
+ ],[
+ va_list v1,v2;
+ v1 = v2;
+-], AC_MSG_RESULT(yes),AC_MSG_ERROR(no))])
++], AC_MSG_RESULT(yes), AC_MSG_ERROR(no))
++fi
+
+ DPKG_C_GCC_ATTRIBUTE([,,],supported,[int x],[,,],ATTRIB,[Define if function attributes a la GCC 2.5 and higher are available.],
+ DPKG_C_GCC_ATTRIBUTE(noreturn,noreturn,[int x],noreturn,NORETURN,[Define if nonreturning functions a la GCC 2.5 and higher are available.])
diff --git a/recipes/dpkg/files/ignore_extra_fields.patch b/recipes/dpkg/files/ignore_extra_fields.patch
new file mode 100644
index 0000000000..43878463e9
--- /dev/null
+++ b/recipes/dpkg/files/ignore_extra_fields.patch
@@ -0,0 +1,21 @@
+ dpkg-deb/build.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+Index: dpkg-1.13.22/dpkg-deb/build.c
+===================================================================
+--- dpkg-1.13.22.orig/dpkg-deb/build.c 2006-05-19 23:11:08.000000000 +0100
++++ dpkg-1.13.22/dpkg-deb/build.c 2006-11-17 14:43:20.000000000 +0000
+@@ -220,11 +220,11 @@ void do_build(const char *const *argv) {
+ controlfile, checkedinfo->otherpriority);
+ warns++;
+ }
+- for (field= checkedinfo->available.arbs; field; field= field->next) {
++ /*for (field= checkedinfo->available.arbs; field; field= field->next) {
+ fprintf(stderr, _("warning, `%s' contains user-defined field `%s'\n"),
+ controlfile, field->name);
+ warns++;
+- }
++ }*/
+ checkversion(checkedinfo->available.version.version,"(upstream) version",&errs);
+ checkversion(checkedinfo->available.version.revision,"Debian revision",&errs);
+ if (errs) ohshit(_("%d errors in control file"),errs);
diff --git a/recipes/dpkg/files/nochroot.patch b/recipes/dpkg/files/nochroot.patch
new file mode 100644
index 0000000000..3a8beaebbf
--- /dev/null
+++ b/recipes/dpkg/files/nochroot.patch
@@ -0,0 +1,18 @@
+---
+ src/help.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+--- dpkg-1.13.22.orig/src/help.c
++++ dpkg-1.13.22/src/help.c
+@@ -175,9 +175,11 @@ static const char* preexecscript(const c
+ */
+ size_t instdirl;
+
++#if 0
+ if (*instdir) {
+ if (chroot(instdir)) ohshite(_("failed to chroot to `%.250s'"),instdir);
+ }
++#endif
+ if (f_debug & dbg_scripts) {
+ fprintf(stderr,"D0%05o: fork/exec %s (",dbg_scripts,path);
+ while (*++argv) fprintf(stderr," %s",*argv);
diff --git a/recipes/dpkg/files/noman.patch b/recipes/dpkg/files/noman.patch
new file mode 100644
index 0000000000..f5984fe14a
--- /dev/null
+++ b/recipes/dpkg/files/noman.patch
@@ -0,0 +1,16 @@
+---
+ Makefile.am | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+--- dpkg-1.13.22.orig/Makefile.am
++++ dpkg-1.13.22/Makefile.am
+@@ -15,8 +15,7 @@ SUBDIRS = \
+ utils \
+ scripts \
+ po \
+- origins \
+- man
++ origins
+
+ ACLOCAL_AMFLAGS = -I m4
+
diff --git a/recipes/dpkg/files/noupdalt.patch b/recipes/dpkg/files/noupdalt.patch
new file mode 100644
index 0000000000..023e99ae8d
--- /dev/null
+++ b/recipes/dpkg/files/noupdalt.patch
@@ -0,0 +1,16 @@
+---
+ scripts/Makefile.am | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+--- dpkg-1.13.22.orig/scripts/Makefile.am
++++ dpkg-1.13.22/scripts/Makefile.am
+@@ -20,8 +20,7 @@ bin_SCRIPTS = \
+ sbin_SCRIPTS = \
+ cleanup-info \
+ dpkg-divert \
+- dpkg-statoverride \
+- update-alternatives
++ dpkg-statoverride
+
+ changelogdir = $(pkglibdir)/parsechangelog
+ changelog_SCRIPTS = \