aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/driftnet/driftnet-0.1.6/arm.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/driftnet/driftnet-0.1.6/arm.patch')
-rw-r--r--recipes/driftnet/driftnet-0.1.6/arm.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/recipes/driftnet/driftnet-0.1.6/arm.patch b/recipes/driftnet/driftnet-0.1.6/arm.patch
new file mode 100644
index 0000000000..340a6cf186
--- /dev/null
+++ b/recipes/driftnet/driftnet-0.1.6/arm.patch
@@ -0,0 +1,55 @@
+--- driftnet-0.1.6/Makefile~ 2004-12-07 23:26:53.211878920 +0000
++++ driftnet-0.1.6/Makefile 2004-12-07 23:25:59.900983408 +0000
+@@ -13,14 +13,14 @@
+ #
+
+ # Compiler to use.
+-#CC = gcc
++CC = arm-linux-gcc
+
+ # Basic compiler, linker flags; should not need any changes.
+ CFLAGS += -g -Wall
+ LDFLAGS += -g
+
+ # You might need these if libpcap is installed somewhere random.
+-CFLAGS += -I/usr/include/pcap
++#CFLAGS += -I/usr/include/pcap
+ #LDFLAGS += -L/path/to/libpcap.so
+
+ # Required on Linux to get BSDish definitions of the TCP/IP structs.
+@@ -31,8 +31,8 @@
+
+ # Optional C compiler and linker flags. Typical driftnet builds have support
+ # for displaying captured images in an X window, and need the following flags:
+-CFLAGS += `gtk-config --cflags`
+-LDLIBS += -ljpeg -lungif `gtk-config --libs`
++CFLAGS += -I$(STAGING_INCDIR)/glib-2.0 -I$(STAGING_INCDIR)/gtk-2.0 -I$(STAGING_INCDIR)/../lib/gtk-2.0/include -I$(STAGING_INCDIR)/atk-1.0
++LDLIBS += -ljpeg -lungif -lgtk-x11-2.0 -lgdk-x11-2.0 -rdynamic -lgmodule-2.0 -lglib-2.0 -ldl -lXext -lX11 -lm
+
+ # Alternatively, you can build a version of driftnet which can only be used
+ # in `adjunct' mode as the back end for some other image-processing program. To
+@@ -81,13 +81,13 @@
+ ( echo '.\" DO NOT EDIT THIS FILE-- edit driftnet.1.in instead' ; sed s/@@@VERSION@@@/$(VERSION)/ ) < driftnet.1.in > driftnet.1
+
+ endianness: endian
+- ./endian > endianness
++
+
+ endian: endian.c
+ $(CC) $(CFLAGS) -o endian endian.c
+
+ %.o: %.c Makefile endianness
+- $(CC) $(CFLAGS) `cat endianness` -c -o $@ $<
++ $(CC) $(CFLAGS) -DDRIFTNET_LITTLE_ENDIAN -c -o $@ $<
+
+ clean: nodepend
+ rm -f *~ *.bak *.o core $(BINS) TAGS driftnet.1 endian endianness
+@@ -103,7 +103,7 @@
+ mv driftnet-$(VERSION).tar.gz ..
+
+ depend: endianness
+- makedepend -- $(CFLAGS) `cat endianness` -- $(SRCS)
++ makedepend -- $(CFLAGS) -DDRIFTNET_LITTLE_ENDIAN -- $(SRCS)
+ touch depend
+ rm -f Makefile.bak
+