aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dropbear/dropbear-0.49
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dropbear/dropbear-0.49')
-rw-r--r--recipes/dropbear/dropbear-0.49/configure.patch27
-rw-r--r--recipes/dropbear/dropbear-0.49/scp-argument-fix.patch21
2 files changed, 48 insertions, 0 deletions
diff --git a/recipes/dropbear/dropbear-0.49/configure.patch b/recipes/dropbear/dropbear-0.49/configure.patch
new file mode 100644
index 0000000000..8d11b23f14
--- /dev/null
+++ b/recipes/dropbear/dropbear-0.49/configure.patch
@@ -0,0 +1,27 @@
+Index: dropbear-0.49/configure.in
+===================================================================
+--- dropbear-0.49.orig/configure.in
++++ dropbear-0.49/configure.in
+@@ -164,14 +164,20 @@ AC_ARG_ENABLE(openpty,
+ AC_MSG_NOTICE(Not using openpty)
+ else
+ AC_MSG_NOTICE(Using openpty if available)
+- AC_SEARCH_LIBS(openpty, util, [AC_DEFINE(HAVE_OPENPTY,,Have openpty() function)])
++ AC_SEARCH_LIBS(openpty, util, [dropbear_cv_func_have_openpty=yes])
+ fi
+ ],
+ [
+ AC_MSG_NOTICE(Using openpty if available)
+- AC_SEARCH_LIBS(openpty, util, [AC_DEFINE(HAVE_OPENPTY)])
++ AC_SEARCH_LIBS(openpty, util, [dropbear_cv_func_have_openpty=yes])
+ ]
+ )
++
++if test "x$dropbear_cv_func_have_openpty" = "xyes"; then
++ AC_DEFINE(HAVE_OPENPTY,,Have openpty() function)
++ no_ptc_check=yes
++ no_ptmx_check=yes
++fi
+
+
+ AC_ARG_ENABLE(syslog,
diff --git a/recipes/dropbear/dropbear-0.49/scp-argument-fix.patch b/recipes/dropbear/dropbear-0.49/scp-argument-fix.patch
new file mode 100644
index 0000000000..716a9670fe
--- /dev/null
+++ b/recipes/dropbear/dropbear-0.49/scp-argument-fix.patch
@@ -0,0 +1,21 @@
+source: https://dev.openwrt.org/browser/trunk/openwrt/package/dropbear/patches/scp-argument-fix.patch?rev=453
+comment: remove unsupported default arguments in scp. Fixes OE bug 3227.
+
+diff -ur dropbear-0.49-orig/scp.c dropbear-0.49/scp.c
+--- dropbear-0.49-orig/scp.c 2007-02-22 16:51:35.000000000 +0100
++++ dropbear-0.49/scp.c 2007-10-19 14:19:08.000000000 +0200
+@@ -308,10 +308,10 @@
+ memset(&args, '\0', sizeof(args));
+ args.list = NULL;
+ addargs(&args, "%s", ssh_program);
+- addargs(&args, "-x");
+- addargs(&args, "-oForwardAgent no");
+- addargs(&args, "-oPermitLocalCommand no");
+- addargs(&args, "-oClearAllForwardings yes");
++// addargs(&args, "-x");
++// addargs(&args, "-oForwardAgent no");
++// addargs(&args, "-oPermitLocalCommand no");
++// addargs(&args, "-oClearAllForwardings yes");
+
+ fflag = tflag = 0;
+ while ((ch = getopt(argc, argv, "dfl:prtvBCc:i:P:q1246S:o:F:")) != -1)