aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dropbear/dropbear-early_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dropbear/dropbear-early_1.0.bb')
-rw-r--r--recipes/dropbear/dropbear-early_1.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/dropbear/dropbear-early_1.0.bb b/recipes/dropbear/dropbear-early_1.0.bb
new file mode 100644
index 0000000000..c947cf0e74
--- /dev/null
+++ b/recipes/dropbear/dropbear-early_1.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Allow to start dropbear soon after boot, depending on kernel command line option."
+SECTION = "devel"
+RDEPENDS = "dropbear"
+PR = "r3"
+
+SRC_URI = "file://dropbear-early"
+
+inherit update-rc.d
+
+do_install() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/
+}
+
+PACKAGE_ARCH = "all"
+
+INITSCRIPT_NAME = "dropbear-early"
+INITSCRIPT_PARAMS = "start 00 S ."