summaryrefslogtreecommitdiffstats
path: root/recipes/duma/duma_2.5.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/duma/duma_2.5.7.bb')
-rw-r--r--recipes/duma/duma_2.5.7.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/duma/duma_2.5.7.bb b/recipes/duma/duma_2.5.7.bb
new file mode 100644
index 0000000000..9f50c356a6
--- /dev/null
+++ b/recipes/duma/duma_2.5.7.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A Red-Zone memory allocator to detect unintended memory access"
+HOMEPAGE = "http://duma.sourceforge.net"
+LICENSE = "GPL LGPL"
+SECTION = "devel"
+DEPENDS = "qemu-native"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/duma/duma_2_5_7.tar.gz"
+
+S = "${WORKDIR}/duma_2_5_7"
+
+EXTRA_OECONF = "-e"
+
+do_configure () {
+ oe_runmake createconf
+ qemu-${TARGET_ARCH} -L ${STAGING_DIR_HOST} ./createconf
+}
+
+do_compile () {
+ oe_runmake libduma.a libduma.so.0.0
+}
+
+do_install () {
+ install -d ${D}${base_bindir}
+ install -d ${D}${base_libdir}
+ install -d ${D}${mandir}/man3
+ oe_runmake install prefix="${D}" MAN_INSTALL_DIR="${D}${mandir}/man3"
+}