aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e17/enjoy_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/e17/enjoy_svn.bb')
-rw-r--r--recipes/e17/enjoy_svn.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/e17/enjoy_svn.bb b/recipes/e17/enjoy_svn.bb
new file mode 100644
index 0000000000..3dc7fd7a76
--- /dev/null
+++ b/recipes/e17/enjoy_svn.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Enjoy music player"
+LICENSE = "LGPLv3"
+DEPENDS = "evas ecore edje emotion lightmediascanner"
+SRCREV = "${EFL_SRCREV}"
+PV = "0.0+svnr${SRCPV}"
+
+#1st needed for all formats
+#2nd needed for mp3 playback
+#3d needed for ogg playback
+#4th needed for flac playback
+#5th needed binary to create db
+RDEPENDS += "\
+ gst-plugin-typefindfunctions gst-plugin-playbin \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugin-lame gst-plugin-id3demux', d)} \
+ gst-plugin-ogg gst-plugin-ivorbisdec \
+ gst-plugin-flac \
+ lightmediascanner-test \
+ "
+
+inherit e
+
+
+EXTRA_OECONF = "\
+ --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
+"
+
+
+pkg_postinst_${PN} () {
+ echo "enjoy: SCAN and LIBRARY MANAGER are not implemeted yet!"
+ echo "enjoy: Meanwhile please run:"
+ echo "enjoy: test-lms -m mono -p id3 -i 5000 -s /path/to/your/music/dir /home/root/.config/enjoy/media.db"
+ echo "enjoy:"
+ echo "enjoy: Use test-lms -P to see available formats that can be scanned"
+}