aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e17/entrance
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/e17/entrance')
-rw-r--r--recipes/e17/entrance/Sessions/Enlightenment3
-rw-r--r--recipes/e17/entrance/Sessions/Failsafe3
-rw-r--r--recipes/e17/entrance/Xserver.patch22
-rw-r--r--recipes/e17/entrance/allow-missing-xsession.patch19
-rw-r--r--recipes/e17/entrance/config-db.patch118
-rw-r--r--recipes/e17/entrance/disable-autodetect.patch8
-rw-r--r--recipes/e17/entrance/fix-auth-mode.patch13
-rw-r--r--recipes/e17/entrance/run-Xinit.patch17
-rw-r--r--recipes/e17/entrance/set-display-env.patch11
-rw-r--r--recipes/e17/entrance/use-bash.patch57
10 files changed, 271 insertions, 0 deletions
diff --git a/recipes/e17/entrance/Sessions/Enlightenment b/recipes/e17/entrance/Sessions/Enlightenment
new file mode 100644
index 0000000000..61498c2c6c
--- /dev/null
+++ b/recipes/e17/entrance/Sessions/Enlightenment
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+enlightenment_start
diff --git a/recipes/e17/entrance/Sessions/Failsafe b/recipes/e17/entrance/Sessions/Failsafe
new file mode 100644
index 0000000000..cf4fcced12
--- /dev/null
+++ b/recipes/e17/entrance/Sessions/Failsafe
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+rxvt \ No newline at end of file
diff --git a/recipes/e17/entrance/Xserver.patch b/recipes/e17/entrance/Xserver.patch
new file mode 100644
index 0000000000..296a7bccf4
--- /dev/null
+++ b/recipes/e17/entrance/Xserver.patch
@@ -0,0 +1,22 @@
+--- entrance/src/daemon/Entranced.h.~1.7.~ 2004-05-19 21:02:09.000000000 -0700
++++ entrance/src/daemon/Entranced.h 2005-08-13 02:00:02.000000000 -0700
+@@ -18,7 +18,7 @@
+
+ #define ENTRANCED_DEBUG 1
+
+-#define X_SERVER "/usr/X11R6/bin/X -quiet"
++#define X_SERVER "/etc/X11/Xserver"
+ //#define X_SERVER "/usr/X11R6/bin/Xnest -full"
+ #define X_DISP ":0" /* only used if DISPLAY variable is NOT set */
+ #define ENTRANCE PREFIX "/bin/entrance_wrapper"
+--- entrance/src/daemon/spawner.c.~1.25.~ 2005-05-28 02:31:14.000000000 -0700
++++ entrance/src/daemon/spawner.c 2005-08-13 02:20:13.000000000 -0700
+@@ -155,7 +155,7 @@
+ sigaction(SIGUSR1, &_entrance_x_sa, NULL);
+ /* FIXME: need to parse command and NOT go thru /bin/sh!!!! */
+ /* why? some /bin/sh's wont pass on this SIGUSR1 thing... */
+- execl("/bin/sh", "/bin/sh", "-c", x_cmd, NULL);
++ execl("/bin/bash", "/bin/bash", "-c", x_cmd, NULL);
+ syslog(LOG_WARNING, "Could not execute X server.");
+ exit(1);
+ default:
diff --git a/recipes/e17/entrance/allow-missing-xsession.patch b/recipes/e17/entrance/allow-missing-xsession.patch
new file mode 100644
index 0000000000..e0ebe6e0e9
--- /dev/null
+++ b/recipes/e17/entrance/allow-missing-xsession.patch
@@ -0,0 +1,19 @@
+Index: entrance/configure.ac
+===================================================================
+--- entrance.orig/configure.ac 2009-02-17 10:59:20.000000000 +0000
++++ entrance/configure.ac 2009-02-17 13:09:51.000000000 +0000
+@@ -198,10 +198,10 @@
+ fi
+ ]
+ )
+-if test ! -x "$xsession" ; then
+- AC_MSG_WARN([** $xsession does not exist or is not executable **])
+- AC_MSG_WARN([** Please consider overriding with --with-xsession **])
+-fi
++#if test ! -x "$xsession" ; then
++# AC_MSG_WARN([** $xsession does not exist or is not executable **])
++# AC_MSG_WARN([** Please consider overriding with --with-xsession **])
++#fi
+
+ AC_DEFINE_UNQUOTED(ENTRANCE_XSESSION, "$xsession", [Xsession script])
+ AC_SUBST(xsession)
diff --git a/recipes/e17/entrance/config-db.patch b/recipes/e17/entrance/config-db.patch
new file mode 100644
index 0000000000..89e18ccff4
--- /dev/null
+++ b/recipes/e17/entrance/config-db.patch
@@ -0,0 +1,118 @@
+Index: entrance/data/config/build_config.sh.in
+===================================================================
+--- entrance.orig/data/config/build_config.sh.in 2009-02-17 10:59:01.000000000 +0000
++++ entrance/data/config/build_config.sh.in 2009-02-17 13:45:06.000000000 +0000
+@@ -1,45 +1,45 @@
+ #!/bin/sh -e
+
+-usage() {
+- cat <<-EOF
+- Usage: $0 [options]
+-
+- Options:
+- -d, --dir Session directory to scan
+- -c, --file Config file (default: $DB)
+- -h, --help This help output :p
+- EOF
+-
+- if [ "$1" = "1" ] ; then
+- echo ""
+- echo "ERROR: $2"
+- fi
+-
+- exit $1
+-}
+-
+-SESSION_DIR=""
++#usage() {
++# cat <<-EOF
++# Usage: $0 [options]
++#
++# Options:
++# -d, --dir Session directory to scan
++# -c, --file Config file (default: $DB)
++# -h, --help This help output :p
++# EOF
++#
++# if [ "$1" = "1" ] ; then
++# echo ""
++# echo "ERROR: $2"
++# fi
++#
++# exit $1
++#}
++#
++#SESSION_DIR=""
+ DB="./entrance_config.cfg"
+-
+-while [ -n "$1" ] ; do
+- case $1 in
+- -d) shift; SESSION_DIR=$1;;
+- -c) shift; DB=$1;;
+- -h) usage 0;;
+- *) usage 1 "Unknown option: $1";;
+- esac
+- shift
+-done
+-
+-if [ -z "$DB" ] || [ -d "$DB" ] ; then
+- usage 1 "Invalid DB argument"
+-fi
+-
+-FROM=$SESSION_DIR
+-if [ -z "$FROM" ] ; then
+- FROM="defaults"
+-fi
+-echo "Generating config file '$DB' from '$FROM' ..."
++#
++#while [ -n "$1" ] ; do
++# case $1 in
++# -d) shift; SESSION_DIR=$1;;
++# -c) shift; DB=$1;;
++# -h) usage 0;;
++# *) usage 1 "Unknown option: $1";;
++# esac
++# shift
++#done
++#
++#if [ -z "$DB" ] || [ -d "$DB" ] ; then
++# usage 1 "Invalid DB argument"
++#fi
++#
++#FROM=$SESSION_DIR
++#if [ -z "$FROM" ] ; then
++# FROM="defaults"
++#fi
++echo "Generating config file '$DB' ..."
+
+ rm -f $DB || exit 1
+
+@@ -59,10 +59,10 @@
+ #ecore_config -c $DB -k /entrance/fonts/0/-s -s "/usr/share/fonts/truetype/"
+ #ecore_config -c $DB -k /entrance/fonts/1/-s -s "/usr/X11R6/lib/X11/fonts/Truetype/"
+ ecore_config -c $DB -k /entrance/greeting/before -s "Welcome to"
+-ecore_config -c $DB -k /entrance/greeting/after -s ""
++ecore_config -c $DB -k /entrance/greeting/after -s " e17/OE"
+
+ count=0
+-ecore_config -c $DB -k /entrance/session/0/session -s "default"
++ecore_config -c $DB -k /entrance/session/0/session -s "/etc/X11/Sessions/Enlightenment"
+ ecore_config -c $DB -k /entrance/session/0/title -s "Default"
+ ecore_config -c $DB -k /entrance/session/0/icon -s "default.png"
+ #if [ -z "$SESSION_DIR" ] ; then
+@@ -92,7 +92,7 @@
+ # done
+ #fi
+ count=`(expr $count + 1)`
+-ecore_config -c $DB -k /entrance/session/$count/session -s "failsafe"
++ecore_config -c $DB -k /entrance/session/$count/session -s "/etc/X11/Sessions/Enlightenment"
+ ecore_config -c $DB -k /entrance/session/$count/title -s "Failsafe"
+ ecore_config -c $DB -k /entrance/session/$count/icon -s "failsafe.png"
+ count=`(expr $count + 1)`
+@@ -107,5 +107,5 @@
+ ecore_config -c $DB -k /entrance/presel/mode -i 1
+
+ # for Entranced
+-ecore_config -c $DB -k /entranced/xserver -s "@xbin@/X -quiet -br -nolisten tcp@ENTRANCE_VT_ARG@"
++ecore_config -c $DB -k /entranced/xserver -s "/etc/X11/Xserver"
+ ecore_config -c $DB -k /entranced/attempts -i 5
diff --git a/recipes/e17/entrance/disable-autodetect.patch b/recipes/e17/entrance/disable-autodetect.patch
new file mode 100644
index 0000000000..a0412b3706
--- /dev/null
+++ b/recipes/e17/entrance/disable-autodetect.patch
@@ -0,0 +1,8 @@
+diff -Nur entrance-0.9.0.007~/Makefile.am entrance-0.9.0.007/Makefile.am
+--- entrance-0.9.0.007~/Makefile.am 2006-05-11 12:18:07.000000000 -0700
++++ entrance-0.9.0.007/Makefile.am 2006-05-11 13:01:41.000000000 -0700
+@@ -23,4 +23,3 @@
+ fi
+
+ install-data-am:
+- sh data/config/autodetect.sh || :
diff --git a/recipes/e17/entrance/fix-auth-mode.patch b/recipes/e17/entrance/fix-auth-mode.patch
new file mode 100644
index 0000000000..46e530b256
--- /dev/null
+++ b/recipes/e17/entrance/fix-auth-mode.patch
@@ -0,0 +1,13 @@
+Index: entrance-0.9.0.009/data/config/build_config.sh.in
+===================================================================
+--- entrance-0.9.0.009.orig/data/config/build_config.sh.in
++++ entrance-0.9.0.009/data/config/build_config.sh.in
+@@ -44,7 +44,7 @@
+ rm -f $DB || exit 1
+
+ # set auth to 1 for pam, 2 for shadow
+-ecore_config -c $DB -k /entrance/auth -i @auth_mode@
++ecore_config -c $DB -k /entrance/auth -i 0
+
+ # uncomment the below to enable experimental OpenGL hardware acceleration
+ #ecore_config -c $DB -k /entrance/engine -i 1
diff --git a/recipes/e17/entrance/run-Xinit.patch b/recipes/e17/entrance/run-Xinit.patch
new file mode 100644
index 0000000000..1d6c2307f7
--- /dev/null
+++ b/recipes/e17/entrance/run-Xinit.patch
@@ -0,0 +1,17 @@
+--- entrance/src/daemon/entrance_wrapper.in.~1.1.~ 2003-01-31 13:57:06.000000000 -0800
++++ entrance/src/daemon/entrance_wrapper.in 2005-08-15 20:13:57.000000000 -0700
+@@ -5,8 +5,13 @@
+
+ test -f /etc/profile && . /etc/profile
+
++if [ -x /etc/X11/Xinit.d/99gpe-login ]; then
++ chmod -x /etc/X11/Xinit.d/99gpe-login
++fi
++
++/etc/X11/Xinit
++
+ exec @prefix@/bin/entrance "$@"
+
+ #fallback
+ exec entrance "$@"
+-
diff --git a/recipes/e17/entrance/set-display-env.patch b/recipes/e17/entrance/set-display-env.patch
new file mode 100644
index 0000000000..37bfc1c2c8
--- /dev/null
+++ b/recipes/e17/entrance/set-display-env.patch
@@ -0,0 +1,11 @@
+diff -Nur entrance~/src/daemon/spawner.c entrance/src/daemon/spawner.c
+--- entrance~/src/daemon/spawner.c 2005-09-02 14:00:29.000000000 -0700
++++ entrance/src/daemon/spawner.c 2005-09-02 15:53:31.000000000 -0700
+@@ -199,6 +199,7 @@
+ free(d->client.homedir);
+ d->client.homedir = NULL;
+
++ setenv("DISPLAY", d->name, 1);
+ snprintf(entrance_cmd, PATH_MAX, "%s -d %s", ENTRANCE, d->name);
+ if (d->config)
+ snprintf(entrance_cmd, PATH_MAX, "%s -d %s -c \"%s\" -z %d",
diff --git a/recipes/e17/entrance/use-bash.patch b/recipes/e17/entrance/use-bash.patch
new file mode 100644
index 0000000000..7dfab83711
--- /dev/null
+++ b/recipes/e17/entrance/use-bash.patch
@@ -0,0 +1,57 @@
+Index: entrance-0.9.0.009/src/client/entrance_session.c
+===================================================================
+--- entrance-0.9.0.009.orig/src/client/entrance_session.c
++++ entrance-0.9.0.009/src/client/entrance_session.c
+@@ -854,7 +854,7 @@ _entrance_session_execute_in_shell(char
+ if (shell && (strlen(shell) > 0))
+ shell_cmd = shell;
+ else
+- shell_cmd = strdup("/bin/sh");
++ shell_cmd = strdup("/bin/bash");
+
+ if (session_name)
+ snprintf(buf, sizeof(buf), "%s %s", session_cmd, session_name);
+@@ -869,9 +869,9 @@ _entrance_session_execute_in_shell(char
+ if (res == -1)
+ /* TODO: should actually hit the user in the face with this message */
+ syslog(LOG_NOTICE,
+- "Neither '%s' or '/bin/sh' are working login shells for user '%s'. Your session may not function properly. ",
++ "Neither '%s' or '/bin/bash' are working login shells for user '%s'. Your session may not function properly. ",
+ shell, user);
+- shell_cmd = strdup("/bin/sh");
++ shell_cmd = strdup("/bin/bash");
+
+ res = execlp(shell_cmd, shell_cmd, "-c", buf, NULL);
+
+Index: entrance-0.9.0.009/src/client/main.c
+===================================================================
+--- entrance-0.9.0.009.orig/src/client/main.c
++++ entrance-0.9.0.009/src/client/main.c
+@@ -453,7 +453,7 @@ reboot_cb(void *data, Evas_Object * o, c
+ {
+ case 0:
+ if (execl
+- ("/bin/sh", "/bin/sh", "-c", "/sbin/shutdown -r now", NULL))
++ ("/bin/bash", "/bin/bash", "-c", "/sbin/shutdown -r now", NULL))
+ {
+ syslog(LOG_CRIT,
+ "Reboot failed: Unable to execute /sbin/shutdown");
+@@ -495,7 +495,7 @@ shutdown_cb(void *data, Evas_Object * o,
+ {
+ case 0:
+ if (execl
+- ("/bin/sh", "/bin/sh", "-c", "/sbin/shutdown -h now", NULL))
++ ("/bin/bash", "/bin/bash", "-c", "/sbin/shutdown -h now", NULL))
+ {
+ syslog(LOG_CRIT,
+ "Shutdown failed: Unable to execute /sbin/shutdown");
+Index: entrance-0.9.0.009/src/daemon/entrance_wrapper.in
+===================================================================
+--- entrance-0.9.0.009.orig/src/daemon/entrance_wrapper.in
++++ entrance-0.9.0.009/src/daemon/entrance_wrapper.in
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/bash
+ # Wrapper script to set up login environment:
+ # Load up all the junk in /etc/profile first, and then
+ # pass control to entrance proper.