aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e17
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/e17')
-rw-r--r--recipes/e17/e-tasks/depends.eina.patch12
-rw-r--r--recipes/e17/e-tasks_svn.bb7
-rw-r--r--recipes/e17/e-wm_svn.bb48
-rw-r--r--recipes/e17/edje-editor_svn.bb14
-rw-r--r--recipes/e17/edje-player_svn.bb15
-rw-r--r--recipes/e17/elementary-alarm_svn.bb4
-rw-r--r--recipes/e17/elmdentica_svn.bb5
-rw-r--r--recipes/e17/entrance_0.9.0.010.bb14
-rw-r--r--recipes/e17/eve/default.theme.remove.min.size.patch19
-rw-r--r--recipes/e17/eve_svn.bb16
-rw-r--r--recipes/e17/exalt_svn.bb3
-rw-r--r--recipes/e17/exhibit_svn.bb10
-rw-r--r--recipes/e17/expedite_svn.bb4
-rw-r--r--recipes/e17/exquisite_svn.bb4
-rw-r--r--recipes/e17/illume-keyboard-default_svn.bb44
-rw-r--r--recipes/e17/illume-keyboards-shr/0001-Makefile-update-KEYBOARDS_DIR-for-new-illume2.patch23
-rw-r--r--recipes/e17/illume-keyboards-shr_git.bb7
-rw-r--r--recipes/e17/intuition_svn.bb2
-rw-r--r--recipes/e17/places_svn.bb9
19 files changed, 129 insertions, 131 deletions
diff --git a/recipes/e17/e-tasks/depends.eina.patch b/recipes/e17/e-tasks/depends.eina.patch
new file mode 100644
index 0000000000..6e1981edb8
--- /dev/null
+++ b/recipes/e17/e-tasks/depends.eina.patch
@@ -0,0 +1,12 @@
+diff -uNr trunk.orig//configure.ac trunk/configure.ac
+--- trunk.orig//configure.ac 2009-12-18 12:59:52.000000000 +0100
++++ trunk/configure.ac 2010-08-22 23:22:52.000000000 +0200
+@@ -15,7 +15,7 @@
+
+ AM_PROG_LIBTOOL
+
+-PKG_CHECK_MODULES(TASKS, [elementary eina-0 dbus-1 sqlite3])
++PKG_CHECK_MODULES(TASKS, [elementary eina dbus-1 sqlite3])
+
+ AC_OUTPUT([
+ Makefile
diff --git a/recipes/e17/e-tasks_svn.bb b/recipes/e17/e-tasks_svn.bb
index 28bc900f98..2d8861401a 100644
--- a/recipes/e17/e-tasks_svn.bb
+++ b/recipes/e17/e-tasks_svn.bb
@@ -7,11 +7,12 @@ DEPENDS = "elementary eina edbus sqlite3"
inherit autotools
-SRCREV = "24"
+SRCREV = "25"
PV = "0.0.1+svnr${SRCPV}"
-PR = "r1"
+PR = "r6"
-SRC_URI = "svn://e-tasks.googlecode.com/svn;module=trunk;proto=http"
+SRC_URI = "svn://e-tasks.googlecode.com/svn;module=trunk;proto=http \
+ file://depends.eina.patch"
S = "${WORKDIR}/trunk"
do_install_append() {
diff --git a/recipes/e17/e-wm_svn.bb b/recipes/e17/e-wm_svn.bb
index 2ab6b82198..4871e3bba4 100644
--- a/recipes/e17/e-wm_svn.bb
+++ b/recipes/e17/e-wm_svn.bb
@@ -3,7 +3,7 @@ DEPENDS = "eet evas ecore edje efreet edbus"
LICENSE = "MIT BSD"
SRCNAME = "e"
PV = "0.16.999.060+svnr${SRCPV}"
-PR = "r13"
+PR = "r16"
SRCREV = "${EFL_SRCREV}"
inherit e update-alternatives
@@ -11,18 +11,17 @@ inherit e update-alternatives
SRC_URI += "\
file://enlightenment_start.oe \
file://applications.menu \
- file://gsm-segfault-fix.patch;patch=1;maxrev=37617 \
- file://fix-profiles.diff;patch=1;maxrev=39889 \
- file://drop-illume-keyboards.patch;patch=1 \
+ file://gsm-segfault-fix.patch;maxrev=37617 \
+ file://fix-profiles.diff;maxrev=39889 \
"
-SRC_URI_append_openmoko = " file://illume-disable-screensaver.patch;patch=1"
+SRC_URI_append_openmoko = " file://illume-disable-screensaver.patch"
SRC_URI_append_shr = " \
- file://illume-disable-screensaver.patch;patch=1 \
- file://wizard-module-skipping.patch;patch=1 \
- file://illume-flaunch-fix.patch;patch=1 \
- file://illume-keyboard-flow.patch;patch=1;maxrev=46549 \
+ file://illume-disable-screensaver.patch \
+ file://wizard-module-skipping.patch \
+ file://illume-flaunch-fix.patch \
+ file://illume-keyboard-flow.patch;maxrev=46549 \
"
EXTRA_OECONF = "\
@@ -62,6 +61,7 @@ RREPLACES_${PN} = "systray"
PACKAGES =+ "\
${PN}-config-default \
${PN}-config-illume \
+ ${PN}-config-illume2 \
${PN}-config-minimalist \
${PN}-config-netbook \
${PN}-config-scaleable \
@@ -77,6 +77,9 @@ PACKAGES =+ "\
${PN}-sysactions \
${PN}-utils \
${PN}-menu \
+ illume-keyboard-default-alpha \
+ illume-keyboard-default-numeric \
+ illume-keyboard-default-terminal \
"
RRECOMMENDS_${PN} = "\
@@ -90,6 +93,7 @@ RRECOMMENDS_${PN} = "\
PACKAGE_ARCH_${PN}-config-default = "all"
PACKAGE_ARCH_${PN}-config-illume = "all"
+PACKAGE_ARCH_${PN}-config-illume2 = "all"
PACKAGE_ARCH_${PN}-config-minimalist = "all"
PACKAGE_ARCH_${PN}-config-netbook = "all"
PACKAGE_ARCH_${PN}-config-scaleable = "all"
@@ -104,6 +108,9 @@ PACKAGE_ARCH_${PN}-other = "all"
PACKAGE_ARCH_${PN}-input-methods = "all"
PACKAGE_ARCH_${PN}-sysactions = "all"
PACKAGE_ARCH_${PN}-menu = "all"
+PACKAGE_ARCH_illume-keyboard-default-alpha = "all"
+PACKAGE_ARCH_illume-keyboard-default-numeric = "all"
+PACKAGE_ARCH_illume-keyboard-default-terminal = "all"
FILES_${PN} = "\
${bindir}/* \
@@ -112,7 +119,6 @@ FILES_${PN} = "\
${libdir}/enlightenment/modules/*/*/* \
${libdir}/enlightenment/*plugins/*/*/* \
${libdir}/enlightenment/preload/e_precache.so \
- ${datadir}/locale \
${datadir}/enlightenment/data/icons \
${datadir}/enlightenment/data/input_methods \
${datadir}/enlightenment/data/config/profile.cfg \
@@ -120,11 +126,11 @@ FILES_${PN} = "\
${datadir}/enlightenment/COPYING \
${datadir}/xsessions/enlightenment.desktop \
${sysconfdir}/xdg \
- ${datadir}/enlightenment/data/config/illume-home \
"
FILES_${PN}-config-default = "${datadir}/enlightenment/data/config/default"
FILES_${PN}-config-illume = "${datadir}/enlightenment/data/config/illume"
+FILES_${PN}-config-illume2 = "${datadir}/enlightenment/data/config/illume-home"
FILES_${PN}-config-minimalist = "${datadir}/enlightenment/data/config/minimalist"
FILES_${PN}-config-netbook = "${datadir}/enlightenment/data/config/netbook"
FILES_${PN}-config-scaleable = "${datadir}/enlightenment/data/config/scaleable"
@@ -142,6 +148,20 @@ FILES_${PN}-sysactions = "${sysconfdir}/enlightenment/sysactions.conf"
FILES_${PN}-utils = "${libdir}/enlightenment/utils/*"
FILES_${PN}-menu = "${sysconfdir}/xdg/menus/applications.menu"
+KEYBOARDS_DIR="${libdir}/enlightenment/modules/illume-keyboard/keyboards"
+FILES_illume-keyboard-default-alpha = "\
+ ${KEYBOARDS_DIR}/Default.kbd \
+ ${KEYBOARDS_DIR}/alpha.png \
+"
+FILES_illume-keyboard-default-numeric = "\
+ ${KEYBOARDS_DIR}/Numbers.kbd \
+ ${KEYBOARDS_DIR}/numeric.png \
+"
+FILES_illume-keyboard-default-terminal = "\
+ ${KEYBOARDS_DIR}/Terminal.kbd \
+ ${KEYBOARDS_DIR}/qwerty.png \
+"
+
RRECOMMENDS_${PN}-config-default = "${PN}-theme-default"
RRECOMMENDS_${PN}-config-illume = "\
${PN}-theme-illume \
@@ -149,6 +169,12 @@ RRECOMMENDS_${PN}-config-illume = "\
illume-keyboard-default-numeric \
illume-keyboard-default-terminal \
"
+RRECOMMENDS_${PN}-config-illume2 = "\
+ ${PN}-theme-illume \
+ illume-keyboard-default-alpha \
+ illume-keyboard-default-numeric \
+ illume-keyboard-default-terminal \
+"
RRECOMMENDS_${PN}-config-minimalist = "\
${PN}-background-light-gradient \
diff --git a/recipes/e17/edje-editor_svn.bb b/recipes/e17/edje-editor_svn.bb
deleted file mode 100644
index f364f26fd5..0000000000
--- a/recipes/e17/edje-editor_svn.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-DESCRIPTION = "Edje-Editor is just that."
-SECTION = "x11/devel"
-LICENSE = "MIT BSD"
-DEPENDS = "etk"
-SRCNAME = "edje_editor"
-
-PV = "0.0.0+svnr${SRCPV}"
-PR = "r1"
-SRCREV = "${EFL_SRCREV}"
-
-inherit e
-SRC_URI = "svn://svn.enlightenment.org/svn/e/OLD;module=${SRCNAME};proto=http"
-
-FILES_${PN} += "${datadir}"
diff --git a/recipes/e17/edje-player_svn.bb b/recipes/e17/edje-player_svn.bb
deleted file mode 100644
index 40c0c99c94..0000000000
--- a/recipes/e17/edje-player_svn.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "Edje-Player is just that."
-SECTION = "x11/devel"
-LICENSE = "MIT BSD"
-DEPENDS = "etk"
-SRCNAME = "edje_editor"
-PV = "0.0.0+svnr${SRCPV}"
-PR = "r0"
-SRCREV = "${EFL_SRCREV}"
-
-inherit e
-
-SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/PROTO;module=edje_player;proto=http"
-S = "${WORKDIR}/edje_player"
-
-FILES_${PN} += "${datadir}"
diff --git a/recipes/e17/elementary-alarm_svn.bb b/recipes/e17/elementary-alarm_svn.bb
index 9fee65dc98..24bbd60945 100644
--- a/recipes/e17/elementary-alarm_svn.bb
+++ b/recipes/e17/elementary-alarm_svn.bb
@@ -3,7 +3,7 @@ LICENSE = "GPL"
DEPENDS = "elementary"
SECTION = "x11"
PV = "0.0.0+svnr${SRCPV}"
-PR = "r1"
+PR = "r2"
SRCREV = "${EFL_SRCREV}"
inherit e
@@ -11,7 +11,7 @@ inherit e
SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/TMP/st;module=elementary-alarm;proto=http"
S = "${WORKDIR}/elementary-alarm"
-RDEPENDS = "waker"
+RDEPENDS_${PN} = "waker"
FILES_${PN} += "${bindir}/*"
FILES_${PN} += "${datadir}/${PN}"
FILES_${PN} += "${datadir}/icons/*"
diff --git a/recipes/e17/elmdentica_svn.bb b/recipes/e17/elmdentica_svn.bb
index c6fb2847e7..5d08c69a51 100644
--- a/recipes/e17/elmdentica_svn.bb
+++ b/recipes/e17/elmdentica_svn.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "A indenti.ca client for E"
-DEPENDS = "glib-2.0 gconf libxml2 curl elementary sqlite3-native"
+DEPENDS = "glib-2.0 gconf curl elementary sqlite3-native libjson"
LICENSE = "GPLv3+"
SECTION = "e/apps"
HOMEPAGE = "http://elmdentica.googlecode.com"
@@ -7,5 +7,6 @@ AUTHOR = "seabra"
inherit e
-PV = "0.9.0+svnr${SRCPV}"
+PV = "0.9.9+svnr${SRCPV}"
+PR = "r1"
SRCREV = "${EFL_SRCREV}"
diff --git a/recipes/e17/entrance_0.9.0.010.bb b/recipes/e17/entrance_0.9.0.010.bb
index a988e50b80..e72e4a6acc 100644
--- a/recipes/e17/entrance_0.9.0.010.bb
+++ b/recipes/e17/entrance_0.9.0.010.bb
@@ -2,8 +2,8 @@ DESCRIPTION = "Entrance is the Enlightenment login manager"
LICENSE = "MIT BSD"
# can also use pam and crypt
DEPENDS = "evas ecore edje esmart bash keylaunch xserver-common login-manager"
-RDEPENDS += "glibc-gconv-iso8859-1 entrance-themes"
-PR = "r2"
+RDEPENDS_${PN} += "glibc-gconv-iso8859-1 entrance-themes"
+PR = "r3"
# entrance and estickies were removed in 46590 for rewrite, move back to EFL_SRCREV when they're back
SRCREV = "46589"
@@ -11,11 +11,11 @@ SRCREV = "46589"
inherit e
SRC_URI += "\
- file://rebased_config-db.patch;patch=1 \
- file://allow-missing-xsession.patch;patch=1 \
- file://run-Xinit.patch;patch=1 \
- file://fix-auth-mode.patch;patch=1 \
- file://use-bash.patch;patch=1 \
+ file://rebased_config-db.patch \
+ file://allow-missing-xsession.patch \
+ file://run-Xinit.patch \
+ file://fix-auth-mode.patch \
+ file://use-bash.patch \
file://Sessions"
S = "${WORKDIR}/entrance"
diff --git a/recipes/e17/eve/default.theme.remove.min.size.patch b/recipes/e17/eve/default.theme.remove.min.size.patch
new file mode 100644
index 0000000000..6887740a81
--- /dev/null
+++ b/recipes/e17/eve/default.theme.remove.min.size.patch
@@ -0,0 +1,19 @@
+diff -uNr eve.orig//data/themes/default.edc eve/data/themes/default.edc
+--- eve.orig//data/themes/default.edc 2010-08-13 15:12:14.000000000 +0200
++++ eve/data/themes/default.edc 2010-08-20 20:15:10.000000000 +0200
+@@ -202,7 +202,6 @@
+ type: RECT;
+ description { state: "default" 0.0;
+ color: 0 0 0 255;
+- min: 480 800;
+ }
+ }
+ }
+@@ -335,7 +334,6 @@
+ type: RECT;
+ description { state: "default" 0.0;
+ color: 0 0 0 255;
+- min: 480 800;
+ }
+ }
+ part { name: "view";
diff --git a/recipes/e17/eve_svn.bb b/recipes/e17/eve_svn.bb
index d51aed3d46..223a90be33 100644
--- a/recipes/e17/eve_svn.bb
+++ b/recipes/e17/eve_svn.bb
@@ -1,19 +1,19 @@
DESCRIPTION = " Enlightenment webbrowser"
LICENSE = "GPL"
DEPENDS = "webkit-efl evas ecore edje"
-PV = "0.0.1+svnr${SRCPV}"
-PR = "r4"
+PV = "0.2.0.0+svnr${SRCPV}"
SRCREV = "${EFL_SRCREV}"
-LDFLAGS += "-lstdc++"
-
inherit e
-SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/PROTO;module=eve;proto=http \
+SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk;module=eve;proto=http \
+ file://default.theme.remove.min.size.patch \
"
-S = "${WORKDIR}/eve"
-
-RDEPENDS_${PN} = "${PN}-themes"
+EXTRA_OECONF = "\
+ --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
+"
+S = "${WORKDIR}/eve"
+FILES_${PN} += "${datadir}/icons/eve.png"
diff --git a/recipes/e17/exalt_svn.bb b/recipes/e17/exalt_svn.bb
index 4e9f39f9cc..4696b72175 100644
--- a/recipes/e17/exalt_svn.bb
+++ b/recipes/e17/exalt_svn.bb
@@ -3,10 +3,11 @@ HOMEPAGE = "http://watchwolf.fr/wiki/doku.php?id=exalt"
LICENSE = "LGPLv2"
DEPENDS = "elementary vpnc wpa-supplicant ecore eet edbus"
-RDEPENDS = "vpnc wpa-supplicant"
+RDEPENDS_${PN} = "vpnc wpa-supplicant"
PV = "0.9+svnr${SRCPV}"
SRCREV = "${EFL_SRCREV}"
+PR = "r1"
inherit e
diff --git a/recipes/e17/exhibit_svn.bb b/recipes/e17/exhibit_svn.bb
deleted file mode 100644
index b897582f6c..0000000000
--- a/recipes/e17/exhibit_svn.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-DESCRIPTION = "Exhibit is the ETK picture viewer"
-LICENSE = "MIT BSD"
-DEPENDS = "evas ecore epsilon edje eet etk efreet"
-PV = "0.1.1+svnr${SRCPV}"
-PR = "r2"
-SRCREV = "${EFL_SRCREV}"
-
-inherit e
-
-SRC_URI = "svn://svn.enlightenment.org/svn/e/OLD;module=${SRCNAME};proto=http"
diff --git a/recipes/e17/expedite_svn.bb b/recipes/e17/expedite_svn.bb
index f5c26e31a9..b88ca4a266 100644
--- a/recipes/e17/expedite_svn.bb
+++ b/recipes/e17/expedite_svn.bb
@@ -1,9 +1,9 @@
DESCRIPTION = "Expedite is a comprehensive benchmarking suite for Evas"
DEPENDS = "eet evas"
-RDEPENDS = "expedite-themes evas-engine-buffer evas-engine-fb evas-engine-software-generic evas-engine-software-x11 evas-loader-png"
+RDEPENDS_${PN} = "expedite-themes evas-engine-buffer evas-engine-fb evas-engine-software-generic evas-engine-software-x11 evas-loader-png"
LICENSE = "MIT BSD"
PV = "0.6.0+svnr${SRCPV}"
-PR = "r3"
+PR = "r4"
SRCREV = "${EFL_SRCREV}"
inherit e
diff --git a/recipes/e17/exquisite_svn.bb b/recipes/e17/exquisite_svn.bb
index 256b5bde13..d58d26bbc9 100644
--- a/recipes/e17/exquisite_svn.bb
+++ b/recipes/e17/exquisite_svn.bb
@@ -2,9 +2,9 @@ DESCRIPTION = "A psplash replacement for display"
LICENSE = "MIT BSD"
DEPENDS = "eet evas ecore embryo edje"
PV = "0.0.1+svnr${SRCPV}"
-PR = "r9"
+PR = "r11"
SRCREV = "${EFL_SRCREV}"
-RDEPENDS = "initscripts"
+RDEPENDS_${PN} = "initscripts"
RRECOMMENDS_${PN} = "exquisite-themes"
RCONFLICTS_${PN} = "psplash virtual-psplash"
diff --git a/recipes/e17/illume-keyboard-default_svn.bb b/recipes/e17/illume-keyboard-default_svn.bb
deleted file mode 100644
index 4eb8ed2156..0000000000
--- a/recipes/e17/illume-keyboard-default_svn.bb
+++ /dev/null
@@ -1,44 +0,0 @@
-DESCRIPTION = "The illume default keyboards"
-SECTION = "x11/data"
-SRCNAME = "e/src/modules/illume/keyboards"
-PV = "0.16.999.060+svnr${SRCPV}"
-PR = "r1"
-SRCREV = "${EFL_SRCREV}"
-
-SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk;module=${SRCNAME};proto=http"
-S = "${WORKDIR}/${SRCNAME}"
-
-PACKAGE_ARCH = "all"
-
-INSTPATH = "/enlightenment/modules/illume/keyboards"
-INSTFILES = "\
-Default.kbd \
-alpha.png \
-Numbers.kbd \
-numeric.png \
-Terminal.kbd \
-qwerty.png \
-"
-
-PACKAGES = "${PN}-alpha ${PN}-numeric ${PN}-terminal"
-
-FILES_${PN}-alpha = "\
- ${libdir}${INSTPATH}/Default.kbd \
- ${libdir}${INSTPATH}/alpha.png \
-"
-FILES_${PN}-numeric = "\
- ${libdir}${INSTPATH}/Numbers.kbd \
- ${libdir}${INSTPATH}/numeric.png \
-"
-FILES_${PN}-terminal = "\
- ${libdir}${INSTPATH}/Terminal.kbd \
- ${libdir}${INSTPATH}/qwerty.png \
-"
-
-do_install() {
- install -d ${D}${libdir}${INSTPATH}
- for f in ${INSTFILES}; do
- install -m 0644 ${S}/${f} ${D}${libdir}${INSTPATH}
- done
-}
-
diff --git a/recipes/e17/illume-keyboards-shr/0001-Makefile-update-KEYBOARDS_DIR-for-new-illume2.patch b/recipes/e17/illume-keyboards-shr/0001-Makefile-update-KEYBOARDS_DIR-for-new-illume2.patch
new file mode 100644
index 0000000000..b18a69b0ba
--- /dev/null
+++ b/recipes/e17/illume-keyboards-shr/0001-Makefile-update-KEYBOARDS_DIR-for-new-illume2.patch
@@ -0,0 +1,23 @@
+From 9316e3973c44b981e73b953b2861060c6902de47 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Mon, 23 Aug 2010 12:54:05 +0200
+Subject: [PATCH] Makefile: update KEYBOARDS_DIR for new illume2
+
+---
+ Makefile | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 46e9420..3d8757c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,5 +1,5 @@
+
+-INSTBASE = /usr/lib/enlightenment/modules/illume/keyboards
++INSTBASE = /usr/lib/enlightenment/modules/illume-keyboard/keyboards
+
+ FILES-arabic = Arabic.kbd Arabic.png
+ FILES-persian = Persian.kbd Persian.png
+--
+1.7.2
+
diff --git a/recipes/e17/illume-keyboards-shr_git.bb b/recipes/e17/illume-keyboards-shr_git.bb
index 49abb9c1a5..302dbd8d24 100644
--- a/recipes/e17/illume-keyboards-shr_git.bb
+++ b/recipes/e17/illume-keyboards-shr_git.bb
@@ -1,12 +1,13 @@
SECTION = "x11/data"
-SRC_URI = "git://git.shr-project.org/repo/illume-keyboards.git;protocol=http;branch=master"
+SRC_URI = "git://git.shr-project.org/repo/illume-keyboards.git;protocol=http;branch=master \
+ file://0001-Makefile-update-KEYBOARDS_DIR-for-new-illume2.patch"
S = "${WORKDIR}/git"
SRCREV = "4064489f359a1addf572089b582f317dff5f50e1"
PV = "0.0+gitr${SRCPV}"
PE = "1"
-PR = "r3"
+PR = "r4"
PACKAGES = "\
@@ -28,7 +29,7 @@ illume-keyboard-persian \
"
PACKAGE_ARCH = "all"
-KEYBOARDS_DIR="${libdir}/enlightenment/modules/illume/keyboards"
+KEYBOARDS_DIR="${libdir}/enlightenment/modules/illume-keyboard/keyboards"
AUTHOR_illume-keyboard-alpha = "Jesus McCloud"
DESCRIPTION_illume-keyboard-alpha = "Illume keyboard with phone-like layout"
diff --git a/recipes/e17/intuition_svn.bb b/recipes/e17/intuition_svn.bb
index 9b2d594c16..287d6ebd2e 100644
--- a/recipes/e17/intuition_svn.bb
+++ b/recipes/e17/intuition_svn.bb
@@ -3,7 +3,7 @@ SECTION = "x11"
LICENSE = "GPLv2"
DEPENDS = "elementary sqlite"
PV = "0.2.0+svnr${SRCPV}"
-PR = "r0"
+PR = "r4"
SRCREV = "194"
SRC_URI = "svn://svn.om.vptt.ch/trunk/;proto=http;module=intuition"
diff --git a/recipes/e17/places_svn.bb b/recipes/e17/places_svn.bb
index 13ef860f77..b24cbd6695 100644
--- a/recipes/e17/places_svn.bb
+++ b/recipes/e17/places_svn.bb
@@ -1,19 +1,16 @@
-LICENSE = "GPLv3 LGPLv3"
+LICENSE = "BSD"
PV = "0.1.0+svnr${SRCPV}"
PR = "r4"
require e-module.inc
-SRC_URI += "file://fix-api.diff;patch=1;maxrev=39830;pnum=3"
+SRC_URI += "file://fix-api.diff;maxrev=39830;striplevel=3"
do_configure_prepend() {
- sed -i -e /po/d -e /AM_GNU_GETTEXT/d configure.ac
+ sed -i -e /po/d -e /AM_GNU_GETTEXT/d configure.ac
sed -i -e s:\ po::g Makefile.am
}
# Calls /usr/bin/eject for media
RRECOMMENDS_${PN} += "eject"
-
-
-