aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e2tools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/e2tools')
-rw-r--r--recipes/e2tools/e2tools-0.0.16/autofoo.patch22
-rw-r--r--recipes/e2tools/e2tools-native_0.0.16.bb15
-rw-r--r--recipes/e2tools/e2tools_0.0.16.bb10
3 files changed, 47 insertions, 0 deletions
diff --git a/recipes/e2tools/e2tools-0.0.16/autofoo.patch b/recipes/e2tools/e2tools-0.0.16/autofoo.patch
new file mode 100644
index 0000000000..dc78c21d51
--- /dev/null
+++ b/recipes/e2tools/e2tools-0.0.16/autofoo.patch
@@ -0,0 +1,22 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- e2tools-0.0.16/Makefile.am~autofoo 2003-07-12 13:06:54.000000000 -0400
++++ e2tools-0.0.16/Makefile.am 2004-09-21 21:00:19.242750360 -0400
+@@ -1,5 +1,3 @@
+-INCLUDES = -I@includedir@
+-
+ .c.o:
+ $(COMPILE) -c $<
+
+@@ -17,7 +15,7 @@
+ tail.c \
+ util.c \
+ write.c
+-e2cp_LDADD = -L@libdir@ -lext2fs -lcom_err
++e2cp_LDADD = -lext2fs -lcom_err
+ EXTRA_DIST = README TODO e2tools.spec
+
+ install-exec-hook:
diff --git a/recipes/e2tools/e2tools-native_0.0.16.bb b/recipes/e2tools/e2tools-native_0.0.16.bb
new file mode 100644
index 0000000000..e37eed2b18
--- /dev/null
+++ b/recipes/e2tools/e2tools-native_0.0.16.bb
@@ -0,0 +1,15 @@
+SECTION = "base"
+require e2tools_${PV}.bb
+inherit native
+
+DEPENDS = "e2fsprogs-libs-native e2fsprogs-native"
+FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/e2tools-${PV}', '${FILE_DIRNAME}/e2tools', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
+PACKAGES = ""
+
+e2links = "e2ln e2ls e2mkdir e2mv e2rm e2tail"
+do_stage () {
+ install -m 0755 e2cp ${STAGING_BINDIR}/
+ for i in ${e2links}; do
+ ln -sf e2cp ${STAGING_BINDIR}/$i
+ done
+}
diff --git a/recipes/e2tools/e2tools_0.0.16.bb b/recipes/e2tools/e2tools_0.0.16.bb
new file mode 100644
index 0000000000..7f98bdb6d3
--- /dev/null
+++ b/recipes/e2tools/e2tools_0.0.16.bb
@@ -0,0 +1,10 @@
+SECTION = "base"
+LICENSE = "GPL"
+DESCRIPTION = "A simple set of utilities for reading, writing, and \
+manipulating files in an ext2/ext3 filesystem."
+DEPENDS = "e2fsprogs-libs e2fsprogs"
+SRC_URI = "http://www.pobox.com/~sheff/sw/e2tools/e2tools-${PV}.tar.gz \
+ file://autofoo.patch;patch=1"
+S = "${WORKDIR}/e2tools-${PV}"
+
+inherit autotools