aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ebtables/ebtables-2.0.6/installcreatedirs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ebtables/ebtables-2.0.6/installcreatedirs.patch')
-rw-r--r--recipes/ebtables/ebtables-2.0.6/installcreatedirs.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/ebtables/ebtables-2.0.6/installcreatedirs.patch b/recipes/ebtables/ebtables-2.0.6/installcreatedirs.patch
new file mode 100644
index 0000000000..86bc4f0a44
--- /dev/null
+++ b/recipes/ebtables/ebtables-2.0.6/installcreatedirs.patch
@@ -0,0 +1,25 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- ebtables-v2.0.6/Makefile~installcreatedirs 2004-06-03 13:34:17.000000000 -0500
++++ ebtables-v2.0.6/Makefile 2004-06-03 13:35:21.000000000 -0500
+@@ -47,14 +47,17 @@
+
+ $(MANDIR)/man8/ebtables.8: ebtables.8
+ mkdir -p $(@D)
++ install -d $(MANDIR)/man8
+ install -m 0644 $(INSTALLOWN) $< $@
+
+ $(ETHERTYPESFILE): ethertypes
+ mkdir -p $(@D)
++ install -d $(ETHERTYPESPATH)
+ install -m 0644 $(INSTALLOWN) $< $@
+
+ .PHONY: exec
+ exec: ebtables
++ install -d $(BINPATH)
+ install -m 0755 $(INSTALLOWN) $< $(BINFILE)
+
+ .PHONY: install