aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ebtables/ebtables_2.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ebtables/ebtables_2.0.6.bb')
-rw-r--r--recipes/ebtables/ebtables_2.0.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/ebtables/ebtables_2.0.6.bb b/recipes/ebtables/ebtables_2.0.6.bb
new file mode 100644
index 0000000000..33ad2b9113
--- /dev/null
+++ b/recipes/ebtables/ebtables_2.0.6.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Utility that enables basic Ethernet frame filtering on a Linux bridge, MAC NAT and brouting."
+PRIORITY = "optional"
+LICENSE = "GPL"
+SECTION = "console/network"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/ebtables/ebtables-v${PV}.tar.gz \
+ file://gcc34.patch;patch=1 \
+ file://gcc4.patch;patch=1 \
+ file://installnonroot.patch;patch=1 \
+ file://installcreatedirs.patch;patch=1"
+S = "${WORKDIR}/ebtables-v${PV}"
+
+do_compile () {
+ oe_runmake 'BINPATH=/sbin/' 'MANDIR=${mandir}/' \
+ 'ETHERTYPESPATH=${sysconfdir}/' 'KERNEL_INCLUDES=${STAGING_INCDIR}'
+}
+
+do_install () {
+ oe_runmake 'BINPATH=${D}${base_sbindir}/' 'MANDIR=${D}${mandir}/' \
+ 'ETHERTYPESPATH=${D}${sysconfdir}/' install
+}