aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ecj/ecj-bootstrap-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ecj/ecj-bootstrap-native.bb')
-rw-r--r--recipes/ecj/ecj-bootstrap-native.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes/ecj/ecj-bootstrap-native.bb b/recipes/ecj/ecj-bootstrap-native.bb
index 6c80de749a..594b08cb9c 100644
--- a/recipes/ecj/ecj-bootstrap-native.bb
+++ b/recipes/ecj/ecj-bootstrap-native.bb
@@ -21,6 +21,8 @@ PR = "r2"
JAR = "ecj-bootstrap.jar"
+NATIVE_INSTALL_WORKS = "1"
+
inherit native
do_compile() {
@@ -31,8 +33,8 @@ do_compile() {
cat ecj.in >> ecj-bootstrap
}
-do_stage() {
- install -d ${STAGING_BINDIR}
- install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}
- install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}/javac
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 ${S}/ecj-bootstrap ${D}${bindir}
+ install -m 755 ${S}/ecj-bootstrap ${D}${bindir}/javac
}