aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ecj/ecj-initial.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ecj/ecj-initial.bb')
-rw-r--r--recipes/ecj/ecj-initial.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/ecj/ecj-initial.bb b/recipes/ecj/ecj-initial.bb
new file mode 100644
index 0000000000..106453691b
--- /dev/null
+++ b/recipes/ecj/ecj-initial.bb
@@ -0,0 +1,31 @@
+# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
+# and no less features.
+
+# This variant runs on the initial (not Java5-compatible runtime).
+
+DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
+HOMEPAGE = "http://www.eclipse.org/"
+LICENSE = "EPL"
+
+DEPENDS = "libecj-bootstrap"
+
+SRC_URI = "file://ecj.in"
+
+S = "${WORKDIR}"
+
+inherit native
+
+JAR = "ecj-bootstrap.jar"
+
+do_compile() {
+ # Create the start script
+ echo "#!/bin/sh" > ecj-initial
+ echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-initial
+ echo "RUNTIME=java-initial" >> ecj-initial
+ cat ecj.in >> ecj-initial
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 ${S}/ecj-initial ${STAGING_BINDIR}
+}