aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/efl1/epdf_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/efl1/epdf_svn.bb')
-rw-r--r--recipes/efl1/epdf_svn.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/efl1/epdf_svn.bb b/recipes/efl1/epdf_svn.bb
new file mode 100644
index 0000000000..7aeb537268
--- /dev/null
+++ b/recipes/efl1/epdf_svn.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Epdf is the glue between EFL and libpoppler"
+LICENSE = "MIT BSD"
+DEPENDS = "poppler evas ecore etk ewl"
+PV = "0.1.0+svnr${SRCREV}"
+PR = "r2"
+
+inherit efl
+
+SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/PROTO;module=epdf;proto=http"
+# file://fix-plugin-path-check.patch;HACK=1;patch=1"
+# FIXME This package is not really working correctly at the moment. It doesn't
+# recognize epsilon and doesn't build everything. The next one actually using
+# this package is welcome to fix it.
+
+EXTRA_OECONF = "--enable-etk --enable-ewl"
+
+# add ewl additions
+FILES_${PN}-dev += "${libdir}/ewl/tests/*.a ${libdir}/ewl/tests/*.la"
+FILES_${PN}-dbg += "${libdir}/ewl/tests/.debug"
+
+# add epsilon additions
+FILES_${PN}-dev += "${libdir}/epsilon/plugins/epdf_thumbnailer.a ${libdir}/epsilon/plugins/epdf_thumbnailer.la"
+FILES_${PN}-dbg += "${libdir}/epsilon/plugins/.debug"
+
+PACKAGES += "${PN}-ewl-widget epsilon-plugin-${PN}"
+FILES_${PN}-ewl-widget = "${libdir}/ewl/tests/libewl_pdf*.so*"
+FILES_epsilon-plugin-${PN} = "${libdir}/epsilon/plugins/epdf_thumbnailer.so*"
+