aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/efl1/libefso_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/efl1/libefso_svn.bb')
-rw-r--r--recipes/efl1/libefso_svn.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/efl1/libefso_svn.bb b/recipes/efl1/libefso_svn.bb
new file mode 100644
index 0000000000..20d520cba5
--- /dev/null
+++ b/recipes/efl1/libefso_svn.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "EFL FSO wrapper library"
+SECTION = "e/libs"
+LICENSE = "GPLv2"
+DEPENDS = "ecore edbus"
+PV = "0.0.0+svnr${SRCREV}"
+PR = "r2"
+
+SRC_URI = "svn://svn.om.vptt.ch/trunk/;proto=http;module=libefso"
+S = "${WORKDIR}/libefso"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ install -m 0644 src/lib/efso.h ${STAGING_INCDIR}/efso.h
+ oe_libinstall -a -so -C src/lib libefso ${STAGING_LIBDIR}
+ autotools_stage_all
+}