aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/efl1
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/efl1')
-rw-r--r--recipes/efl1/ecore.inc2
-rw-r--r--recipes/efl1/ecore/exit_uclibc_newer.patch12
-rw-r--r--recipes/efl1/ecore_svn.bb10
-rw-r--r--recipes/efl1/edbus_svn.bb2
-rw-r--r--recipes/efl1/edje-native_svn.bb2
-rw-r--r--recipes/efl1/edje_svn.bb2
-rw-r--r--recipes/efl1/eet_svn.bb2
-rw-r--r--recipes/efl1/eflpp_svn.bb2
-rw-r--r--recipes/efl1/efreet_svn.bb2
-rw-r--r--recipes/efl1/eina_svn.bb2
-rw-r--r--recipes/efl1/elementary_svn.bb9
-rw-r--r--recipes/efl1/epdf_svn.bb2
-rw-r--r--recipes/efl1/evas-native_svn.bb3
-rw-r--r--recipes/efl1/evas.inc12
-rw-r--r--recipes/efl1/evas_svn.bb5
-rw-r--r--recipes/efl1/evolve-native_svn.bb6
-rw-r--r--recipes/efl1/evolve_svn.bb10
-rw-r--r--recipes/efl1/ewl_svn.bb2
-rw-r--r--recipes/efl1/imlib2_svn.bb10
-rw-r--r--recipes/efl1/libeflvala_svn.bb4
20 files changed, 56 insertions, 45 deletions
diff --git a/recipes/efl1/ecore.inc b/recipes/efl1/ecore.inc
index 183f25203a..bb7eea5dc6 100644
--- a/recipes/efl1/ecore.inc
+++ b/recipes/efl1/ecore.inc
@@ -12,7 +12,7 @@ inherit efl
BBCLASSEXTEND = "native"
-SRC_URI += "file://fix-ecore-fb-initialization.patch;patch=1"
+SRC_URI += "file://fix-ecore-fb-initialization.patch"
do_configure_prepend() {
touch ${S}/po/Makefile.in.in || true
diff --git a/recipes/efl1/ecore/exit_uclibc_newer.patch b/recipes/efl1/ecore/exit_uclibc_newer.patch
new file mode 100644
index 0000000000..3d04453eb8
--- /dev/null
+++ b/recipes/efl1/ecore/exit_uclibc_newer.patch
@@ -0,0 +1,12 @@
+diff -uNr ecore.orig//src/lib/ecore_con/ecore_con_info.c ecore/src/lib/ecore_con/ecore_con_info.c
+--- ecore.orig//src/lib/ecore_con/ecore_con_info.c 2010-08-13 14:31:18.000000000 +0200
++++ ecore/src/lib/ecore_con/ecore_con_info.c 2010-08-13 14:49:37.000000000 +0200
+@@ -283,7 +283,7 @@
+
+ err = write(fd[1], "", 1);
+ close(fd[1]);
+-#ifdef __USE_ISOC99
++#if defined(__USE_ISOC99) && !defined(__UCLIBC__)
+ _Exit(0);
+ #else
+ _exit(0);
diff --git a/recipes/efl1/ecore_svn.bb b/recipes/efl1/ecore_svn.bb
index bcee012da4..d38bc8ee5d 100644
--- a/recipes/efl1/ecore_svn.bb
+++ b/recipes/efl1/ecore_svn.bb
@@ -1,18 +1,18 @@
require ecore.inc
SRCREV = "${EFL_SRCREV}"
-PR = "r11"
+PR = "r12"
SRC_URI += "\
- file://iconv.patch;patch=1;maxrev=43996 \
- file://exit_uclibc_dns.patch;patch=1;maxrev=47076 \
- file://exit_uclibc.patch;patch=1 \
+ file://iconv.patch;maxrev=43996 \
+ file://exit_uclibc_dns.patch;maxrev=47076 \
+ file://exit_uclibc.patch;maxrev=50815 \
+ file://exit_uclibc_newer.patch;minrev=50816 \
"
ECORE_OECONF = "\
--x-includes=${STAGING_INCDIR}/X11 \
--x-libraries=${STAGING_LIBDIR} \
--enable-simple-x11 \
- --enable-ecore-txt \
--enable-ecore-config \
--enable-ecore-x \
--enable-ecore-job \
diff --git a/recipes/efl1/edbus_svn.bb b/recipes/efl1/edbus_svn.bb
index 087bfe7c97..1ef1f16c6a 100644
--- a/recipes/efl1/edbus_svn.bb
+++ b/recipes/efl1/edbus_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "DBus and HAL convenience wrappers for EFL"
DEPENDS = "dbus ecore"
LICENSE = "MIT BSD"
PV = "0.5.0.060+svnr${SRCPV}"
-PR = "r1"
+PR = "r2"
SRCREV = "${EFL_SRCREV}"
inherit efl
diff --git a/recipes/efl1/edje-native_svn.bb b/recipes/efl1/edje-native_svn.bb
index 33fe06f41c..420d8c15ae 100644
--- a/recipes/efl1/edje-native_svn.bb
+++ b/recipes/efl1/edje-native_svn.bb
@@ -1,6 +1,6 @@
require edje_${PV}.bb
inherit native
-PR = "r4"
+PR = "r5"
DEPENDS = "lua5.1-native evas-native ecore-native eet-native embryo-native"
diff --git a/recipes/efl1/edje_svn.bb b/recipes/efl1/edje_svn.bb
index 1fd67cde65..fd410281e1 100644
--- a/recipes/efl1/edje_svn.bb
+++ b/recipes/efl1/edje_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Edje is the Enlightenment graphical design & layout library"
DEPENDS = "lua5.1 eet evas ecore embryo edje-native"
LICENSE = "MIT BSD"
PV = "0.9.92.060+svnr${SRCPV}"
-PR = "r6"
+PR = "r7"
SRCREV = "${EFL_SRCREV}"
inherit efl
diff --git a/recipes/efl1/eet_svn.bb b/recipes/efl1/eet_svn.bb
index 919ca46585..afb6db6bc2 100644
--- a/recipes/efl1/eet_svn.bb
+++ b/recipes/efl1/eet_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "EET is the Enlightenment data storage library"
DEPENDS = "pkgconfig zlib jpeg openssl eina"
LICENSE = "MIT BSD"
SRCREV = "${EFL_SRCREV}"
-PV = "1.1.0+svnr${SRCPV}"
+PV = "1.3.2+svnr${SRCPV}"
PR = "r1"
inherit efl
diff --git a/recipes/efl1/eflpp_svn.bb b/recipes/efl1/eflpp_svn.bb
index 1ea3e65e7b..e29009f223 100644
--- a/recipes/efl1/eflpp_svn.bb
+++ b/recipes/efl1/eflpp_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "EFLpp are C++ bindings to the EFL"
AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
HOMEPAGE = "http://www.vanille-media.de/site/index.php/projects/efl/"
LICENSE = "LGPL"
-DEPENDS = "evas ecore edje emotion esmart etk ewl libsigc++-2.0"
+DEPENDS = "evas ecore edje emotion esmart libsigc++-2.0"
SRCREV = "${EFL_SRCREV}"
PV = "0.1.0+svnr${SRCPV}"
PR = "r1"
diff --git a/recipes/efl1/efreet_svn.bb b/recipes/efl1/efreet_svn.bb
index 555016dcf4..d988f52a6b 100644
--- a/recipes/efl1/efreet_svn.bb
+++ b/recipes/efl1/efreet_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "The Enlightenment freedesktop.org library"
DEPENDS = "ecore"
LICENSE = "MIT BSD"
PV = "0.5.0.060+svnr${SRCPV}"
-PR = "r3"
+PR = "r4"
SRCREV = "${EFL_SRCREV}"
inherit efl
diff --git a/recipes/efl1/eina_svn.bb b/recipes/efl1/eina_svn.bb
index 6873e83750..34e1aa89cf 100644
--- a/recipes/efl1/eina_svn.bb
+++ b/recipes/efl1/eina_svn.bb
@@ -6,7 +6,7 @@ SRCREV = "${EFL_SRCREV}"
inherit efl
-SRC_URI += "file://gnu_source.patch;patch=1"
+SRC_URI += "file://gnu_source.patch"
# Some upgrade path tweaking
AUTO_LIBNAME_PKGS = ""
diff --git a/recipes/efl1/elementary_svn.bb b/recipes/efl1/elementary_svn.bb
index 1ee8f37dbb..29e8919cfc 100644
--- a/recipes/efl1/elementary_svn.bb
+++ b/recipes/efl1/elementary_svn.bb
@@ -1,8 +1,8 @@
DESCRIPTION = "EFL based widget set for mobile devices"
LICENSE = "LGPL"
DEPENDS = "eet-native efreet evas ecore edje eet edbus"
-PV = "0.0.0+svnr${SRCPV}"
-PR = "r8"
+PV = "0.7.0+svnr${SRCPV}"
+PR = "r11"
SRCREV = "${EFL_SRCREV}"
inherit efl
@@ -50,3 +50,8 @@ FILES_${PN}-tests = "\
${libdir}/elementary/modules/test_entry/* \
"
+# Some upgrade path tweaking, as in evas
+AUTO_LIBNAME_PKGS = ""
+
+RREPLACES_${PN}-themes = "libelementary-ver-pre-svn-05-themes libelementary-ver-svn-06-themes libelementary-ver-pre-svn-06-themes"
+RREPLACES_${PN}-configs = "libelementary-ver-pre-svn-05-configs libelementary-ver-svn-06-configs libelementary-ver-pre-svn-06-configs"
diff --git a/recipes/efl1/epdf_svn.bb b/recipes/efl1/epdf_svn.bb
index c905051837..eac8e87123 100644
--- a/recipes/efl1/epdf_svn.bb
+++ b/recipes/efl1/epdf_svn.bb
@@ -8,7 +8,7 @@ SRCREV = "${EFL_SRCREV}"
inherit efl
SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/PROTO;module=epdf;proto=http"
-# file://fix-plugin-path-check.patch;HACK=1;patch=1"
+# file://fix-plugin-path-check.patch;HACK=1"
# FIXME This package is not really working correctly at the moment. It doesn't
# recognize epsilon and doesn't build everything. The next one actually using
# this package is welcome to fix it.
diff --git a/recipes/efl1/evas-native_svn.bb b/recipes/efl1/evas-native_svn.bb
index a76997626c..c587c1260d 100644
--- a/recipes/efl1/evas-native_svn.bb
+++ b/recipes/efl1/evas-native_svn.bb
@@ -1,7 +1,8 @@
require evas.inc
inherit native
DEPENDS = "freetype-native libxext-native libpng-native jpeg-native eet-native eina-native libfribidi-native"
-PR = "r3"
+PACKAGES_DYNAMIC = ""
+PR = "r4"
EXTRA_OECONF = "\
--x-includes=${STAGING_INCDIR}/X11 \
diff --git a/recipes/efl1/evas.inc b/recipes/efl1/evas.inc
index bc2645d856..e7ba309bdf 100644
--- a/recipes/efl1/evas.inc
+++ b/recipes/efl1/evas.inc
@@ -30,12 +30,12 @@ do_install_append() {
find "${D}" -name .debug -type d -exec rm -rf {} \;
}
-FILES_${SRCNAME}-dev += "${libdir}/evas/modules/*/*/*/*.a ${libdir}/evas/modules/*/*/*/*.la"
-FILES_${SRCNAME}-dbg += "${libdir}/evas/modules/*/*/*/.debug/"
+FILES_${PN}-dev += "${libdir}/evas/modules/*/*/*/*.a ${libdir}/evas/modules/*/*/*/*.la"
+FILES_${PN}-dbg += "${libdir}/evas/modules/*/*/*/.debug/"
PACKAGES_DYNAMIC = "evas-engine-* evas-loader-* evas-saver-*"
-RRECOMMENDS_${SRCNAME} = "\
+RRECOMMENDS_${PN} = "\
evas-engine-buffer \
evas-engine-fb \
evas-engine-software-generic \
@@ -52,9 +52,9 @@ RRECOMMENDS_${SRCNAME} = "\
# Some upgrade path tweaking
AUTO_LIBNAME_PKGS = ""
-RREPLACES_${SRCNAME} = "libevas-ver-pre-svn-00-0 libevas-ver-pre-svn-01-0"
+RREPLACES_${PN} = "libevas-ver-pre-svn-00-0 libevas-ver-pre-svn-01-0"
-RREPLACES_${SRCNAME}-tests = "libevas-ver-pre-svn-00-tests libevas-ver-pre-svn-01-tests"
+RREPLACES_${PN}-tests = "libevas-ver-pre-svn-00-tests libevas-ver-pre-svn-01-tests"
RREPLACES_evas-loader-pmaps = "liblibevas-ver-pre-svn-00-loader-pmaps libevas-ver-pre-svn-00-loader-pmaps "
RREPLACES_evas-loader-eet = "liblibevas-ver-pre-svn-00-loader-eet libevas-ver-pre-svn-00-loader-eet "
@@ -80,6 +80,6 @@ RREPLACES_evas-engine-software-x11 = "liblibevas-ver-pre-svn-00-engine-software-
# disabling this, since (due to OE bugs) it drags in whole Gtk+
-#RRECOMMENDS_${SRCNAME} += "\
+#RRECOMMENDS_${PN} += "\
# libevas-loader-svg \
#"
diff --git a/recipes/efl1/evas_svn.bb b/recipes/efl1/evas_svn.bb
index bdcffa13ca..805e64b7f7 100644
--- a/recipes/efl1/evas_svn.bb
+++ b/recipes/efl1/evas_svn.bb
@@ -1,8 +1,9 @@
require evas.inc
-PR = "r6"
+PR = "r8"
EVAS_CPU_TWEAKS = ""
-EVAS_CPU_TWEAKS_armv7a = "--enable-cpu-neon"
+# Disabled for now, see http://thread.gmane.org/gmane.comp.window-managers.enlightenment.devel/25194
+#EVAS_CPU_TWEAKS_armv7a = "--enable-cpu-neon"
EXTRA_OECONF = "\
--x-includes=${STAGING_INCDIR}/X11 \
diff --git a/recipes/efl1/evolve-native_svn.bb b/recipes/efl1/evolve-native_svn.bb
deleted file mode 100644
index 5d57075498..0000000000
--- a/recipes/efl1/evolve-native_svn.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-require evolve_svn.bb
-inherit native
-DEPENDS = "etk-native"
-
-# needs ecore-x :/
-BROKEN = "1"
diff --git a/recipes/efl1/evolve_svn.bb b/recipes/efl1/evolve_svn.bb
deleted file mode 100644
index 7966e8d58a..0000000000
--- a/recipes/efl1/evolve_svn.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-DESCRIPTION = "Evolve allows you to write ETK designs using a C-like language"
-LICENSE = "MIT"
-DEPENDS = "etk evolve-native"
-PV = "0.1.0.001+svnr${SRCPV}"
-PR = "r2"
-SRCREV = "${EFL_SRCREV}"
-
-inherit efl
-
-SRC_URI = "svn://svn.enlightenment.org/svn/e/OLD;module=${BPN};proto=http"
diff --git a/recipes/efl1/ewl_svn.bb b/recipes/efl1/ewl_svn.bb
index 9e309c4e2f..595259cb5a 100644
--- a/recipes/efl1/ewl_svn.bb
+++ b/recipes/efl1/ewl_svn.bb
@@ -7,6 +7,8 @@ SRCREV = "${EFL_SRCREV}"
inherit efl
+SRC_URI = "svn://svn.enlightenment.org/svn/e/BROKEN;module=${PN};proto=http"
+
EXTRA_OECONF = "\
--enable-software-x11 \
--enable-software-16-x11 \
diff --git a/recipes/efl1/imlib2_svn.bb b/recipes/efl1/imlib2_svn.bb
index 320020ae8c..c0616be181 100644
--- a/recipes/efl1/imlib2_svn.bb
+++ b/recipes/efl1/imlib2_svn.bb
@@ -4,18 +4,24 @@ LICENSE = "BSD"
DEPENDS = "freetype libpng jpeg virtual/libx11 libxext"
PROVIDES = "virtual/imlib2"
PV = "1.4.2.001+svnr${SRCPV}"
-PR = "r0"
+PR = "r2"
SRCREV = "${EFL_SRCREV}"
inherit efl
-EXTRA_OECONF = "--with-x"
+EXTRA_OECONF = "--with-x \
+ --x-includes=${STAGING_INCDIR} \
+ --x-libraries=${STAGING_LIBDIR} "
# TODO: Use more fine granular version
#OE_LT_RPATH_ALLOW=":${libdir}/imlib2/loaders:${libdir}/imlib2/filters:"
OE_LT_RPATH_ALLOW = "any"
OE_LT_RPATH_ALLOW[export]="1"
+do_install_append() {
+ install -m 0755 imlib2-config ${STAGING_BINDIR_CROSS}
+}
+
PACKAGES =+ "imlib2-loaders-dbg imlib2-filters-dbg imlib2-loaders imlib2-filters"
FILES_${PN} = "${libdir}/lib*.so.* ${libdir}/imlib2/*/*.so"
FILES_${PN}-dbg = "${libdir}/.debug/ ${bindir}/.debug/"
diff --git a/recipes/efl1/libeflvala_svn.bb b/recipes/efl1/libeflvala_svn.bb
index 9a88054287..22159e61c6 100644
--- a/recipes/efl1/libeflvala_svn.bb
+++ b/recipes/efl1/libeflvala_svn.bb
@@ -4,14 +4,14 @@ LICENSE = "LGPL"
SECTION = "devel"
DEPENDS = "vala-native glib-2.0 dbus dbus-glib eina eet evas ecore edje elementary"
PV = "0.5.0+svnr${SRCPV}"
-PR = "r0"
+PR = "r1"
PE = "1"
SRCREV = "${EFL_SRCREV}"
SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/BINDINGS;module=vala;proto=http"
S = "${WORKDIR}/vala"
-inherit autotools_stage pkgconfig vala
+inherit autotools pkgconfig vala
PACKAGES =+ "${PN}-examples"
FILES_${PN}-examples = "${datadir}/libeflvala ${bindir}/*"