aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ekiga/ptlib_2.4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ekiga/ptlib_2.4.4.bb')
-rw-r--r--recipes/ekiga/ptlib_2.4.4.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/ekiga/ptlib_2.4.4.bb b/recipes/ekiga/ptlib_2.4.4.bb
new file mode 100644
index 0000000000..f5598d31ab
--- /dev/null
+++ b/recipes/ekiga/ptlib_2.4.4.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Portable Tools Libary"
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += "libgsm openldap openssl expat virtual/libsdl alsa-lib"
+
+SRC_URI = "http://www.ekiga.org/admin/downloads/latest/sources/ekiga_3.0.2/ptlib-${PV}.tar.bz2"
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ ptlib.pc
+}
+
+FILES_${PN} += "${libdir}/ptlib-${PV}/*/*/*.so"
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+
+