aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ekiga
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ekiga')
-rw-r--r--recipes/ekiga/ekiga_3.0.2.bb6
-rw-r--r--recipes/ekiga/ekiga_3.1.0.bb4
-rw-r--r--recipes/ekiga/ekiga_3.2.0.bb3
-rw-r--r--recipes/ekiga/ekiga_3.2.4.bb3
-rw-r--r--recipes/ekiga/ekiga_3.2.5.bb3
-rw-r--r--recipes/ekiga/ekiga_3.2.7.bb23
-rw-r--r--recipes/ekiga/ekiga_git.bb11
-rw-r--r--recipes/ekiga/opal_3.4.4.bb7
-rw-r--r--recipes/ekiga/opal_3.5.2.bb7
-rw-r--r--recipes/ekiga/opal_3.6.1.bb7
-rw-r--r--recipes/ekiga/opal_3.6.2.bb7
-rw-r--r--recipes/ekiga/opal_3.6.4.bb7
-rw-r--r--recipes/ekiga/opal_3.6.6.bb7
-rw-r--r--recipes/ekiga/opal_3.8.2.bb27
-rw-r--r--recipes/ekiga/ptlib_2.4.4.bb8
-rw-r--r--recipes/ekiga/ptlib_2.5.2.bb8
-rw-r--r--recipes/ekiga/ptlib_2.6.1.bb8
-rw-r--r--recipes/ekiga/ptlib_2.6.2.bb8
-rw-r--r--recipes/ekiga/ptlib_2.6.4.bb8
-rw-r--r--recipes/ekiga/ptlib_2.6.5.bb2
-rw-r--r--recipes/ekiga/ptlib_2.8.2.bb33
21 files changed, 107 insertions, 90 deletions
diff --git a/recipes/ekiga/ekiga_3.0.2.bb b/recipes/ekiga/ekiga_3.0.2.bb
index 951168a950..72113c35b9 100644
--- a/recipes/ekiga/ekiga_3.0.2.bb
+++ b/recipes/ekiga/ekiga_3.0.2.bb
@@ -1,16 +1,16 @@
DESCRIPTION = "Gnome videoconferencing application"
LICENSE = "GPLv2"
-PR = "r1"
+PR = "r2"
ARM_INSTRUCTION_SET = "arm"
inherit gnome
DEPENDS += " avahi libnotify eds-dbus libgnome gtkmm libsigc++-2.0 gstreamer opal ptlib"
-RDEPENDS += "opal ptlib"
+RDEPENDS_${PN} += "opal ptlib"
SRC_URI = "http://www.ekiga.org/admin/downloads/latest/sources/ekiga_${PV}/ekiga-${PV}.tar.gz \
- file://static-fix.diff;patch=1"
+ file://static-fix.diff"
EXTRA_OECONF = " --enable-static-libs --disable-gdu --disable-scrollkeeper "
diff --git a/recipes/ekiga/ekiga_3.1.0.bb b/recipes/ekiga/ekiga_3.1.0.bb
index 7d52a293e8..3daa6d404c 100644
--- a/recipes/ekiga/ekiga_3.1.0.bb
+++ b/recipes/ekiga/ekiga_3.1.0.bb
@@ -1,13 +1,13 @@
DESCRIPTION = "Gnome videoconferencing application"
LICENSE = "GPLv2"
-PR = "r3"
+PR = "r4"
ARM_INSTRUCTION_SET = "arm"
inherit gnome
DEPENDS += " avahi libnotify eds-dbus libgnome gtkmm libsigc++-2.0 gstreamer gst-plugins-good gst-plugins-base gst-plugins-bad opal ptlib gnome-doc-utils"
-RDEPENDS += "gst-plugin-app gst-plugin-video4linux2 opal ptlib"
+RDEPENDS_${PN} += "gst-plugin-app gst-plugin-video4linux2 opal ptlib"
EXTRA_OECONF = "--enable-static-libs --disable-ldap --disable-gnome --enable-gstreamer --disable-gdu --disable-scrollkeeper "
diff --git a/recipes/ekiga/ekiga_3.2.0.bb b/recipes/ekiga/ekiga_3.2.0.bb
index 49fffe3167..e467835552 100644
--- a/recipes/ekiga/ekiga_3.2.0.bb
+++ b/recipes/ekiga/ekiga_3.2.0.bb
@@ -5,7 +5,8 @@ ARM_INSTRUCTION_SET = "arm"
inherit gnome
DEPENDS += " avahi libnotify eds-dbus libgnome gtkmm libsigc++-2.0 gstreamer gst-plugins-good gst-plugins-base gst-plugins-bad opal ptlib gnome-doc-utils"
-RDEPENDS += "gst-plugin-app gst-plugin-video4linux2 opal ptlib"
+RDEPENDS_${PN} += "gst-plugin-app gst-plugin-video4linux2 opal ptlib"
+PR = "r1"
EXTRA_OECONF = "--enable-static-libs --disable-ldap --disable-gnome --enable-gstreamer --disable-gdu --disable-scrollkeeper "
diff --git a/recipes/ekiga/ekiga_3.2.4.bb b/recipes/ekiga/ekiga_3.2.4.bb
index ad96bd9c18..5bc7d8d263 100644
--- a/recipes/ekiga/ekiga_3.2.4.bb
+++ b/recipes/ekiga/ekiga_3.2.4.bb
@@ -5,7 +5,8 @@ ARM_INSTRUCTION_SET = "arm"
inherit gnome
DEPENDS += " avahi libnotify eds-dbus libgnome gtkmm libsigc++-2.0 gstreamer gst-plugins-good gst-plugins-base gst-plugins-bad opal ptlib gnome-doc-utils"
-RDEPENDS += "gst-plugin-app gst-plugin-video4linux2 opal ptlib"
+RDEPENDS_${PN} += "gst-plugin-app gst-plugin-video4linux2 opal ptlib"
+PR = "r1"
EXTRA_OECONF = "--enable-static-libs --disable-ldap --disable-gnome --enable-gstreamer --disable-gdu --disable-scrollkeeper "
diff --git a/recipes/ekiga/ekiga_3.2.5.bb b/recipes/ekiga/ekiga_3.2.5.bb
index 2d9f9fe806..abf6381ef1 100644
--- a/recipes/ekiga/ekiga_3.2.5.bb
+++ b/recipes/ekiga/ekiga_3.2.5.bb
@@ -5,7 +5,8 @@ ARM_INSTRUCTION_SET = "arm"
inherit gnome
DEPENDS += " avahi libnotify eds-dbus libgnome gtkmm libsigc++-2.0 gstreamer gst-plugins-good gst-plugins-base gst-plugins-bad opal ptlib gnome-doc-utils"
-RDEPENDS += "gst-plugin-app gst-plugin-video4linux2 opal ptlib"
+RDEPENDS_${PN} += "gst-plugin-app gst-plugin-video4linux2 opal ptlib"
+PR = "r1"
EXTRA_OECONF = "--enable-static-libs --disable-ldap --disable-gnome --enable-gstreamer --disable-gdu --disable-scrollkeeper "
diff --git a/recipes/ekiga/ekiga_3.2.7.bb b/recipes/ekiga/ekiga_3.2.7.bb
new file mode 100644
index 0000000000..c79c2225e0
--- /dev/null
+++ b/recipes/ekiga/ekiga_3.2.7.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Gnome videoconferencing application"
+LICENSE = "GPLv2"
+
+ARM_INSTRUCTION_SET = "arm"
+
+inherit gnome
+
+SRC_URI[archive.md5sum] = "5cf2edf199075a3c3d115ce9b94cbf0f"
+SRC_URI[archive.sha256sum] = "f25a1309b68eafe69f0d7aed461bc9a8196939060543d09bd2f19e0bb1e3fd8f"
+
+DEPENDS += " avahi libnotify eds-dbus libgnome gtkmm libsigc++-2.0 gstreamer gst-plugins-good gst-plugins-base gst-plugins-bad opal ptlib gnome-doc-utils"
+RDEPENDS_${PN} += "gst-plugin-app gst-plugin-video4linux2 opal ptlib"
+
+EXTRA_OECONF = "--enable-static-libs --disable-ldap --disable-gnome --enable-gstreamer --disable-gdu --disable-scrollkeeper "
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
+}
+
+FILES_${PN} += "${datadir}/dbus-1 ${datadir}/icons"
+
+
diff --git a/recipes/ekiga/ekiga_git.bb b/recipes/ekiga/ekiga_git.bb
index 91e73d26ff..025767b2c6 100644
--- a/recipes/ekiga/ekiga_git.bb
+++ b/recipes/ekiga/ekiga_git.bb
@@ -3,21 +3,22 @@ LICENSE = "GPLv2"
ARM_INSTRUCTION_SET = "arm"
-DEFAULT_PREFERENCE = "1"
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_angstrom = "1"
+
PV = "3.3.1+git"
-PR = "r3+gitr${SRCREV}"
-SRCREV = "c81cabbee7901b6643907d08f9a530308044ec22"
+PR = "r6+gitr${SRCREV}"
+SRCREV = "7c669dd4ce69296f09004f8876366058c20a3352"
inherit gnome
SRC_URI = "git://git.gnome.org/ekiga;protocol=git;branch=master \
- file://rgb16.patch;patch=1 \
"
S = "${WORKDIR}/git"
DEPENDS += " boost avahi libnotify eds-dbus libgnome gtkmm libsigc++-2.0 gstreamer gst-plugins-good gst-plugins-base gst-plugins-bad opal ptlib gnome-doc-utils"
-RDEPENDS += "gst-plugin-app gst-plugin-video4linux2 opal ptlib"
+RDEPENDS_${PN} += "gst-plugin-app gst-plugin-video4linux2 opal ptlib"
EXTRA_OECONF = " \
# --enable-static-libs \
diff --git a/recipes/ekiga/opal_3.4.4.bb b/recipes/ekiga/opal_3.4.4.bb
index 052d7989e2..5244d63740 100644
--- a/recipes/ekiga/opal_3.4.4.bb
+++ b/recipes/ekiga/opal_3.4.4.bb
@@ -6,7 +6,7 @@ inherit gnome
DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
SRC_URI = "http://www.ekiga.org/admin/downloads/latest/sources/ekiga_3.0.2/opal-${PV}.tar.bz2 \
- file://configure.diff;patch=1 \
+ file://configure.diff \
"
EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
@@ -20,10 +20,5 @@ do_configure() {
FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"
-do_stage() {
- autotools_stage_all
-}
-
-
SRC_URI[md5sum] = "01e76bc1261ab6c5b537387a81e7fdd9"
SRC_URI[sha256sum] = "3ed39e1dc74b4e1adb3d8a3430b18bcfd19d21406375faf420cbdcd5499a4594"
diff --git a/recipes/ekiga/opal_3.5.2.bb b/recipes/ekiga/opal_3.5.2.bb
index 2407e9b0ab..a8aa99117e 100644
--- a/recipes/ekiga/opal_3.5.2.bb
+++ b/recipes/ekiga/opal_3.5.2.bb
@@ -8,7 +8,7 @@ inherit gnome
DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/opal-${PV}.tar.bz2 \
- file://configure.diff;patch=1 \
+ file://configure.diff \
"
EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
@@ -25,10 +25,5 @@ do_configure() {
FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"
-do_stage() {
- autotools_stage_all
-}
-
-
SRC_URI[md5sum] = "7a1e7424b346ee0a0b719217a1081cfd"
SRC_URI[sha256sum] = "c11daf4e0baf1bc70d30411944f9a3238d61e3c1972c33443dbe0cb078cfe2d7"
diff --git a/recipes/ekiga/opal_3.6.1.bb b/recipes/ekiga/opal_3.6.1.bb
index 4460d76e6c..fa5ae8e26c 100644
--- a/recipes/ekiga/opal_3.6.1.bb
+++ b/recipes/ekiga/opal_3.6.1.bb
@@ -6,7 +6,7 @@ inherit gnome
DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/opal-${PV}.tar.bz2 \
- file://configure.diff;patch=1 \
+ file://configure.diff \
"
EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
@@ -23,10 +23,5 @@ do_configure() {
FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"
-do_stage() {
- autotools_stage_all
-}
-
-
SRC_URI[md5sum] = "c2b4f12822cef2182267ea0d020bddf6"
SRC_URI[sha256sum] = "e6b48a294b35449c851c2a6ea6969041ed7f4148e92b3faa03a330b7bb5a59af"
diff --git a/recipes/ekiga/opal_3.6.2.bb b/recipes/ekiga/opal_3.6.2.bb
index 5ba8f1191c..031ba5fef7 100644
--- a/recipes/ekiga/opal_3.6.2.bb
+++ b/recipes/ekiga/opal_3.6.2.bb
@@ -6,7 +6,7 @@ inherit gnome
DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/opal-${PV}.tar.bz2 \
- file://configure.diff;patch=1 \
+ file://configure.diff \
"
EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
@@ -23,10 +23,5 @@ do_configure() {
FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"
-do_stage() {
- autotools_stage_all
-}
-
-
SRC_URI[md5sum] = "88076eeadee1351704afb2aeb3532c17"
SRC_URI[sha256sum] = "09ffe451256fafdd74d4dc35ed153b93c81328c397d36872cca1f0104877caca"
diff --git a/recipes/ekiga/opal_3.6.4.bb b/recipes/ekiga/opal_3.6.4.bb
index 28ce3e709d..dcbfce49ab 100644
--- a/recipes/ekiga/opal_3.6.4.bb
+++ b/recipes/ekiga/opal_3.6.4.bb
@@ -6,7 +6,7 @@ inherit gnome
DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/opal-${PV}.tar.bz2 \
- file://configure.diff;patch=1 \
+ file://configure.diff \
"
EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
@@ -23,10 +23,5 @@ do_configure() {
FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"
-do_stage() {
- autotools_stage_all
-}
-
-
SRC_URI[md5sum] = "d894c176818a33d34a04b21386798c4f"
SRC_URI[sha256sum] = "b1fb3bad0c8581b82f0da9c69673f43ad9aed7868a7e4f2a68c6c72ed656237b"
diff --git a/recipes/ekiga/opal_3.6.6.bb b/recipes/ekiga/opal_3.6.6.bb
index d8cf9c852c..e8202bd3a2 100644
--- a/recipes/ekiga/opal_3.6.6.bb
+++ b/recipes/ekiga/opal_3.6.6.bb
@@ -6,7 +6,7 @@ inherit gnome
DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/opal-${PV}.tar.bz2 \
- file://configure.diff;patch=1 \
+ file://configure.diff \
"
EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
@@ -23,10 +23,5 @@ do_configure() {
FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"
-do_stage() {
- autotools_stage_all
-}
-
-
SRC_URI[md5sum] = "43b363c860780e7f1a0361cfee8f9f4a"
SRC_URI[sha256sum] = "60c9d75703bedfeca7140cb76b23fae7179ce1f86e7e8b0026b72d66acd75c82"
diff --git a/recipes/ekiga/opal_3.8.2.bb b/recipes/ekiga/opal_3.8.2.bb
new file mode 100644
index 0000000000..a8f4c645de
--- /dev/null
+++ b/recipes/ekiga/opal_3.8.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Open Phone Abstraction Library, implementation of the ITU H.323 teleconferencing protocol, and successor of the openh323 library."
+LICENSE = "MPL"
+
+PR = "r2"
+
+inherit gnome
+
+DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
+SRC_URI = "http://garr.dl.sourceforge.net/project/opalvoip/v3.8%20Sirius/Stable%202/opal-${PV}.tar.bz2;name=opal \
+ "
+SRC_URI[opal.md5sum] = "dff4204187f4a43ea8c2be376ea6155b"
+SRC_URI[opal.sha256sum] = "a699f4c3710a2ddb5ae9a6cba0e303bbd29a94ed011f642b7763729a61598c7c"
+
+EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
+ARM_INSTRUCTION_SET = "arm"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+TARGET_CC_ARCH += "-D__STDC_CONSTANT_MACROS"
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
+FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"
diff --git a/recipes/ekiga/ptlib_2.4.4.bb b/recipes/ekiga/ptlib_2.4.4.bb
index 08b0cb64dd..db98e6a44d 100644
--- a/recipes/ekiga/ptlib_2.4.4.bb
+++ b/recipes/ekiga/ptlib_2.4.4.bb
@@ -21,13 +21,5 @@ do_compile_append() {
FILES_${PN} += "${libdir}/ptlib-${PV}/*/*/*.so"
-do_stage() {
- autotools_stage_all
-}
-
-
-
-
-
SRC_URI[md5sum] = "221ea2f96ff6bae9cf604d8766eae526"
SRC_URI[sha256sum] = "c9ef4267490507fc9699634551b50c0c1c225d48e0c095a81be6fa5a1fa96a3a"
diff --git a/recipes/ekiga/ptlib_2.5.2.bb b/recipes/ekiga/ptlib_2.5.2.bb
index 04112e0e91..ef4bd53ddc 100644
--- a/recipes/ekiga/ptlib_2.5.2.bb
+++ b/recipes/ekiga/ptlib_2.5.2.bb
@@ -21,13 +21,5 @@ do_compile_append() {
FILES_${PN} += "${libdir}/ptlib-${PV}/*/*/*.so"
-do_stage() {
- autotools_stage_all
-}
-
-
-
-
-
SRC_URI[md5sum] = "7d8dcd999827d51ad4a15afe74aad181"
SRC_URI[sha256sum] = "c99897464bd07c73dbb72095a9806ddc0c26141230e34b181d7e742e78259e4b"
diff --git a/recipes/ekiga/ptlib_2.6.1.bb b/recipes/ekiga/ptlib_2.6.1.bb
index db7a502cf0..93a8df9a09 100644
--- a/recipes/ekiga/ptlib_2.6.1.bb
+++ b/recipes/ekiga/ptlib_2.6.1.bb
@@ -21,13 +21,5 @@ do_compile_append() {
FILES_${PN} += "${libdir}/ptlib-${PV}/*/*/*.so"
-do_stage() {
- autotools_stage_all
-}
-
-
-
-
-
SRC_URI[md5sum] = "122ab96fcc44110ce05153f259b3285a"
SRC_URI[sha256sum] = "b8301389c1ee9968df8075942061665e33198d3865f92d8fb26e519068517305"
diff --git a/recipes/ekiga/ptlib_2.6.2.bb b/recipes/ekiga/ptlib_2.6.2.bb
index c9cc5829ab..46f224af17 100644
--- a/recipes/ekiga/ptlib_2.6.2.bb
+++ b/recipes/ekiga/ptlib_2.6.2.bb
@@ -21,13 +21,5 @@ do_compile_append() {
FILES_${PN} += "${libdir}/ptlib-${PV}/*/*/*.so"
-do_stage() {
- autotools_stage_all
-}
-
-
-
-
-
SRC_URI[md5sum] = "d478121cfc82da7c0f0ce0e53fc7c2fd"
SRC_URI[sha256sum] = "941ead5179f5bab8dd6e81806b6e52120dc5b98c6ced8128df24639af1eabedd"
diff --git a/recipes/ekiga/ptlib_2.6.4.bb b/recipes/ekiga/ptlib_2.6.4.bb
index 92d34ff85d..6ad0ed4537 100644
--- a/recipes/ekiga/ptlib_2.6.4.bb
+++ b/recipes/ekiga/ptlib_2.6.4.bb
@@ -27,13 +27,5 @@ do_install_append() {
FILES_${PN} += "${libdir}/ptlib-${PV}/*/*/*.so"
-do_stage() {
- autotools_stage_all
-}
-
-
-
-
-
SRC_URI[md5sum] = "bcc8e2d5bb6be7e3fea857ce2f7fce5c"
SRC_URI[sha256sum] = "22eae4f6c72247f8ac79c57ce4469797ad3df67614758c5096b7ce9290bd10b4"
diff --git a/recipes/ekiga/ptlib_2.6.5.bb b/recipes/ekiga/ptlib_2.6.5.bb
index c6a19b997e..7d544d5cf1 100644
--- a/recipes/ekiga/ptlib_2.6.5.bb
+++ b/recipes/ekiga/ptlib_2.6.5.bb
@@ -8,7 +8,7 @@ inherit gnome
DEPENDS += "libgsm openldap openssl expat virtual/libsdl alsa-lib"
SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/ptlib-${PV}.tar.bz2 \
- file://rgb16.patch;patch=1 \
+ file://rgb16.patch \
"
do_configure() {
diff --git a/recipes/ekiga/ptlib_2.8.2.bb b/recipes/ekiga/ptlib_2.8.2.bb
new file mode 100644
index 0000000000..20bc20bee0
--- /dev/null
+++ b/recipes/ekiga/ptlib_2.8.2.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Portable Tools Libary"
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += "libgsm openldap openssl expat virtual/libsdl alsa-lib"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/ptlib-${PV}.tar.bz2;name=ptlib \
+"
+SRC_URI[ptlib.md5sum] = "3248cbea1af92439a10a4ef15824e9e3"
+SRC_URI[ptlib.sha256sum] = "5e4518710e6f7daebe93581c388ef37c56fa3a1529b1ad48be86213ab3f3b8c7"
+
+EXTRA_OECONF = " --enable-exceptions "
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ ptlib.pc
+}
+
+do_install_append() {
+ chmod +x ${D}${libdir}/*
+}
+
+FILES_${PN} += "${libdir}/ptlib-${PV}/*/*/*.so"
+
+