aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/enca/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/enca/files')
-rw-r--r--recipes/enca/files/configure-hack.patch12
-rw-r--r--recipes/enca/files/configure-remove-dumbness.patch26
-rw-r--r--recipes/enca/files/dont-run-tests.patch13
-rw-r--r--recipes/enca/files/makefile-remove-tools.patch13
4 files changed, 64 insertions, 0 deletions
diff --git a/recipes/enca/files/configure-hack.patch b/recipes/enca/files/configure-hack.patch
new file mode 100644
index 0000000000..85abcdcf02
--- /dev/null
+++ b/recipes/enca/files/configure-hack.patch
@@ -0,0 +1,12 @@
+--- enca-1.9/configure.ac.orig 2006-02-15 00:57:39.000000000 -0800
++++ enca-1.9/configure.ac 2006-02-15 00:57:46.000000000 -0800
+@@ -92,9 +92,6 @@
+ dnl And for gtk-doc
+ gtk_CHECK_GTK_DOC
+
+-dnl Check for good random number sources
+-AC_CHECK_FILES(/dev/random /dev/urandom /dev/srandom /dev/arandom)
+-
+ dnl Dirty path hack. Helps some people with badly set up search paths.
+ if test "$prefix" = "NONE"; then
+ LDFLAGS="$LDFLAGS -L$ac_default_prefix/lib"
diff --git a/recipes/enca/files/configure-remove-dumbness.patch b/recipes/enca/files/configure-remove-dumbness.patch
new file mode 100644
index 0000000000..6f6f3e320e
--- /dev/null
+++ b/recipes/enca/files/configure-remove-dumbness.patch
@@ -0,0 +1,26 @@
+--- enca-1.9/configure.ac.orig 2006-06-29 15:30:44.000000000 +0100
++++ enca-1.9/configure.ac 2006-06-29 15:31:41.000000000 +0100
+@@ -92,14 +92,15 @@
+ dnl And for gtk-doc
+ gtk_CHECK_GTK_DOC
+
+-dnl Dirty path hack. Helps some people with badly set up search paths.
+-if test "$prefix" = "NONE"; then
+- LDFLAGS="$LDFLAGS -L$ac_default_prefix/lib"
+- CPPFLAGS="$CPPFLAGS -I$ac_default_prefix/include"
+-else
+- LDFLAGS="$LDFLAGS -L$prefix/lib"
+- CPPFLAGS="$CPPFLAGS -I$prefix/include"
+-fi
++# This is really dumb code
++#dnl Dirty path hack. Helps some people with badly set up search paths.
++#if test "$prefix" = "NONE"; then
++# LDFLAGS="$LDFLAGS -L$ac_default_prefix/lib"
++# CPPFLAGS="$CPPFLAGS -I$ac_default_prefix/include"
++#else
++# LDFLAGS="$LDFLAGS -L$prefix/lib"
++# CPPFLAGS="$CPPFLAGS -I$prefix/include"
++#fi
+
+ dnl Checks for libraries.
+ ye_CHECK_LIBM
diff --git a/recipes/enca/files/dont-run-tests.patch b/recipes/enca/files/dont-run-tests.patch
new file mode 100644
index 0000000000..321d1e6201
--- /dev/null
+++ b/recipes/enca/files/dont-run-tests.patch
@@ -0,0 +1,13 @@
+Index: enca-1.9/Makefile.am
+===================================================================
+--- enca-1.9.orig/Makefile.am 2005-11-24 11:21:32.000000000 +0100
++++ enca-1.9/Makefile.am 2006-04-11 11:14:21.832502904 +0200
+@@ -2,7 +2,7 @@
+ if MAINTAINER_MODE
+ SUBDIRS = tools data script lib src devel-docs test
+ else
+-SUBDIRS = tools script lib src devel-docs test
++SUBDIRS = tools script lib src devel-docs
+ endif
+ man_MANS = man/enca.1
+
diff --git a/recipes/enca/files/makefile-remove-tools.patch b/recipes/enca/files/makefile-remove-tools.patch
new file mode 100644
index 0000000000..accfbccd6b
--- /dev/null
+++ b/recipes/enca/files/makefile-remove-tools.patch
@@ -0,0 +1,13 @@
+--- enca-1.9/Makefile.am.orig 2006-06-29 15:34:55.000000000 +0100
++++ enca-1.9/Makefile.am 2006-06-29 15:35:20.000000000 +0100
+@@ -1,8 +1,8 @@
+ # @(#) $Id: Makefile.am,v 1.35 2005/11/24 10:21:32 yeti Exp $
+ if MAINTAINER_MODE
+-SUBDIRS = tools data script lib src devel-docs test
++SUBDIRS = data script lib src devel-docs test
+ else
+-SUBDIRS = tools script lib src devel-docs
++SUBDIRS = script lib src devel-docs
+ endif
+ man_MANS = man/enca.1
+