aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/erlang
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/erlang')
-rw-r--r--recipes/erlang/erlang-native_R13B01.bb5
-rw-r--r--recipes/erlang/erlang_R13B01.bb5
2 files changed, 8 insertions, 2 deletions
diff --git a/recipes/erlang/erlang-native_R13B01.bb b/recipes/erlang/erlang-native_R13B01.bb
index bc0e343b42..0e69dcee83 100644
--- a/recipes/erlang/erlang-native_R13B01.bb
+++ b/recipes/erlang/erlang-native_R13B01.bb
@@ -2,13 +2,16 @@ include erlang.inc
inherit native
+PR = "r1"
+
# EXTRA_OEMAKE = 'OTP_SMALL_BUILD=true'
EXTRA_OECONF = '--without-ssl'
do_configure() {
TARGET=${HOST_SYS} \
ac_cv_prog_javac_ver_1_2=no \
- oe_runconf
+ ac_cv_prog_javac_ver_1_5=no \
+ oe_runconf
}
do_compile_prepend() {
diff --git a/recipes/erlang/erlang_R13B01.bb b/recipes/erlang/erlang_R13B01.bb
index 33ecfc7564..eda4db67a4 100644
--- a/recipes/erlang/erlang_R13B01.bb
+++ b/recipes/erlang/erlang_R13B01.bb
@@ -1,6 +1,8 @@
include erlang.inc
DEPENDS += "erlang-native openssl"
+PR = "r1"
+
SRC_URI += "\
file://erts-emulator-Makefile.in.patch;patch=1 \
file://erts-etc-unix-Install.src.patch;patch=1 \
@@ -29,7 +31,8 @@ do_configure() {
. ${CONFIG_SITE}
ac_cv_prog_javac_ver_1_2=no \
- SHLIB_LD='${CC}' \
+ ac_cv_prog_javac_ver_1_5=no \
+ SHLIB_LD='${CC}' \
oe_runconf
sed -i -e 's|$(ERL_TOP)/bin/dialyzer|${NATIVE_BIN}/dialyzer --output_plt $@ -pa $(ERL_TOP)/lib/kernel/ebin -pa $(ERL_TOP)/lib/stdlib/ebin|' lib/dialyzer/src/Makefile