aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/esound
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/esound')
-rw-r--r--recipes/esound/esound_0.2.36.bb34
-rw-r--r--recipes/esound/files/configure-fix.patch10
-rw-r--r--recipes/esound/files/no-docs.patch11
3 files changed, 55 insertions, 0 deletions
diff --git a/recipes/esound/esound_0.2.36.bb b/recipes/esound/esound_0.2.36.bb
new file mode 100644
index 0000000000..388b52c7e3
--- /dev/null
+++ b/recipes/esound/esound_0.2.36.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Enlightened Sound Daemon"
+SECTION = "gpe/base"
+LICENSE = "GPL"
+DEPENDS = "audiofile"
+PE = "1"
+PR = "r3"
+
+inherit gnome binconfig
+
+SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/esound/0.2/esound-0.2.36.tar.bz2 \
+ https://launchpad.net/ubuntu/breezy/+source/esound/0.2.36-1ubuntu5/+files/esound_0.2.36-1ubuntu5.diff.gz;patch=1 \
+ file://no-docs.patch;patch=1 \
+ file://configure-fix.patch;patch=1"
+
+EXTRA_OECONF = " \
+ --disable-alsa \
+ --disable-arts \
+ --disable-artstest \
+"
+do_configure_prepend() {
+ sed -i -e 's:/usr/include/mme:${STAGING_INCDIR}/mme:g' configure.ac
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+PACKAGES =+ "esddsp esd esd-utils"
+
+FILES_esddsp = "${bindir}/esddsp ${libdir}/libesddsp.so.*"
+FILES_esd = "${bindir}/esd"
+FILES_esd-utils = "${bindir}/*"
+
diff --git a/recipes/esound/files/configure-fix.patch b/recipes/esound/files/configure-fix.patch
new file mode 100644
index 0000000000..8fdc35ad5e
--- /dev/null
+++ b/recipes/esound/files/configure-fix.patch
@@ -0,0 +1,10 @@
+--- /tmp/configure.ac 2008-06-02 16:46:55.640793306 +0200
++++ esound-0.2.36/configure.ac 2008-06-02 16:47:26.030793494 +0200
+@@ -29,6 +29,7 @@
+ AC_SUBST(pkgdocdir)
+
+ AC_PROG_CC
++AC_PROG_CXX
+ AC_PROG_CPP
+ AC_LIBTOOL_WIN32_DLL
+ AM_PROG_LIBTOOL
diff --git a/recipes/esound/files/no-docs.patch b/recipes/esound/files/no-docs.patch
new file mode 100644
index 0000000000..fc69f1a038
--- /dev/null
+++ b/recipes/esound/files/no-docs.patch
@@ -0,0 +1,11 @@
+Index: esound-0.2.36/Makefile.am
+===================================================================
+--- esound-0.2.36.orig/Makefile.am
++++ esound-0.2.36/Makefile.am
+@@ -1,5 +1,5 @@
+
+-SUBDIRS = docs
++SUBDIRS =
+
+ ACLOCAL_FLAGS = -I m4
+