aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/espgs/espgs_7.07.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/espgs/espgs_7.07.1.bb')
-rw-r--r--recipes/espgs/espgs_7.07.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/espgs/espgs_7.07.1.bb b/recipes/espgs/espgs_7.07.1.bb
new file mode 100644
index 0000000000..b6f422fb03
--- /dev/null
+++ b/recipes/espgs/espgs_7.07.1.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "ESP Ghostscript is an up-to-date GNU Ghostscript distribution \
+including bug fixes, new drivers, and additional support for CUPS."
+HOMEPAGE = "http://espgs.sf.net"
+SECTION = "libs"
+DEPENDS = "jpeg zlib libpng"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/espgs/espgs-${PV}-source.tar.bz2"
+S = "${WORKDIR}/espgs-${PV}"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+EXTRA_OECONF = "--with-drivers= \
+ --without-ijs \
+ --without-gimp-print \
+ --without-omni \
+ --without-x \
+ --disable-cups"
+
+do_compile() {
+ oe_runmake CCAUX="${BUILD_CC}"
+}
+
+do_install () {
+ oe_runmake 'prefix=${D}${prefix}' \
+ 'bindir=${D}${bindir}' \
+ 'datadir=${D}${datadir}' \
+ 'mandir=${D}${mandir}' install
+}