aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/espgs
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/espgs')
-rw-r--r--recipes/espgs/espgs_7.07.1.bb31
-rw-r--r--recipes/espgs/espgs_8.15.3.bb55
2 files changed, 86 insertions, 0 deletions
diff --git a/recipes/espgs/espgs_7.07.1.bb b/recipes/espgs/espgs_7.07.1.bb
new file mode 100644
index 0000000000..b6f422fb03
--- /dev/null
+++ b/recipes/espgs/espgs_7.07.1.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "ESP Ghostscript is an up-to-date GNU Ghostscript distribution \
+including bug fixes, new drivers, and additional support for CUPS."
+HOMEPAGE = "http://espgs.sf.net"
+SECTION = "libs"
+DEPENDS = "jpeg zlib libpng"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/espgs/espgs-${PV}-source.tar.bz2"
+S = "${WORKDIR}/espgs-${PV}"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+EXTRA_OECONF = "--with-drivers= \
+ --without-ijs \
+ --without-gimp-print \
+ --without-omni \
+ --without-x \
+ --disable-cups"
+
+do_compile() {
+ oe_runmake CCAUX="${BUILD_CC}"
+}
+
+do_install () {
+ oe_runmake 'prefix=${D}${prefix}' \
+ 'bindir=${D}${bindir}' \
+ 'datadir=${D}${datadir}' \
+ 'mandir=${D}${mandir}' install
+}
diff --git a/recipes/espgs/espgs_8.15.3.bb b/recipes/espgs/espgs_8.15.3.bb
new file mode 100644
index 0000000000..13cfad6d12
--- /dev/null
+++ b/recipes/espgs/espgs_8.15.3.bb
@@ -0,0 +1,55 @@
+DESCRIPTION = "ESP Ghostscript is an up-to-date GNU Ghostscript distribution \
+including bug fixes, new drivers, and additional support for CUPS."
+HOMEPAGE = "http://www.cups.org/espgs/"
+SECTION = "libs"
+DEPENDS = "jpeg zlib libpng tiff fontconfig"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/ghostscript/${PV}/espgs-${PV}-source.tar.bz2"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+EXTRA_OECONF = "--with-drivers=ALL \
+ --enable-cups \
+ --without-ijs \
+ --disable-gtk \
+ --without-gimp-print \
+ --without-x \
+ --without-omni"
+
+do_compile() {
+ oe_runmake CCAUX="${BUILD_CC}"
+}
+
+
+do_install () {
+ oe_runmake 'prefix=${D}${prefix}' \
+ 'bindir=${D}${bindir}' \
+ 'datadir=${D}${datadir}' \
+ 'cups_datadir=${D}${datadir}/cups' \
+ 'cups_serverroot=${D}${sysconfdir}/cups' \
+ 'cups_serverbin= ${D}${libdir}/cups' \
+ 'CUPSSERVER=${cups_serverbin}' \
+ 'CUPSCONFIG=${cups_serverroot}' \
+ 'CUPSDATA=${cups_datadir}' \
+ 'sysconfdir=${D}${sysconfdir}' \
+ 'gsdir=${D}${datadir}/ghostscript' \
+ 'gsdatadir=${D}${datadir}/ghostscript/8.15' \
+ 'mandir=${D}${mandir}' \
+ 'docdir=${D}${datadir}/doc/espgs/' install
+}
+
+PACKAGES += "espgs-examples espgs-resources"
+
+# I added the lib dir to the central package, since espgs complained of a missing file when run.
+# If I find exactly which files are needed for operation, I'll just add those, and split the package.
+
+FILES_${PN} += "${datadir}/ghostscript/8.15/lib/* \
+ ${libdir}/cups/filter/* \
+ ${datadir}/cups/model/* \"
+FILES_${PN}-doc += "${datadir}/ghostscript/8.15/doc/*"
+FILES_${PN}-examples += "${datadir}/ghostscript/8.15/examples/*"
+FILES_${PN}-resources += "${datadir}/ghostscript/8.15/Resource/*"