summaryrefslogtreecommitdiffstats
path: root/recipes/etherpuppet/etherpuppet_0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/etherpuppet/etherpuppet_0.2.bb')
-rw-r--r--recipes/etherpuppet/etherpuppet_0.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/etherpuppet/etherpuppet_0.2.bb b/recipes/etherpuppet/etherpuppet_0.2.bb
new file mode 100644
index 0000000000..0f3150e8e4
--- /dev/null
+++ b/recipes/etherpuppet/etherpuppet_0.2.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Etherpuppet is a small program for Linux that will create a \
+voodoo doll for an Ethernet interface. You have to run the Etherpuppet on \
+your machine to create the doll, which will have the shape of a virtual \
+TUN/TAP interface (named by default puppet%d, where %d is a number). \
+You also have to run Etherpuppet on the victim interface's machine."
+SECTION = "console/network"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.secdev.org/projects/etherpuppet/files/etherpuppet.c"
+S = "${WORKDIR}"
+
+do_unpack() {
+ install -m 0644 ${DL_DIR}/etherpuppet.c ${S}
+}
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LFLAGS} -o etherpuppet etherpuppet.c
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 etherpuppet ${D}${sbindir}
+}
+