aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ezx/ezx-boot-usb-native_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ezx/ezx-boot-usb-native_svn.bb')
-rw-r--r--recipes/ezx/ezx-boot-usb-native_svn.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/ezx/ezx-boot-usb-native_svn.bb b/recipes/ezx/ezx-boot-usb-native_svn.bb
new file mode 100644
index 0000000000..426ad4a555
--- /dev/null
+++ b/recipes/ezx/ezx-boot-usb-native_svn.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Boot a Motorola EZX device with a user supplied kernel"
+DEPENDS = "libusb-native virtual/kernel"
+SECTION = "devel"
+AUTHOR = "Team OpenEZX <openezx-devel@lists.openezx.org>"
+LICENSE = "GPL"
+PV = "0.3.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.openezx.org/trunk/src/host;module=boot_usb;proto=http"
+S = "${WORKDIR}/boot_usb"
+
+EXTRA_OECONF := '--with-kernel-dir="${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"'
+
+inherit autotools native
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_TOOLS}
+ install -m 0755 boot_usb ${DEPLOY_DIR_TOOLS}/ezx-boot-usb-${PV}
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ :
+}
+
+addtask deploy before do_build after do_compile