aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ezx/ezx-gpiotool_1877.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ezx/ezx-gpiotool_1877.bb')
-rw-r--r--recipes/ezx/ezx-gpiotool_1877.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/ezx/ezx-gpiotool_1877.bb b/recipes/ezx/ezx-gpiotool_1877.bb
new file mode 100644
index 0000000000..81a1ecc2a0
--- /dev/null
+++ b/recipes/ezx/ezx-gpiotool_1877.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Gpiotool can read/write gpio configuration from userspace."
+SECTION = "devel"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.openezx.org"
+AUTHOR = "Harald Welte"
+PR = "r0"
+
+SRC_URI = "svn://svn.openezx.org/trunk/src/userspace;module=gpiotool;proto=http;rev=${PV}"
+S = "${WORKDIR}/gpiotool"
+
+do_compile() {
+ for i in mmio.c gpiotool.c gpio.c
+ do
+ ${CC} ${CFLAGS} -c $i
+ done
+ ${CC} ${CFLAGS} -o ezx-gpiotool mmio.o gpiotool.o gpio.o
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ezx-gpiotool ${D}${sbindir}
+}