aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ezx
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ezx')
-rw-r--r--recipes/ezx/ezxd/ezxd.init5
-rw-r--r--recipes/ezx/ezxd_svn.bb4
2 files changed, 8 insertions, 1 deletions
diff --git a/recipes/ezx/ezxd/ezxd.init b/recipes/ezx/ezxd/ezxd.init
index a345952d1e..ba44942829 100644
--- a/recipes/ezx/ezxd/ezxd.init
+++ b/recipes/ezx/ezxd/ezxd.init
@@ -37,6 +37,11 @@ start_it_up()
fi
echo -n "Starting $DESC: "
+ modprobe ohci-hcd
+ sleep 2
+ modprobe moto-usb-ipc
+ modprobe ts27010mux
+
start-stop-daemon --start --background --quiet --pidfile $PIDFILE \
--exec $DAEMON -- --system $PARAMS
# We need to sleep here because opening the mux devices takes some time
diff --git a/recipes/ezx/ezxd_svn.bb b/recipes/ezx/ezxd_svn.bb
index 134980f4c0..19bbd93184 100644
--- a/recipes/ezx/ezxd_svn.bb
+++ b/recipes/ezx/ezxd_svn.bb
@@ -22,7 +22,9 @@ CFLAGS_append = " -DDEBUG "
TARGET_CC_ARCH += "${LDFLAGS}"
do_configure() {
- sed -i -e s:CROSS:CC:g Makefile
+ # Comment out both CC and CROSS definitions
+ sed -i -e 's:^CC.*$:#\0:g' Makefile
+ sed -i -e 's:^CROSS.*$:#\0:g' Makefile
}
fakeroot do_install() {