aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fakeroot/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fakeroot/files')
-rw-r--r--recipes/fakeroot/files/configure-libtool.patch20
-rw-r--r--recipes/fakeroot/files/fix-prefix.patch15
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes/fakeroot/files/configure-libtool.patch b/recipes/fakeroot/files/configure-libtool.patch
new file mode 100644
index 0000000000..46f7df7025
--- /dev/null
+++ b/recipes/fakeroot/files/configure-libtool.patch
@@ -0,0 +1,20 @@
+Index: fakeroot-1.12.1/configure.ac
+===================================================================
+--- fakeroot-1.12.1.orig/configure.ac
++++ fakeroot-1.12.1/configure.ac
+@@ -2,14 +2,12 @@
+ AC_INIT([fakeroot],[FAKEROOT_VERSION],[schizo@debian.org],[fakeroot])
+ AC_PREREQ(2.61)
+ AC_CONFIG_MACRO_DIR([build-aux])
+-LT_PREREQ(2.1a)
+ AC_CANONICAL_TARGET
+ AM_INIT_AUTOMAKE
+ AM_MAINTAINER_MODE
+ AC_CONFIG_HEADERS([config.h])
+ AC_PROG_MAKE_SET
+-LT_INIT
+-LT_LANG(C)
++AC_PROG_LIBTOOL
+
+ AH_BOTTOM([#if ! HAVE_BUILTIN_EXPECT
+ #define __builtin_expect(x, expected_value) (x)
diff --git a/recipes/fakeroot/files/fix-prefix.patch b/recipes/fakeroot/files/fix-prefix.patch
new file mode 100644
index 0000000000..3c47bd7650
--- /dev/null
+++ b/recipes/fakeroot/files/fix-prefix.patch
@@ -0,0 +1,15 @@
+Index: fakeroot-1.12.1/scripts/fakeroot.in
+===================================================================
+--- fakeroot-1.12.1.orig/scripts/fakeroot.in
++++ fakeroot-1.12.1/scripts/fakeroot.in
+@@ -30,8 +30,8 @@
+ }
+
+ # strip /bin/fakeroot to find install prefix
+-PREFIX=@prefix@
+-BINDIR=@bindir@
++BINDIR=`dirname $0`
++PREFIX=`dirname ${BINDIR}`
+
+ USEABSLIBPATH=@LDPRELOADABS@
+ LIB=lib@fakeroot_transformed@@DLSUFFIX@