aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fastjar/fastjar-native_0.92+gcc3.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fastjar/fastjar-native_0.92+gcc3.4.2.bb')
-rw-r--r--recipes/fastjar/fastjar-native_0.92+gcc3.4.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/fastjar/fastjar-native_0.92+gcc3.4.2.bb b/recipes/fastjar/fastjar-native_0.92+gcc3.4.2.bb
new file mode 100644
index 0000000000..367912fa8b
--- /dev/null
+++ b/recipes/fastjar/fastjar-native_0.92+gcc3.4.2.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "jar replacement written in C."
+HOMEPAGE = "http://sourceforge.net/projects/fastjar/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEPENDS = "zlib"
+
+GCC_VER = "${@bb.data.getVar('PV',d,1).split('gcc')[1]}"
+SRC_URI = "${GNU_MIRROR}/gcc/gcc-${GCC_VER}/gcc-${GCC_VER}.tar.bz2"
+
+S = "${WORKDIR}/gcc-${GCC_VER}"
+
+inherit autotools native
+
+EXTRA_OECONF = "--with-system-zlib --with-fastjar"
+
+do_configure () {
+ gnu-configize || die "failure running gnu-configize"
+ oe_runconf
+}
+
+do_compile() {
+ oe_runmake maybe-all-fastjar
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 fastjar/jar ${STAGING_BINDIR}/fastjar
+ install -m 755 fastjar/grepjar ${STAGING_BINDIR}
+}