aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fbpanel/fbpanel_4.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fbpanel/fbpanel_4.12.bb')
-rw-r--r--recipes/fbpanel/fbpanel_4.12.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/fbpanel/fbpanel_4.12.bb b/recipes/fbpanel/fbpanel_4.12.bb
new file mode 100644
index 0000000000..6c5997fea2
--- /dev/null
+++ b/recipes/fbpanel/fbpanel_4.12.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "A gtk based panel application"
+SECTION = "x11"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libxmu libxpm"
+HOMEPAGE = "http://fbpanel.sourceforge.net/"
+SRC_URI = "${SOURCEFORGE_MIRROR}/fbpanel/fbpanel-${PV}.tgz"
+
+PR = "r1"
+
+LDFLAGS += "-Wl,--export-dynamic"
+
+do_configure () {
+ ./configure --prefix=/usr --cpu=on
+}
+
+do_compile () {
+ oe_runmake CHATTY=1
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 fbpanel ${D}${bindir}
+ install -d ${D}${datadir}/fbpanel/
+ install -d ${D}${datadir}/fbpanel/plugins
+ install -m 644 plugins/*.so ${D}${datadir}/fbpanel/plugins
+ install -m 644 systray/tray.so ${D}${datadir}/fbpanel/plugins
+ install -m 644 config/default ${D}${datadir}/fbpanel/default
+ install -d ${D}${datadir}/fbpanel/images
+ install -m 644 config/images/* ${D}${datadir}/fbpanel/images
+}