aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fbpanel/fbpanel_4.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fbpanel/fbpanel_4.3.bb')
-rw-r--r--recipes/fbpanel/fbpanel_4.3.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/fbpanel/fbpanel_4.3.bb b/recipes/fbpanel/fbpanel_4.3.bb
new file mode 100644
index 0000000000..b849df0c6f
--- /dev/null
+++ b/recipes/fbpanel/fbpanel_4.3.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "A gtk based panel application"
+SECTION = "x11"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libxmu libxpm"
+HOMEPAGE = "http://fbpanel.sourceforge.net/"
+SRC_URI = "${SOURCEFORGE_MIRROR}/fbpanel/fbpanel-${PV}.tgz \
+ file://makefile.common.patch;patch=1 "
+
+PR = "r1"
+
+LDFLAGS += "-Wl,--export-dynamic"
+
+do_configure () {
+ ./configure --prefix=/usr --cpu=on
+}
+
+do_compile () {
+ oe_runmake CHATTY=1
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 fbpanel ${D}${bindir}
+ install -d ${D}${datadir}/fbpanel/
+ install -d ${D}${datadir}/fbpanel/plugins
+ install -m 644 plugins/*.so ${D}${datadir}/fbpanel/plugins
+ install -m 644 systray/tray.so ${D}${datadir}/fbpanel/plugins
+ install -m 644 config/default ${D}${datadir}/fbpanel/default
+ install -d ${D}${datadir}/fbpanel/images
+ install -m 644 config/images/* ${D}${datadir}/fbpanel/images
+}
+