aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fbpanel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fbpanel')
-rw-r--r--recipes/fbpanel/fbpanel-4.3/makefile.common.patch13
-rw-r--r--recipes/fbpanel/fbpanel_4.12.bb30
-rw-r--r--recipes/fbpanel/fbpanel_4.3.bb32
3 files changed, 75 insertions, 0 deletions
diff --git a/recipes/fbpanel/fbpanel-4.3/makefile.common.patch b/recipes/fbpanel/fbpanel-4.3/makefile.common.patch
new file mode 100644
index 0000000000..13807b063a
--- /dev/null
+++ b/recipes/fbpanel/fbpanel-4.3/makefile.common.patch
@@ -0,0 +1,13 @@
+--- fbpanel-4.3/Makefile.common.orig 2006-02-27 15:01:37.000000000 +0000
++++ fbpanel-4.3/Makefile.common 2006-02-27 15:02:04.000000000 +0000
+@@ -83,8 +83,8 @@
+ # compile flags
+
+ RM = rm -f
+-CC = gcc
+-AR = ar
++#CC = gcc
++#AR = ar
+ LIBS = $(shell pkg-config --libs gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0) -L/usr/X11R6/lib -lXmu
+ INCS2 = $(shell pkg-config --cflags gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0)
+ INCS := $(INCS2:-I%=-isystem %)
diff --git a/recipes/fbpanel/fbpanel_4.12.bb b/recipes/fbpanel/fbpanel_4.12.bb
new file mode 100644
index 0000000000..6c5997fea2
--- /dev/null
+++ b/recipes/fbpanel/fbpanel_4.12.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "A gtk based panel application"
+SECTION = "x11"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libxmu libxpm"
+HOMEPAGE = "http://fbpanel.sourceforge.net/"
+SRC_URI = "${SOURCEFORGE_MIRROR}/fbpanel/fbpanel-${PV}.tgz"
+
+PR = "r1"
+
+LDFLAGS += "-Wl,--export-dynamic"
+
+do_configure () {
+ ./configure --prefix=/usr --cpu=on
+}
+
+do_compile () {
+ oe_runmake CHATTY=1
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 fbpanel ${D}${bindir}
+ install -d ${D}${datadir}/fbpanel/
+ install -d ${D}${datadir}/fbpanel/plugins
+ install -m 644 plugins/*.so ${D}${datadir}/fbpanel/plugins
+ install -m 644 systray/tray.so ${D}${datadir}/fbpanel/plugins
+ install -m 644 config/default ${D}${datadir}/fbpanel/default
+ install -d ${D}${datadir}/fbpanel/images
+ install -m 644 config/images/* ${D}${datadir}/fbpanel/images
+}
diff --git a/recipes/fbpanel/fbpanel_4.3.bb b/recipes/fbpanel/fbpanel_4.3.bb
new file mode 100644
index 0000000000..b849df0c6f
--- /dev/null
+++ b/recipes/fbpanel/fbpanel_4.3.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "A gtk based panel application"
+SECTION = "x11"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libxmu libxpm"
+HOMEPAGE = "http://fbpanel.sourceforge.net/"
+SRC_URI = "${SOURCEFORGE_MIRROR}/fbpanel/fbpanel-${PV}.tgz \
+ file://makefile.common.patch;patch=1 "
+
+PR = "r1"
+
+LDFLAGS += "-Wl,--export-dynamic"
+
+do_configure () {
+ ./configure --prefix=/usr --cpu=on
+}
+
+do_compile () {
+ oe_runmake CHATTY=1
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 fbpanel ${D}${bindir}
+ install -d ${D}${datadir}/fbpanel/
+ install -d ${D}${datadir}/fbpanel/plugins
+ install -m 644 plugins/*.so ${D}${datadir}/fbpanel/plugins
+ install -m 644 systray/tray.so ${D}${datadir}/fbpanel/plugins
+ install -m 644 config/default ${D}${datadir}/fbpanel/default
+ install -d ${D}${datadir}/fbpanel/images
+ install -m 644 config/images/* ${D}${datadir}/fbpanel/images
+}
+