aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fbv/fbv_1.0b.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fbv/fbv_1.0b.bb')
-rw-r--r--recipes/fbv/fbv_1.0b.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/fbv/fbv_1.0b.bb b/recipes/fbv/fbv_1.0b.bb
new file mode 100644
index 0000000000..04c70661d6
--- /dev/null
+++ b/recipes/fbv/fbv_1.0b.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Frame Buffer Viewer"
+LICENSE = "GPL"
+DEPENDS = "libpng"
+PR = "r1"
+
+SRC_URI = "http://s-tech.elsat.net.pl/fbv/fbv-1.0b.tar.gz \
+ file://cross_compile.patch;patch=1"
+
+do_configure() {
+ CC="${CC}" ./configure --without-libungif --without-bmp \
+ --without-libjpeg
+}
+
+do_compile() {
+ oe_runmake CFLAGS="-O2 -Wall -D_GNU_SOURCE -D__KERNEL_STRICT_NAMES" \
+ CC="${CC}"
+}
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 fbv ${D}${bindir}
+
+ # man
+ install -d ${D}${mandir}/man1/
+ install -m 0644 fbv.1 ${D}${mandir}/man1/fbv.1
+}