aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/feh
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/feh')
-rw-r--r--recipes/feh/feh-1.7/noxinerama.patch13
-rw-r--r--recipes/feh/feh_1.7.bb17
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes/feh/feh-1.7/noxinerama.patch b/recipes/feh/feh-1.7/noxinerama.patch
new file mode 100644
index 0000000000..d84d9d5d66
--- /dev/null
+++ b/recipes/feh/feh-1.7/noxinerama.patch
@@ -0,0 +1,13 @@
+--- a/config.mk 2010-06-10 14:16:09.000000000 +0400
++++ b/config.mk 2010-06-21 01:30:35.615419264 +0400
+@@ -17,8 +17,8 @@
+ CFLAGS += -Wall -Wextra -pedantic
+
+ # Comment these out if you don't have libxinerama
+-xinerama = -DHAVE_LIBXINERAMA
+-xinerama_ld = -lXinerama
++# xinerama = -DHAVE_LIBXINERAMA
++# xinerama_ld = -lXinerama
+
+ debug = -DDEBUG
+ # Uncomment this for debug mode
diff --git a/recipes/feh/feh_1.7.bb b/recipes/feh/feh_1.7.bb
new file mode 100644
index 0000000000..b01e0f15bc
--- /dev/null
+++ b/recipes/feh/feh_1.7.bb
@@ -0,0 +1,17 @@
+SECTION = "x11/utils"
+DESCRIPTION = "feh is a fast, lightweight image viewer which uses imlib2."
+LICENSE = "MIT"
+DEPENDS = "virtual/imlib2 giblib jpeg virtual/libx11 libxext libxt"
+
+SRC_URI = "https://derf.homelinux.org/projects/feh/feh-${PV}.tar.bz2 \
+ file://noxinerama.patch"
+S = "${WORKDIR}/feh-${PV}"
+
+inherit autotools
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' PREFIX=/usr install-bin
+}
+
+SRC_URI[md5sum] = "59181976384d1f5bddae016b39334e2e"
+SRC_URI[sha256sum] = "13cd57ac8e97430ea7875d9e5d642166df4f1fb5884cc4523da84bcfe4fa6c56"