aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/file/file_4.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/file/file_4.18.bb')
-rw-r--r--recipes/file/file_4.18.bb15
1 files changed, 4 insertions, 11 deletions
diff --git a/recipes/file/file_4.18.bb b/recipes/file/file_4.18.bb
index a98c68009e..5433d3e9e6 100644
--- a/recipes/file/file_4.18.bb
+++ b/recipes/file/file_4.18.bb
@@ -1,22 +1,15 @@
-DESCRIPTION = "File attempts to classify files depending \
-on their contents and prints a description if a match is found."
-SECTION = "console/utils"
-LICENSE = "BSD-ADV"
-DEPENDS = "file-native"
+require file.inc
+
+PR = "${INCPR}.0"
SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
file://dump \
file://filesystems"
-S = "${WORKDIR}/file-${PV}"
-inherit autotools
+SRC_URI_append_virtclass-native = " file://native-fix.diff;patch=1"
do_configure_prepend() {
sed -i -e 's,$(top_builddir)/src/file,file,' ${S}/magic/Makefile.am
cp ${WORKDIR}/dump ${S}/magic/Magdir/
cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
}
-
-do_stage() {
- autotools_stage_all
-}