aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/flnx/flnx_0.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/flnx/flnx_0.17.bb')
-rw-r--r--recipes/flnx/flnx_0.17.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/flnx/flnx_0.17.bb b/recipes/flnx/flnx_0.17.bb
new file mode 100644
index 0000000000..e2db1358d8
--- /dev/null
+++ b/recipes/flnx/flnx_0.17.bb
@@ -0,0 +1,16 @@
+SECTION = "x11/libs"
+LICENSE = "LGPL"
+DEPENDS = "microwindows"
+RDEPENDS = "microwindows"
+SRC_URI = "ftp://ftp.microwindows.org/pub/microwindows/flnx/flnx-${PV}.tar.gz"
+DESCRIPTION = "fltk library for microwindows."
+
+inherit autotools
+
+EXTRA_OECONF = "--with-microwin=${STAGING_LIBDIR}/.."
+
+do_install () {
+ oe_runmake "bindir=${D}${bindir}" \
+ "libdir=${D}${libdir}" \
+ "includedir=${D}${includedir}" install
+}