aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/flnx
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/flnx')
-rw-r--r--recipes/flnx/flnx-0.18/gcc3.patch16
-rw-r--r--recipes/flnx/flnx_0.17.bb16
-rw-r--r--recipes/flnx/flnx_0.18.bb32
3 files changed, 64 insertions, 0 deletions
diff --git a/recipes/flnx/flnx-0.18/gcc3.patch b/recipes/flnx/flnx-0.18/gcc3.patch
new file mode 100644
index 0000000000..ba543b857a
--- /dev/null
+++ b/recipes/flnx/flnx-0.18/gcc3.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- flnx/src/Fl_Animator.cxx~gcc3 2003-08-07 17:18:39.000000000 -0400
++++ flnx/src/Fl_Animator.cxx 2004-02-26 16:28:03.000000000 -0500
+@@ -28,7 +28,7 @@
+
+ Fl_Animator::Fl_Animator(char * const *image, int X, int Y,
+ int fcount, int fwidth, int fheight,
+- int interval, const char *label = 0)
++ int interval, const char *label)
+ : Fl_Widget(X,Y,fwidth,fheight,label)
+
+ {
diff --git a/recipes/flnx/flnx_0.17.bb b/recipes/flnx/flnx_0.17.bb
new file mode 100644
index 0000000000..e2db1358d8
--- /dev/null
+++ b/recipes/flnx/flnx_0.17.bb
@@ -0,0 +1,16 @@
+SECTION = "x11/libs"
+LICENSE = "LGPL"
+DEPENDS = "microwindows"
+RDEPENDS = "microwindows"
+SRC_URI = "ftp://ftp.microwindows.org/pub/microwindows/flnx/flnx-${PV}.tar.gz"
+DESCRIPTION = "fltk library for microwindows."
+
+inherit autotools
+
+EXTRA_OECONF = "--with-microwin=${STAGING_LIBDIR}/.."
+
+do_install () {
+ oe_runmake "bindir=${D}${bindir}" \
+ "libdir=${D}${libdir}" \
+ "includedir=${D}${includedir}" install
+}
diff --git a/recipes/flnx/flnx_0.18.bb b/recipes/flnx/flnx_0.18.bb
new file mode 100644
index 0000000000..6f84247404
--- /dev/null
+++ b/recipes/flnx/flnx_0.18.bb
@@ -0,0 +1,32 @@
+SECTION = "x11/libs"
+DEPENDS = "microwindows"
+RDEPENDS = "microwindows"
+DESCRIPTION = "fltk library for microwindows."
+SRC_URI = "ftp://ftp.microwindows.org/pub/microwindows/flnx/flnx-${PV}-tar.gz \
+ file://gcc3.patch;patch=1"
+S = "${WORKDIR}/flnx"
+LICENSE = "LGPL"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-microwin=${STAGING_LIBDIR}/.."
+
+python do_fetch () {
+ import os
+ bb.build.exec_func("base_do_fetch", d)
+ if os.access(bb.data.expand("${DL_DIR}/flnx-${PV}-tar.gz", d), os.R_OK):
+ os.rename(bb.data.expand("${DL_DIR}/flnx-${PV}-tar.gz", d), bb.data.expand("${DL_DIR}/flnx-${PV}.tar.gz", d))
+}
+
+python do_unpack () {
+ src_uri = bb.data.getVar("SRC_URI", d)
+ src_uri = src_uri.replace("-tar", ".tar")
+ bb.data.setVar("SRC_URI", src_uri, d)
+ bb.build.exec_func("base_do_unpack", d)
+}
+
+do_install () {
+ oe_runmake "bindir=${D}${bindir}" \
+ "libdir=${D}${libdir}" \
+ "includedir=${D}${includedir}" install
+}