aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/free42/files/free42-bcd-gtk-only.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/free42/files/free42-bcd-gtk-only.patch')
-rw-r--r--recipes/free42/files/free42-bcd-gtk-only.patch100
1 files changed, 100 insertions, 0 deletions
diff --git a/recipes/free42/files/free42-bcd-gtk-only.patch b/recipes/free42/files/free42-bcd-gtk-only.patch
new file mode 100644
index 0000000000..571785f36f
--- /dev/null
+++ b/recipes/free42/files/free42-bcd-gtk-only.patch
@@ -0,0 +1,100 @@
+--- free42-orig/gtk/Makefile 2007-01-06 09:37:55.000000000 -0800
++++ free42gtk/gtk/Makefile 2007-09-02 23:54:34.000000000 -0700
+@@ -35,20 +35,14 @@
+ core_math2.o core_phloat.o core_sto_rcl.o core_tables.o \
+ core_variables.o
+
+-ifdef BCD_MATH
+ CXXFLAGS += -DBCD_MATH
+ SRCS += bcdfloat.cc bcd.cc bcdmath.cc
+ OBJS += bcdfloat.o bcd.o bcdmath.o
+ EXE = free42dec
+-else
+-EXE = free42bin
+-endif
+
+ $(EXE): $(OBJS)
+ $(CXX) -o $(EXE) $(LDFLAGS) $(OBJS) $(LIBS)
+
+-$(SRCS): symlinks
+-
+ .cc.o:
+ $(CXX) $(CXXFLAGS) -c -o $@ $<
+
+@@ -64,74 +58,18 @@
+ keymap.cc: keymap2cc keymap.txt
+ ./keymap2cc
+
+-symlinks:
+- ln -s ../common/free42.h
+- ln -s ../common/core_commands1.cc
+- ln -s ../common/core_commands1.h
+- ln -s ../common/core_commands2.cc
+- ln -s ../common/core_commands2.h
+- ln -s ../common/core_commands3.cc
+- ln -s ../common/core_commands3.h
+- ln -s ../common/core_commands4.cc
+- ln -s ../common/core_commands4.h
+- ln -s ../common/core_commands5.cc
+- ln -s ../common/core_commands5.h
+- ln -s ../common/core_commands6.cc
+- ln -s ../common/core_commands6.h
+- ln -s ../common/core_display.cc
+- ln -s ../common/core_display.h
+- ln -s ../common/core_globals.cc
+- ln -s ../common/core_globals.h
+- ln -s ../common/core_helpers.cc
+- ln -s ../common/core_helpers.h
+- ln -s ../common/core_keydown.cc
+- ln -s ../common/core_keydown.h
+- ln -s ../common/core_linalg1.cc
+- ln -s ../common/core_linalg1.h
+- ln -s ../common/core_linalg2.cc
+- ln -s ../common/core_linalg2.h
+- ln -s ../common/core_math1.cc
+- ln -s ../common/core_math1.h
+- ln -s ../common/core_math2.cc
+- ln -s ../common/core_math2.h
+- ln -s ../common/core_main.cc
+- ln -s ../common/core_main.h
+- ln -s ../common/core_phloat.cc
+- ln -s ../common/core_phloat.h
+- ln -s ../common/core_sto_rcl.cc
+- ln -s ../common/core_sto_rcl.h
+- ln -s ../common/core_tables.cc
+- ln -s ../common/core_tables.h
+- ln -s ../common/core_variables.cc
+- ln -s ../common/core_variables.h
+- ln -s ../common/shell.h
+- ln -s ../common/shell_loadimage.cc
+- ln -s ../common/shell_loadimage.h
+- ln -s ../common/shell_spool.cc
+- ln -s ../common/shell_spool.h
+- ln -s ../common/skin2cc.cc
+- ln -s ../common/skin2cc.conf
+- ln -s ../common/keymap2cc.cc
+- ln -s ../common/bcd.cc
+- ln -s ../common/bcd.h
+- ln -s ../common/bcdfloat.cc
+- ln -s ../common/bcdfloat.h
+- ln -s ../common/bcdmath.cc
+- ln -s ../common/bcdmath.h
+- touch symlinks
+-
+ clean: FORCE
+ rm -f `find . -type l` \
+ skin2cc skin2cc.exe skins.cc \
+ keymap2cc keymap2cc.exe keymap.cc \
+- *.o *.d *.i *.ii *.s symlinks core.*
++ *.o *.d *.i *.ii *.s core.*
+
+ cleaner: FORCE
+ rm -f `find . -type l` \
+ free42bin free42bin.exe free42dec free42dec.exe \
+ skin2cc skin2cc.exe skins.cc \
+ keymap2cc keymap2cc.exe keymap.cc \
+- *.o *.d *.i *.ii *.s symlinks core.*
++ *.o *.d *.i *.ii *.s core.*
+
+ FORCE:
+