summaryrefslogtreecommitdiffstats
path: root/recipes/freedoom
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freedoom')
-rw-r--r--recipes/freedoom/freedoom_0.3.bb28
-rw-r--r--recipes/freedoom/freedoom_0.6.2.bb27
2 files changed, 55 insertions, 0 deletions
diff --git a/recipes/freedoom/freedoom_0.3.bb b/recipes/freedoom/freedoom_0.3.bb
new file mode 100644
index 0000000000..daef13fc8a
--- /dev/null
+++ b/recipes/freedoom/freedoom_0.3.bb
@@ -0,0 +1,28 @@
+SECTION = "games"
+DESCRIPTION = "The Freedoom project aims at collaboratively creating a Free IWAD file.\
+ Combined with the Free source code, this results in a complete game \
+ based on the Doom engine which is Free Software."
+HOMEPAGE = "http://freedoom.sourceforge.net/"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "http://ovh.dl.sourceforge.net/sourceforge/freedoom/freedoom-iwad-0.3.zip"
+
+PR = "r1"
+
+FILES_${PN} = "/usr/share/games/doom/*"
+FILES_${PN}-doc = "/usr/share/doc/freedoom/*"
+
+do_install() {
+ install -d ${D}/usr/share/games/doom
+ install -d ${D}/usr/share/doc/freedoom
+
+ install -m 0644 ${WORKDIR}/freedoom-iwad-${PV}/doom2.wad ${D}/usr/share/games/doom/
+ install -m 0644 ${WORKDIR}/freedoom-iwad-${PV}/* ${D}/usr/share/doc/freedoom
+ rm ${D}/usr/share/doc/freedoom/*.wad
+
+
+
+
+}
+
diff --git a/recipes/freedoom/freedoom_0.6.2.bb b/recipes/freedoom/freedoom_0.6.2.bb
new file mode 100644
index 0000000000..0a3be04410
--- /dev/null
+++ b/recipes/freedoom/freedoom_0.6.2.bb
@@ -0,0 +1,27 @@
+SECTION = "games"
+DESCRIPTION = "The Freedoom project aims at collaboratively creating a Free IWAD file.\
+ Combined with the Free source code, this results in a complete game \
+ based on the Doom engine which is Free Software."
+HOMEPAGE = "http://freedoom.sourceforge.net/"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/freedoom/freedoom-iwad-${PV}.zip"
+
+PACKAGE_ARCH = "all"
+FILES_${PN} = "${datadir}/games/doom/*"
+FILES_${PN}-doc = "${datadir}/doc/freedoom/*"
+
+do_install() {
+ install -d ${D}/${datadir}/games/doom
+ install -d ${D}/${datadir}/doc/freedoom
+
+ install -m 0644 ${WORKDIR}/freedoom-iwad-${PV}/doom2.wad ${D}/${datadir}/games/doom/
+ install -m 0644 ${WORKDIR}/freedoom-iwad-${PV}/* ${D}/${datadir}/doc/freedoom
+ rm ${D}/${datadir}/doc/freedoom/*.wad
+
+
+
+
+}
+