aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/fsodeviced_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone/fsodeviced_git.bb')
-rw-r--r--recipes/freesmartphone/fsodeviced_git.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/recipes/freesmartphone/fsodeviced_git.bb b/recipes/freesmartphone/fsodeviced_git.bb
index e7ea1c0a6a..f00bcce381 100644
--- a/recipes/freesmartphone/fsodeviced_git.bb
+++ b/recipes/freesmartphone/fsodeviced_git.bb
@@ -1,19 +1,21 @@
require cornucopia.inc
inherit fso-plugin
-DEPENDS += "alsa-lib libcanberra libfsoresource"
-RDEPENDS += "libcanberra-alsa"
+DEPENDS += "alsa-lib libcanberra libfsoresource android-rpc"
+RDEPENDS_${PN} += "libcanberra-alsa"
# Included in fsodeviced itself now
-# RRECOMMENDS += "fso-alsa-data"
+# RRECOMMENDS_${PN} += "fso-alsa-data"
RPROVIDES_${PN} = "openmoko-alsa-scenarios virtual/alsa-scenarios"
+SRCREV = "cbd57abf8afaa95f78d22cf593577794ce9ed5b6"
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
-PV = "0.9.0+gitr${SRCPV}"
+PV = "0.9.4+gitr${SRCPV}"
PE = "2"
-PR = "${INC_PR}.12"
+PR = "${INC_PR}.15"
EXTRA_OECONF = "\
--enable-kernel26-rfkill \
--enable-player-canberra \
+ --enable-htcdream-powercontrol \
"
inherit update-rc.d