summaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/fsodeviced_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone/fsodeviced_git.bb')
-rw-r--r--recipes/freesmartphone/fsodeviced_git.bb13
1 files changed, 7 insertions, 6 deletions
diff --git a/recipes/freesmartphone/fsodeviced_git.bb b/recipes/freesmartphone/fsodeviced_git.bb
index 33f58d3d01..240794bb3c 100644
--- a/recipes/freesmartphone/fsodeviced_git.bb
+++ b/recipes/freesmartphone/fsodeviced_git.bb
@@ -1,19 +1,16 @@
require cornucopia.inc
inherit fso-plugin
-DEPENDS += "alsa-lib libcanberra libfsoresource android-rpc i2c-tools"
-RDEPENDS_${PN} += "libcanberra-alsa"
-# Included in fsodeviced itself now
-# RRECOMMENDS_${PN} += "fso-alsa-data"
+DEPENDS += "alsa-lib libfsoresource android-rpc i2c-tools"
RPROVIDES_${PN} = "openmoko-alsa-scenarios virtual/alsa-scenarios"
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
PV = "0.9.4+gitr${SRCPV}"
PE = "2"
-PR = "${INC_PR}.18"
+PR = "${INC_PR}.19"
EXTRA_OECONF = "\
--enable-kernel26-rfkill \
- --enable-player-canberra \
+ --disable-player-canberra \
--enable-htcdream-powercontrol \
"
@@ -24,6 +21,10 @@ INITSCRIPT_PARAMS = "defaults 27"
SRC_URI += "file://fsodeviced"
+do_configure_prepend() {
+ install ${STAGING_INCDIR}/linux/i2c-dev-user.h ${STAGING_INCDIR}/linux/i2c-dev.h
+}
+
CONFFILES_${PN} = "${sysconfdir}/freesmartphone/conf/openmoko_gta/fsodeviced.conf \
${sysconfdir}/freesmartphone/conf/palm_pre/fsodeviced.conf \
${sysconfdir}/freesmartphone/conf/htc_qualcomm_dream/fsodeviced.conf \