aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/illume-theme-freesmartphone_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone/illume-theme-freesmartphone_git.bb')
-rw-r--r--recipes/freesmartphone/illume-theme-freesmartphone_git.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/freesmartphone/illume-theme-freesmartphone_git.bb b/recipes/freesmartphone/illume-theme-freesmartphone_git.bb
new file mode 100644
index 0000000000..1351674a18
--- /dev/null
+++ b/recipes/freesmartphone/illume-theme-freesmartphone_git.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Illume theme for the freesmartphone.org project"
+HOMEPAGE = "http://illume.projects.openmoko.org/"
+LICENSE = "MIT/BSD"
+DEPENDS = "edje-native eet-native"
+PV = "0.1.0+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/artwork.git;protocol=git;branch=master"
+S = "${WORKDIR}/git/illume"
+
+do_compile() {
+ cd illume && ./build.sh && cd ..
+ cd illume_init && ./build.sh && cd ..
+ cd illume-config
+ eet -e e.cfg config e.src 1
+ eet -e module.battery.cfg config module.battery.src 1
+ eet -e module.illume.cfg config module.illume.src 1
+}
+
+do_install() {
+ install -d ${D}${sysconfdir}/enlightenment
+ install -d ${D}${datadir}/enlightenment/data/themes/
+ install -d ${D}${datadir}/enlightenment/data/init/
+ install -d ${D}${datadir}/enlightenment/data/config/fso/
+
+ # Make fso the default profile
+ echo 'E_PROFILE="-profile fso"' > ${D}${sysconfdir}/enlightenment/default_profile
+
+ install -m 0644 ${S}/illume/fso.edj ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/illume_init/fso_init.edj ${D}${datadir}/enlightenment/data/init/
+
+ install -m 0644 ${S}/illume-config/e.cfg ${D}${datadir}/enlightenment/data/config/fso/
+ install -m 0644 ${S}/illume-config/module.battery.cfg ${D}${datadir}/enlightenment/data/config/fso/
+ install -m 0644 ${S}/illume-config/module.illume.cfg ${D}${datadir}/enlightenment/data/config/fso/
+}
+
+RPROVIDES_${PN} = "illume-theme"
+CONFFILES_${PN} = "${sysconfdir}/enlightenment/default_profile"
+FILES_${PN} = "${sysconfdir}/enlightenment ${datadir}/enlightenment"
+
+PACKAGE_ARCH_${PN} = "all"
+