aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/mdbus_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone/mdbus_git.bb')
-rw-r--r--recipes/freesmartphone/mdbus_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/freesmartphone/mdbus_git.bb b/recipes/freesmartphone/mdbus_git.bb
new file mode 100644
index 0000000000..229ff7f1fd
--- /dev/null
+++ b/recipes/freesmartphone/mdbus_git.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Mickey's DBus introspection and calling Program"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+HOMEPAGE = "http://www.freesmartphone.org"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+PV = "0.9.2+gitr${SRCREV}"
+PR = "r2"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 mickeydbus/mdbus ${D}${bindir}
+}
+
+RDEPENDS_${PN} = "\
+ python-dbus \
+ python-pygobject \
+ python-pprint \
+ python-xml \
+"
+
+PACKAGE_ARCH_${PN} = "all"
+